Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

  1. #21
    Join Date
    Jun 2010
    Beans
    Hidden!

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    IF you are using a Radeon GPU on Lucid, try disabling Kernel Mode Setting (see https://wiki.ubuntu.com/X/KernelModeSetting ). According to bug reports, there are 2D&3D performance problems on (some) Radeon cards with KMS enabled. Personally, disabling KMS solved the problems with Youtube on my P4 2.4 Ghz with Radeon 9600.

    Do the following:

    Create a module configuration file with the following command:

    Code:
    sudo nano /etc/modprobe.d/radeon-kms.conf
    Copy the following line to the file:

    Code:
    options radeon modeset=0
    Save the file and restart the computer.

    The bug reports referenced:

    https://bugs.launchpad.net/ubuntu/+s...ox/+bug/562293 (See comment #2 and forwards)
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583653 (Lucid has backported KMS-related Xorg stuff from kernel 2.6.33, but anyway...)
    https://bugzilla.redhat.com/show_bug.cgi?id=557420 (not the same kernel version as in Ubuntu Lucid, but anyway...)


  2. #22
    Join Date
    Apr 2007
    Location
    Dublin
    Beans
    22
    Distro
    Ubuntu Development Release

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    I think this problem maybe relate to the graphic card driver. When I watch a flash video, the CPU usage goes up, but if I hide the browser behind another application windows (e.g. evolution), the CPU usage goes down to almost nothing.

  3. #23
    Join Date
    Jul 2010
    Beans
    62
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Red face Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    dude, i had the same problem, its fixed now.

    heres how i did it: reinstalled ubuntu 10.04

    you should try this first
    1. completely remove flash (apt-get purge? i think and autoremove, autoclean)
    2. configurations too
    3. reinstall flash

    if this fails

    reinstall ubuntu 10.04 or now the new 10.10

    i think there is/was a leak or somethin that they call it. I dont know the logic behind it, it was a miracle xD

    what happens wen you kill/end the process (flash) in system monitor? Because for me it restarted and worked fine for a while.

    by any chance, when you first installed ubuntu was it an earlier version and then upgrade? i.e. 8.04 --> 10.04 (cuz maybe u didnt want to burn another disk -> like me :/ )

    tell us how it goes if you still have this problem

  4. #24
    Join Date
    Jan 2009
    Beans
    4

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by Kurkha View Post
    IF you are using a Radeon GPU on Lucid, try disabling Kernel Mode Setting (see https://wiki.ubuntu.com/X/KernelModeSetting ). According to bug reports, there are 2D&3D performance problems on (some) Radeon cards with KMS enabled. Personally, disabling KMS solved the problems with Youtube on my P4 2.4 Ghz with Radeon 9600.

    Do the following:

    Create a module configuration file with the following command:

    Code:
    sudo nano /etc/modprobe.d/radeon-kms.conf
    Copy the following line to the file:

    Code:
    options radeon modeset=0
    Save the file and restart the computer.

    The bug reports referenced:

    https://bugs.launchpad.net/ubuntu/+s...ox/+bug/562293 (See comment #2 and forwards)
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583653 (Lucid has backported KMS-related Xorg stuff from kernel 2.6.33, but anyway...)
    https://bugzilla.redhat.com/show_bug.cgi?id=557420 (not the same kernel version as in Ubuntu Lucid, but anyway...)

    Wow! That made the world of difference! Thank you Kurkha. I am on a Pentium III 500 w/768 megs or ram and an old ATI card running 10.04. I was thinking it was just because of my old hardware... This is GREAT!! Haha!

  5. #25
    Join Date
    Jan 2009
    Beans
    4

    Smile Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by WhErEeVeR View Post
    Wow! That made the world of difference! Thank you Kurkha. I am on a Pentium III 500 w/768 megs or ram and an old ATI card running 10.04. I was thinking it was just because of my old hardware... This is GREAT!! Haha!
    Well, flash performance has not improved much but system performance has dramatically improved! Flash is a whole other issue I guess. At least now I can move my mouse smoothly across the screen.

  6. #26
    Join Date
    Jan 2006
    Beans
    21

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by Kurkha View Post
    IF you are using a Radeon GPU on Lucid, try disabling Kernel Mode Setting (see https://wiki.ubuntu.com/X/KernelModeSetting ). According to bug reports, there are 2D&3D performance problems on (some) Radeon cards with KMS enabled. Personally, disabling KMS solved the problems with Youtube on my P4 2.4 Ghz with Radeon 9600.

    Do the following:

    Create a module configuration file with the following command:

    Code:
    sudo nano /etc/modprobe.d/radeon-kms.conf
    Copy the following line to the file:

    Code:
    options radeon modeset=0
    Save the file and restart the computer.

    The bug reports referenced:

    https://bugs.launchpad.net/ubuntu/+s...ox/+bug/562293 (See comment #2 and forwards)
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583653 (Lucid has backported KMS-related Xorg stuff from kernel 2.6.33, but anyway...)
    https://bugzilla.redhat.com/show_bug.cgi?id=557420 (not the same kernel version as in Ubuntu Lucid, but anyway...)

    Thank you, this helped me a lot.
    Xorg CPU usage was going crazy while browsing some website on my PIV HT 3GHz. This workaround did put everything back to normal.

    Strange how some old bugs keep resurfacing updates after updates.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •