Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: LUCID - Low graphics mode with intel 945GME

  1. #11
    Join Date
    Jun 2005
    Beans
    74

    Re: LUCID - Low graphics mode with intel 945GME

    rlzaleski: The problem remains here (notebook DELL 6510 with Intel integrated graphics card). I have

    cribari@darwin:~$ dpkg -l | grep xserver | grep intel
    ii xserver-xorg-video-intel 2:2.12.0+git20100705~glasen~ppa1 X.Org X server -- Intel i8xx, i9xx display driver
    ii xserver-xorg-video-intel-dbg 2:2.12.0+git20100705~glasen~ppa1 X.Org X server -- Intel i8xx, i9xx display driver (debug symbols

    cribari@darwin:~$ dpkg -l | grep mesa-utils
    ii mesa-utils 7.7.1-1ubuntu3 Miscellaneous Mesa GL utilities

    cribari@darwin:~$ glxinfo | grep rendering
    direct rendering: Yes
    cribari@darwin:~$ glxinfo | grep OpenGL
    OpenGL vendor string: Mesa Project
    OpenGL renderer string: Software Rasterizer
    OpenGL version string: 2.1 Mesa 7.7.1
    OpenGL shading language version string: 1.20
    OpenGL extensions:

    I still get a blank screen when I boot the computer, unless I use the kernel option "i915.modeset=0".

    Suggestions are welcome.

  2. #12
    Join Date
    Aug 2010
    Beans
    2

    Re: LUCID - Low graphics mode with intel 945GME

    I've got this problem too.

    Code:
    (EE) intel(0): [drm] failed to set drm interface version.
    (EE) intel(0): Failed to become DRM master.
    DRM_IOCTL_I915_GEM_APERTURE failed: Bad file descriptor
    Assuming 131072kB available aperture size.
    May lead to reduced performance or incorrect rendering.
    get chip id failed: -1 [9]
    param: 4, val: 0
    (EE) intel(0): failed to get resources: Bad file descriptor
    (EE) Screen(s) found, but none have a usable configuration.
    
    Fatal server error:
    no screens found
    glxinfo just says that it's unable to open display.

  3. #13
    Join Date
    Mar 2008
    Beans
    189
    Distro
    Ubuntu

    Re: LUCID - Low graphics mode with intel 945GME

    Hi guys

    I have intel gma 4500M and i have this strange problem.Compiz and the graphic is really cool in gnome but if i "log in" in Openbox window manager (or when i use gnome without special effects), the windows behave strange - when i move them, the edges of windows are somewhat sticky and they are not smooth. I have a blank xorg.conf, though.

    Any suggestions?
    thx
    Let's open source the society!

  4. #14
    Join Date
    Aug 2009
    Beans
    1

    Re: LUCID - Low graphics mode with intel 945GME

    it did work!!
    as soon as the driver update, the display changed immediately!


    Quote Originally Posted by rlzaleski View Post
    I was getting the black screen when my comp booted to X. Normally Ubuntu is so good about video configuration I didn't even think drivers, but I guess the chipset in this 2 week old Dell desktop is too new, Oh well, that's the way of linux.

    Anyways, it's running good, to get it there I did the following.

    Code:
    sudo add-apt-repository ppa:glasen/intel-driver 
    sudo apt-get update && sudo apt-get upgrade
    I would also recommend you remove your xorg.conf as that's how I'm running, ubuntu/xorg will auto configure everything on startup.

    Code:
    sudo rm /etc/X11/xorg.conf
    Then reboot and hope for the best. Assuming that works, then double check things after you log in via

    Code:
    sudo apt-get install mesa-utils
    glxinfo
    You should get a whole bunch of text, the important lines are towards the top

    Code:
    ...
    direct rendering: Yes
    ...
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) G45/G43 GEM 20091221 2009Q4 x86/MMX/SSE2
    ...
    Note there's there's a server, client, and OpenGL vendor string, you want the OpenGL one. The Intel line may change a bit too. If that all works the last thing to do is

    Code:
    glxgears
    Which if you let it run for awhile and don't move the mouse, it'll calculate the FPS, I run it in it's default windowed size and maximized and I'm getting 4,800 and 300 FPS, which isn't bad.

    Hopefully this won't freak out again. Hope that helps someone.

  5. #15
    Join Date
    Jun 2006
    Beans
    8
    Distro
    Ubuntu 5.10

    Talking Re: LUCID - Low graphics mode with intel 945GME

    This didn't really solve my lowres woes, but it helped some. Thanks anyway.

    Here's my report, as posted at launchpad.net:
    Code:
    https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/532579
    Problem: Having installed Linux Mint 9 LXDE on an elderly HP Vectra VL400 workstation (PIII 1GHz, 512MB RAM, 20GB HDD), the graphic UI was available, but my maximum resolution would be 800x600x60Hz and I had no 'xorg.conf' file in '/etc/X11/'. Querying with lspci returned the following adapter identification:

    00:02.0 VGA compatible controller: Intel Corporation 82815 Chipset Graphics Controller (CGC) (rev 02)

    Thus began my two day ordeal. After searching high and low, reading leaft and right, a lot of brow wrinkling, pencil sucking, and hair pulling, I was exactly where I started, with zero results. I saw [... here] how this predicament could be solved by installing the latest libdrm, which I did to no avail. I even tried building a new xorg.conf by hand (as per http://forums.linuxmint.com/viewtopi...=58781#p336104), and failed miserably, attesting to the real depth of my noobiness. The system wouldn't even start, so I had to launch the livecd to delete that xorg.conf...

    But eventually that was the seed for the solution: after some more editing, including the Section "Module" suggested by TJ, I rebooted and everything automagically worked -- without further ado, I now have 1024x768x85Hz, which is rather more bearable to work with.

    Here's the healing xorg.conf:

    Code:
    ----- xorg.conf -----
    
    Section "Device"
    	Identifier	"Intel Corporation 82815 CGC"
    	Driver		"intel"
    #	Driver		"vesa"
    EndSection
    
    Section "Monitor"
    	Identifier	"Monitor0"
    	VendorName	"DEC"
    	ModelName	"VRT17-HA"
    	Option		"DPMS"
    	HorizSync	29-82
    	VertRefresh	50-150
    EndSection
    
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Intel Corporation 82815 CGC"
    	Monitor		"Monitor0"
    	DefaultDepth	16
    	SubSection "Display"
    		Depth	16
    		Modes	"1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "Server Layout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    EndSection
    
    Section "Module"
    	Load		"vesa"
    EndSection
    May it help others stuck with such a hairy problem. Now, I must solve the remaining ones...
    Last edited by Pnin; December 14th, 2010 at 10:12 AM. Reason: Add missing reference link...

  6. #16
    Join Date
    Jan 2008
    Location
    Kansas
    Beans
    545
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: LUCID - Low graphics mode with intel 945GME

    Quote Originally Posted by rlzaleski View Post
    I was getting the black screen when my ***p booted to X. Normally Ubuntu is so good about video configuration I didn't even think drivers, but I guess the chipset in this 2 week old Dell desktop is too new, Oh well, that's the way of linux.

    Anyways, it's running good, to get it there I did the following.

    Code:
    sudo add-apt-repository ppa:glasen/intel-driver 
    sudo apt-get update && sudo apt-get upgrade
    I would also re***mend you remove your xorg.conf as that's how I'm running, ubuntu/xorg will auto configure everything on startup.

    Code:
    sudo rm /etc/X11/xorg.conf
    Then reboot and hope for the best. Assuming that works, then double check things after you log in via

    Code:
    sudo apt-get install mesa-utils
    glxinfo
    You should get a whole bunch of text, the important lines are towards the top

    Code:
    ...
    direct rendering: Yes
    ...
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) G45/G43 GEM 20091221 2009Q4 x86/MMX/SSE2
    ...
    Note there's there's a server, client, and OpenGL vendor string, you want the OpenGL one. The Intel line may change a bit too. If that all works the last thing to do is

    Code:
    glxgears
    Which if you let it run for awhile and don't move the mouse, it'll calculate the FPS, I run it in it's default windowed size and maximized and I'm getting 4,800 and 300 FPS, which isn't bad.

    Hopefully this won't freak out again. Hope that helps someone.
    I followed these instructions and I think it made think it might have made things worse for me. How do I roll back to the default driver?

  7. #17
    Join Date
    Sep 2006
    Beans
    12

    Re: LUCID - Low graphics mode with intel 945GME

    Quote Originally Posted by rlzaleski View Post
    I was getting the black screen when my comp booted to X. Normally Ubuntu is so good about video configuration I didn't even think drivers, but I guess the chipset in this 2 week old Dell desktop is too new, Oh well, that's the way of linux.

    Anyways, it's running good, to get it there I did the following.

    Code:
    sudo add-apt-repository ppa:glasen/intel-driver 
    sudo apt-get update && sudo apt-get upgrade
    I would also recommend you remove your xorg.conf as that's how I'm running, ubuntu/xorg will auto configure everything on startup.

    Code:
    sudo rm /etc/X11/xorg.conf
    Then reboot and hope for the best. Assuming that works, then double check things after you log in via

    Code:
    sudo apt-get install mesa-utils
    glxinfo
    You should get a whole bunch of text, the important lines are towards the top

    Code:
    ...
    direct rendering: Yes
    ...
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) G45/G43 GEM 20091221 2009Q4 x86/MMX/SSE2
    ...
    Note there's there's a server, client, and OpenGL vendor string, you want the OpenGL one. The Intel line may change a bit too. If that all works the last thing to do is

    Code:
    glxgears
    Which if you let it run for awhile and don't move the mouse, it'll calculate the FPS, I run it in it's default windowed size and maximized and I'm getting 4,800 and 300 FPS, which isn't bad.

    Hopefully this won't freak out again. Hope that helps someone.

    This helped me after pulling hair for a couple hours.

    Thank you.

    Rich

  8. #18
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,713
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: LUCID - Low graphics mode with intel 945GME

    Old thread closed!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •