Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Lucid in Low-Graphics mode

  1. #1
    Join Date
    Mar 2009
    Location
    Ireland
    Beans
    362
    Distro
    Ubuntu 12.04 Precise Pangolin

    Exclamation Lucid in Low-Graphics mode

    Starting up Lucid, I get this error message:

    Code:
    (EE)NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the system's kernel log for additional error messages.
    
    ***Aborting***
    
    Screen(s) found, but none have a usable configuration.
    Can anyone work out what's wrong? I don't seem to have a file at /etc/X11/xorg.conf.

    I have a GeForce 220GT, and was using the driver from Hardware Drivers - it's called 'version current'.

    Thanks.

  2. #2
    Join Date
    Mar 2009
    Location
    Ireland
    Beans
    362
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Lucid in Low-Graphics mode

    Just to add - I was able to fix the issue temporarily by resetting the X config to default, and then reinstalling the driver. I did this before, though, so this issue is not solved.

    Cheers!

  3. #3
    Join Date
    May 2010
    Beans
    2

    Re: Lucid in Low-Graphics mode

    Same here... Lucid seems to be ok on my netbook (which installed easily, just like Koala), but I got a new laptop (a sony vaio pcg series - which is multi-processor) and I have tried every possible thiy ng to get it to recognize the display and then to use the proprietary drivers and - apart from being unsucessful (due to my limited linux skills when working with and understanding X and super-graphic stuff) have been frustrated with the lack of any apparent reliable fix for this... I have had to go to the absurd length of uninstalling and re-installing over a dozen times over the last 30 hours (which seems to take a lot longer than koala ever did, but that could be a problem on my end due to the multi-processors)... and have tried everything I could find code-wise... I'm at my wits end... if anyone else has a newer vaio and has experienced similar problems, please chime in... Also: I only really care because (during the alleatory periods when it does let me boot into full res X) the "margins" of the desktop are trimmed so that I can't use my new wonderful machine to have dozens of drag and droppable desktops open. IN the meantime, I;'m booting into CLI, and working on my stuff there... Totally not a huge deal (I've been using a netbook as my primary for months now), but... Sigh... I had such high hopes for this new notebook and its super humongous screen...

    Any help is truly appreciated...

  4. #4
    Join Date
    Feb 2005
    Location
    Oregon
    Beans
    496
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Lucid in Low-Graphics mode

    I've been getting this about 2/3's of boots (GT 240, current drivers [195.36.15]), ever since I added a second monitor.

    Still looking for a solution, apart from disconnecting the monitor or RMAing the card, the latter of which is growing more appealing. I have a 9600 GSO card that works just fine with the same driver and both monitors, but it's slightly slower and a lot louder, and I still use the other computer I have it in.

    What I've tried so far is exporting EDID information on both monitors and adding them to the device section my xorg.conf like so (only one monitor uses DVI):
    Option "ConnectedMonitor" "DFP-0,CRT-1"
    Option "CustomEDID" "DFP-0:/etc/X11/edid2.bin;CRT-1:/etc/X11/edid.bin"

    But then with the above options it crashes 100% of the time. If I specify only one monitor or the other, it does not crash at all, but then I only get that monitor. With the options commented out, it randomly either completely works for both monitors or it crashes.

    Update: Crashes went away when I made DFP-0 instead of CRT-1 my primary display. Not sure if the driver or card was to blame.

    Update 2: Nevermind. Just crashes much less frequently now.
    Last edited by dtfinch; May 18th, 2010 at 02:33 AM. Reason: update

  5. #5
    Join Date
    Mar 2009
    Location
    Ireland
    Beans
    362
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Lucid in Low-Graphics mode

    Just happened to me again. Solution was to reconfigure graphics to default, and then reboot, then reinstall the driver, then reboot again. This, however, is only a temporary fix.

  6. #6
    Join Date
    Mar 2009
    Location
    Ireland
    Beans
    362
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Lucid in Low-Graphics mode

    It has now happened twice since my last post. Can anyone help?

  7. #7
    Join Date
    May 2008
    Location
    Cluj, Romania
    Beans
    1,292

    Re: Lucid in Low-Graphics mode

    You MUST have an xorg.conf file if using other than OSS drivers.

    Install the driver and type:

    sudo nvidia-xconfig

    To set up your xorg.conf. If you see at the end of the output that it writes another file such as XF86something, rename that file to xorg.conf.

    @Dtfinch:

    When you want to set up yout monitors, first rename xorg.conf, run "sudo nvidia-xconfig" from a terminal, reboot, connect both monitors start the computer, log in, launch "gksudo nvidia-settings" in a terminal. Set up the monitors as you like, then click "save to X configuration file". You MUST launch the nvidia-settings with gksudo in front to be able to write to that file, simply launching the nvidia-settings will retain the settings only until you reboot/logout.

  8. #8
    Join Date
    Mar 2009
    Location
    Ireland
    Beans
    362
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Lucid in Low-Graphics mode

    I was wrong - I do have an xorg.conf. I'm still getting these errors though.

  9. #9
    Join Date
    Feb 2005
    Location
    Oregon
    Beans
    496
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Lucid in Low-Graphics mode

    Quote Originally Posted by gradinaruvasile View Post
    @Dtfinch:

    When you want to set up yout monitors, first rename xorg.conf, run "sudo nvidia-xconfig" from a terminal, reboot, connect both monitors start the computer, log in, launch "gksudo nvidia-settings" in a terminal. Set up the monitors as you like, then click "save to X configuration file". You MUST launch the nvidia-settings with gksudo in front to be able to write to that file, simply launching the nvidia-settings will retain the settings only until you reboot/logout.
    That's the first thing I did after connecting the 2nd monitor, having done it before. It works perfectly except for the random times that it fails during bootup.

    Another thing I've found is that when I get to the error, if I exit to the console and rerun gdm manually, it works, though I haven't tried enough times to be positive whether that's all the time or I've just been lucky.

    Relevant parts of /etc/X11/xorg.conf:
    Code:
    ...
    Section "Monitor"
        #this section was added when I ran nvidia-xconfig, but it skipped my DVI-connected monitor, like it didn't need a section.
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "ViewSonic VA2226w"
        HorizSync       30.0 - 82.0
        VertRefresh     50.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        #commented this out because it didn't help. Exported edid files from nvidia-xconfig
        #Option "ConnectedMonitor" "DFP-0,CRT-1"
        #Option "CustomEDID" "DFP-0:/etc/X11/edid2.bin;CRT-1:/etc/X11/edid.bin"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GT 240"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        #Initially just one metamode when problems started. Added others to fix fullscreen games.
        Option         "metamodes" "CRT: 1680x1050_60 +1680+0, DFP: 1680x1050_60 +0+0; CRT: NULL, DFP: 1680x1050_60 +0+0; CRT: NULL, DFP: 1440x900_60 +0+0; CRT: NULL, DFP: 1024x768_60 +0+0; CRT: NULL, DFP: 640x480_60 +0+0"
        SubSection     "Display"
            Depth       24
    	Modes "3360x1050" "1680x1050" "1440x900" "1024x768" "640x480"
        EndSubSection
    EndSection
    The error says to check the kernel log, but I've found no related errors in /var/log/kern.log, syslog, messages, dmesg, and nothing in Xorg.*.log apart from the original error.

    Code:
    (**) May 13 18:29:57 NVIDIA(0): Enabling RENDER acceleration
    (II) May 13 18:29:57 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
    (II) May 13 18:29:57 NVIDIA(0):     enabled.
    (EE) May 13 18:29:57 NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
    (EE) May 13 18:29:57 NVIDIA(0):     system's kernel log for additional error messages and
    (EE) May 13 18:29:57 NVIDIA(0):     consult the NVIDIA README for details.
    (EE) NVIDIA(0):  *** Aborting ***
    (II) UnloadModule: "nvidia"
    (II) UnloadModule: "wfb"
    (II) UnloadModule: "fb"
    (EE) Screen(s) found, but none have a usable configuration.

  10. #10
    Join Date
    Sep 2007
    Location
    Over thar
    Beans
    310
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Lucid in Low-Graphics mode

    what i have done as a temporary fix is to uninstall the current proprietary driver and install the old 173 driver. no low graphics mode with the old driver. hopefully this is fixed soon.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •