I had chosen automatic logon. Then updated to 10.04. During logout to change Desktop Environment/Session, I noticed that GDM login screen had an option for KDE session although I had not installed KDE. I got curious. So I tried it. System hangs. Restart does not help because somehow gdm proceeds to the KDE session although I did not choose it to be default session. So I had only CLI left.

I got over it by stopping gdm (/etc/init.d/gdm stop) and removing gdm and installing xdm. Anyway, what is the proper way? How to order desktop environment from CLI and/or where is the default desktop environment option written in a file?