Results 1 to 10 of 57

Thread: Wacom Graphire I serial and Lucid

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Location
    EU
    Beans
    133
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Question Wacom Graphire I serial and Lucid

    I have a Wacom Graphire I serial tablet, that was working well.
    After installing Lucid it stopped working completely. The tablet is not even listed as an X input device.

    Here I read that serial Wacom tablets are no longer supported. If this is true, this is a big &**&@#$ (which I would expect from a commercial OS company, but not in the open source world)!

    Is there some kind of workaround possible?

  2. #2
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom Graphire I serial and Lucid

    Hi gwi,

    I don't know about the workaround. Maybe adding the serial Wacom sections to xorg.conf and otherwise setting it up like old times, serial conf etc.? Without support in the code I'm dubious.

    The only update on serial tablets I've seen is the answer to this post: https://sourceforge.net/mailarchive/...xwacom-discuss

    So that's interesting. It looks like it wasn't a policy change but a lack of developer resources. My guess is Peter thought serial tablets are old enough that there aren't that many still around so why spend the time adding serial support for xf86-input-wacom? Many things with higher priority to do first.

  3. #3
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom Graphire I serial and Lucid

    Hi gwi,

    Just posted on linuxwacom-discuss is a link to a patch that purports to add serial wacom back into xf86-input-wacom! It was made against 0.10.6. It's by Sebastian Berthold and company. See: https://sourceforge.net/mailarchive/...xwacom-discuss So you should be able to download xf86-input-wacom, apply the patch, compile it and enable your tablet. How about that!

    The original patch the new patch is based on is here on Nuclear's blog: http://codelab.wordpress.com/2010/02/21/wacom-hacking/

    I downloaded both and looked at them. Looks like the real deal.
    Last edited by Favux; May 13th, 2010 at 12:37 AM.

  4. #4
    Join Date
    May 2010
    Beans
    4
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Wacom Graphire I serial and Lucid

    Hi Favux,

    I'm in the same boat as gwi, upgraded to lucid and now no serial tablet.. I got as far as downloading the source for xf86-input-wacom, and the patch file but all the sites I've been on that explain how to apply a patch file have been frustratingly vague. Any chance you could give a short step by step?

    I mean, my tablet is ancient by tech standards, but if I can save myself from having to spend 400 bones on a new one just to get it working with lucid that would be wonderful.


    *edit* Having the patch file in the same folder as the xf86-input-wacom-0.10.5 folder and running it results in "hunk failed" about 20 times.*edit*
    *edit2* got it to succeed just had to rename the xf86-input-wacom_0.10.5 folder to just xf86-input-wacom. Now all I have to do is compile and test. I'll post if it works *edit2*
    Last edited by turquoiserabbit; May 13th, 2010 at 10:22 PM.

  5. #5
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom Graphire I serial and Lucid

    Hi turquoiserabbit,

    Welcome to Ubuntu forums!

    I can sure understand not wanting to buy a new tablet when you already have a perfectly good one.

    OK, copy or move the patch into the downloaded xf86-input-wacom file, whether the unpacked 0.10.6 tar or the git clone. Then, for e.g., in a terminal:
    Code:
    cd Desktop
    
    cd xf86-input-wacom-0.10.6
    
    patch -p1 < xf86-input-wacom_git-20100511.patch
    I'm pretty sure that will work for you.

    Hope this helps.

  6. #6
    Join Date
    May 2010
    Beans
    4
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Wacom Graphire I serial and Lucid

    Well I managed to patch successfully, and compile and install but my tablet still isn't working. I'm getting this in my /var/log/Xorg.0.log:

    Code:
    (II) LoadModule: "wacom"
    (WW) Warning, couldn't open module wacom
    (II) UnloadModule: "wacom"
    (EE) Failed to load module "wacom" (module does not exist, 0)
    my xorg.conf still has the settings in it from before I updated to lucid. The wacom entries were commented out by the update, but I uncommented them all in again. Still nothing.

    Did you get it working gwi?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •