Page 1 of 6 123 ... LastLast
Results 1 to 10 of 55

Thread: Failed to load NVIDIA kernel module!

  1. #1
    Join Date
    May 2010
    Beans
    29

    Exclamation Failed to load NVIDIA kernel module!

    My nvidia graphics driver was updated last night, and since then I've been unable to get into Gnome without resorting to low graphics mode. I'm pretty new to Ubuntu, though I have extensive knowledge of Windoze systems. Upon boot up, I get the following error:

    (EE) NVIDIA(0): Failed to load NVIDIA kernel module!
    (EE) NVIDIA(0): *** Aborting ***
    (EE) Screen(s) found, but none have a usable configuration

    I've tried some troubleshooting, including attempting to uninstall all nvidia drivers and reinstall (via synaptic).

    Administration->Hardware Drivers reports that version 173 is installed loaded and active. Nvidia X Server Settings (nvidia-settings) gives me the "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server." error.

    I've tried the nvidia-xconfig (both with gdm up and down) and it hasn't made any difference.

    Oh, it's a GeForce 6200 wwith two Dell E193FPp monitors running on Ubuntu 10.04.

    Here's my xorg.conf:

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder75) Fri Mar 12 01:42:27 PST 2010

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    I would appreciate any assistance offered to help me resolve this issue. Thanks in advance.

  2. #2
    Join Date
    May 2010
    Beans
    29

    Re: Failed to load NVIDIA kernel module!

    Bump

  3. #3
    Join Date
    May 2010
    Beans
    Hidden!

    Re: Failed to load NVIDIA kernel module!

    Can you load the NVIDIA module with

    Code:
    sudo modprobe nvidia

  4. #4
    Join Date
    May 2010
    Beans
    29

    Re: Failed to load NVIDIA kernel module!

    Quote Originally Posted by notceecee View Post
    Can you load the NVIDIA module with

    Code:
    sudo modprobe nvidia
    No luck.


    sudo modprobe nvidia
    [sudo] password for davin:
    FATAL: Module nvidia not found.

  5. #5
    Join Date
    May 2010
    Beans
    Hidden!

    Re: Failed to load NVIDIA kernel module!

    Is the NVIDIA driver installed when you tried that?

  6. #6
    Join Date
    May 2010
    Beans
    29

    Re: Failed to load NVIDIA kernel module!

    I believe so. Below is a screenshot of Hardware Drivers and nvidi X Server configuration
    Attached Images Attached Images

  7. #7
    Join Date
    Mar 2007
    Location
    Pensacola, Fl
    Beans
    1,055
    Distro
    Xubuntu 11.04 Natty Narwhal

    Re: Failed to load NVIDIA kernel module!

    Quote Originally Posted by DavinA View Post
    I believe so. Below is a screenshot of Hardware Drivers and nvidi X Server configuration
    I think this might be due to a mismatch between the kernel module version and the version in userspace used by the driver. I noticed in your last screenshot you are not using the recommended driver. Is there any particular reason why? I would try enabling the driver that says recommended and then restart the computer. If that fails, then we can try to ensure you have the proper kernel source for the version of the driver you are running.

    Out of curiosity, did you upgrade from 9.10 to 10.04, or is this a fresh install?
    Stop Trusted Computing! http://www.cl.cam.ac.uk/~rja14/tcpa-faq.html
    Asus Rampage 2 Extreme/2.66GHz i7 Quad/6GB DDR3 1600MHz 8-8-8-24/2x Nvidia 9800GTX+
    2x150GB 10krpm HD/2x1TB 7200RPM HD/3ware RAID/
    Xubuntu 11.04/Arch Linux/Gentoo Linux/Fedora

  8. #8
    Join Date
    May 2010
    Beans
    Hidden!

    Re: Failed to load NVIDIA kernel module!

    Uninstall the driver and install it through a terminal

    Code:
    sudo apt-get install nvidia-173
    Check if any errors pop out.

  9. #9
    Join Date
    May 2010
    Beans
    29

    Re: Failed to load NVIDIA kernel module!

    This is an upgrade from 9.10. 9.10 was fresh.

    I switched back to 173 from recommended earlier in an attempt to "roll back" the driver, with no luck. I'll try re-enabling the recommended driver and rebooting now, then post my results.

  10. #10
    Join Date
    May 2010
    Beans
    29

    Re: Failed to load NVIDIA kernel module!

    but i'll try the apt-get 1st.

Page 1 of 6 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •