Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 38

Thread: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

  1. #21
    Join Date
    Nov 2006
    Beans
    22

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    After much installing and trying other drivers my Lucid sytem kept freezing up, so i am using crunchbang now, which i used before installing my touchscreen.

    The touchscreen is working good sofar, at least no freezing which my Ubuntu Lucid just kept doing. The only thing is the calibration numbers wont stick. The commands of the first post worked great, but i after each reboot i have to give the command seperatly.
    Anyone know how to keep these after reboot?

  2. #22
    Join Date
    Jun 2010
    Beans
    1

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Hi all,
    I have a Gigabyte T1028X with the eGalax touchscreen. I just installed a fresh install of Lucid on it. I have tried everything in this post to set it up, however whenever I touch the screen the cursor flits around in seeming random patterns.

    Thanks in advance,
    Enoch

  3. #23
    Join Date
    Mar 2006
    Beans
    45

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    @border: Thank you very much, solved the problem with my samsung nc10 + eGalax touchscreen with
    Once again I installed evtouch:
    Code:
    ~$ sudo apt-get install xserver-xorg-input-evtouch
    Then created the Xorg config file:
    Code:
    ~$ sudo gedit /usr/lib/X11/xorg.conf.d/11-touchscreen.conf
    Code:
    Section "InputClass"
    	Identifier "Touchkit Touch"
    	MatchIsTablet	"on"
    	MatchDevicePath "/dev/input/event*"
    	Driver 	"evtouch"
    	Option	"ReportingMode"	   "Raw"
    	Option	"Emulate3Buttons"
    	Option	"Emultate3Timeout"  "50"
    	Option	"SendCoreEvents"    "On"
    	Option	"TapTimer"	    "90"
    	Option	"LongTouchTimer"    "150"
            Option  "MinX"              "108"
            Option  "MinY"              "124"
            Option  "MaxX"              "1835"
            Option  "MaxY"              "1970"
    #	Option  "Calibrate"         "1"
    	Option  "SwapX"	            "1"
    	Option	"SwapY"		    "1"
    	Option	"Rotate"	    "ccw"
    EndSection
    I had to rotate the screen orientation using the "Rotate" option and to calibrate one time with the calibration tool included in the latest evtouch-package (http://www.conan.de/touchscreen/evtouch.html) as my old values did not work anymore.

    Now the screen works fine for 4 days, surviving suspend/resume/reboot - no problems until now.

    Easystroke works great, now I have to figure out some good values for tap timing, I'd prefer the touchscreen to recognize a touch immediately AND beeing able to initiate a right-mouse-click - with TapTimer 90 this is nearly impossible...

    After this I'll finally think about my planned NC10/Tablet mod again...

    Thank you very much
    Ubuntu Lucid Lynx @ 10,4" Travelmate C110 TabletPC, 1Ghz, 1.5GB RAM, no fan
    Ubuntu Lucid Lynx @ Samsung NC10, Touchscreen

  4. #24
    Join Date
    Jun 2010
    Location
    Russia
    Beans
    11
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Quote Originally Posted by border View Post
    So here's the configuration I added to /usr/lib/X11/xorg,conf.d:
    file name 11-touchkit.conf

    Code:
    Section "InputClass"
    ...
    	Option	"MaxX"			"3973"
    ...
    EndSection
    I've tried some values for more precize X axis positioning and discovered MaxX value 3950 (for Q1 Ultra). Now cursor is exactly at stylus position at the right side of the screen.

  5. #25
    Join Date
    Mar 2006
    Beans
    45

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Must correct myself again - TOuchscreen DID work for some days, right after my last post I tried to finetune the calibration and now the screen does not do anything anymore
    I think I give up on this...
    Ubuntu Lucid Lynx @ 10,4" Travelmate C110 TabletPC, 1Ghz, 1.5GB RAM, no fan
    Ubuntu Lucid Lynx @ Samsung NC10, Touchscreen

  6. #26
    Join Date
    Jan 2010
    Location
    Brisvegas, QLD, AU
    Beans
    13
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Quote Originally Posted by border View Post
    I looked at that link, and it's obvious that it does not work in 10.04 since hal is not used anymore (deprecated) and since they use hal rules inthere...

    But I adapted it to 10.04 (with xorg.conf.d) and it works for my touchscreen!!!
    I have a Samsung Q1 ultra. My touchscreen is a
    ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen
    as reported by lsusb
    and udev reports it as Touchkit Touch (that's how I found it in Xorg.0.log)

    So here's the configuration I added to /usr/lib/X11/xorg,conf.d:
    file name 11-touchkit.conf

    Code:
    Section "InputClass"
    	Identifier "Touchkit Touch"
    	MatchIsTablet	"on"
    	MatchDevicePath "/dev/input/event*"
    	Driver 	"evtouch"
    	Option	"ReportingMode"	"Raw"
    	Option	"Emulate3Buttons"
    	Option	"Emultate3Timeout"	"50"
    	Option	"SendCoreEvents"	"On"
    	Option	"TapTimer"		"200"
    	Option	"LongTouchTimer"	"400"
    	Option	"MinX"			"145"
    	Option	"MinY"			"193"
    	Option	"MaxX"			"3973"
    	Option	"MaxY"			"3898"
    EndSection
    I got those evtouch options out of an old xorg.conf file from a configuration package specially made for a q1ultra which existed in the ubuntu 8.04 time.
    And now it runs perfectly!!!
    I also calibrated it using the utility in the first post, but I don't think that was necessary.

    Thanks everybody for your contributions
    I'm glad I got everything together finally
    And I hope that it can be of use to anyone

    Edit: To be clear to anyone, I also was troubled by the cursor stuck in upper left corner 'bug' after clicking once. So I can advice everyone with that problem to install xserver-xorg-input-evtouch and add a file like mine to the directory xorg.conf.d
    Thanks Border! This has now fixed my jump to corner behaviour on my T1028x. Now I have a reasonably working touchscreen.

    However! Using my stylus the touch screen is accurate in the centre of the screen then it slowly tends to accelerate faster than I move the stylus in any direction from there.

    i.e. Going right from the centre with the stylus the pointer slowly gets further and further to the right of the stylus itself.

    EDIT: I tried the calibration tool at the start of this thread and created a udev rule, it changed nothing.
    I also remember the 9.10 UNR had a touch screen calibration option under the Administration menu which had 9 point calibration.

    I'm pretty sure the only issue now is calibration now.
    Last edited by aeqel; June 23rd, 2010 at 03:46 AM.

  7. #27
    Join Date
    Jun 2009
    Beans
    9

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    For me and my Q1 naugtur's original solution (see first post) worked perfectly

    To call xinput every time the system initialises, I added the "xinput ..." line to the graphical Startup Programs manager (in Mint; I bet there's a similar thing in Ubuntu).

    Works good, but would there be a way to run this straight when X initialises, some setting or script? As I have it now, the correct calibration does not get set until after login.

  8. #28
    Join Date
    Aug 2010
    Beans
    1

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Has anyone managed to get the eGalax screens working properly? I just recently put one in my Asus Eee 1005HAB. I was able to install the eGalax driver without any problem. I was even able to calibrate with their tool. It took running the eGalaxTouch tool as root for it to work correctly. When I wasn't running it as root, it would let me get through a few points and then just completely crash, leaving an error in the terminal.

    The calibration seems to have worked fine, but I still have one remaining issue. The whole thing where everyone says the cursor jumps to the top-left of the screen. I got that before the calibration and, although I can touch and move the cursor where I want, it jumps at that top left with every tap, causing it to think i'm doing a drag and highlighting text, icons, etc...

    I'm assuming this is just left over from what was originally there on a clean install. Is there any way to remove that? I'm not a noob, but i'm no pro either. Hopefully I can be of some use if anyone needs to know specifics on how I got this far at least.

  9. #29
    Join Date
    Jun 2010
    Location
    Russia
    Beans
    11
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Read the thread above. http://ubuntuforums.org/showpost.php...77&postcount=9 solves this problem for Samsung Q1 Ultra, it might suite you too.

  10. #30
    Join Date
    Nov 2005
    Location
    near Boston, MA, USA
    Beans
    12
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    I've just been through the whole eGalax journey with a Xenarc 700TSV display. This thread (and some others) was a major part of my finally getting it working (after an entire day of trying things). I'm writing this to summarize what worked for me on an Asus EB1501, running Lucid 10.4 with the Xenarc display. My system also has a USB/Bluetooth mouse and keyboard. The mouse is extra helpful while trying to get things working, and seems to coexist well with the touchscreen.

    The key steps were:
    - downloading the beta Linux driver (3.03.4510 at this time) from the EETI website:
    http://home.eeti.com.tw/web20/eGalax...inuxDriver.htm
    - running the unmodified setup.sh script with sudo
    - rebooting
    - running the eGalaxTouch command after rebooting and selecting USB and disabling right click
    - running the TKCal command and doing a 4-point calibration
    - running xinput -list and note that there were two eGalax input sources
    - adding a startup program: xinput -set-prop "eGalax Inc. Touch" "Device Enabled" 0

    Disabling the second eGalax input device was the key to eliminating the upper-left pointer issue. I'm still working to determine exactly where to run this command during startup, as it sometimes seems to lose its effect, but rerunning it *always* removes the upper-left pointer problem.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •