Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: 9.10, 10.04 Random Memory Leak

  1. #1
    Join Date
    Mar 2010
    Beans
    36

    9.10, 10.04 Random Memory Leak

    I keep having a memory usage problem. This occurred randomly every once in a while in 9.10 and just happened again in 10.04.
    What happens is, when I turn the computer on, right after I log in, I'll notice it takes an abnormally long time for the desktop to appear. When I check memory usage in gnome-system-monitor, the system will be using ~350 MB of memory, about 100-200 more than usual, which is a lot considering I only have 480 MB total. Plus, it will be using some 80 MB of swap. However, there is no program using more memory than usual in the processes tab.
    Because of the amount of swapping being done (despite having some 100 MB of RAM left), all programs run slowly (very slowly) and make the system nearly unusable. Once it even froze with only 3 programs open, forcing me to hold in the power button for 5 seconds to force-kill it.
    Rebooting the computer always solves the memory usage problem.
    I do not believe this is the xorg memory leak frequently discussed because the high memory usage comes right when I start up. I only have the computer on for several hours at a time and the memory usage doesn't noticeably increase during that time period.
    Checking the log files does not immediately show me anything, though I have no idea what to look for.
    Other sources hint it may have something to do with closed-source video drivers, so I've included my card info here.
    sudo lshw -C video:
    Code:
      *-display               
           description: VGA compatible controller
           product: 82865G Integrated Graphics Controller
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 02
           width: 32 bits
           clock: 33MHz
           capabilities: pm bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:16 memory:f0000000-f7ffffff(prefetchable) memory:fe780000-fe7fffff ioport:ec00(size=8)
    sudo hwinfo --gfxcard
    Code:
    11: PCI 02.0: 0300 VGA compatible controller (VGA)              
      [Created at pci.318]
      UDI: /org/freedesktop/Hal/devices/pci_8086_2572
      Unique ID: _Znp.6KAz8n86w0D
      SysFS ID: /devices/pci0000:00/0000:00:02.0
      SysFS BusID: 0000:00:02.0
      Hardware Class: graphics card
      Model: "Intel 865 G"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x2572 "865 G"
      SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
      SubDevice: pci 0x80a5 "P5P800-MX Mainboard"
      Revision: 0x02
      Driver: "i915"
      Driver Modules: "drm"
      Memory Range: 0xf0000000-0xf7ffffff (rw,prefetchable)
      Memory Range: 0xfe780000-0xfe7fffff (rw,non-prefetchable)
      I/O Ports: 0xec00-0xec07 (rw)
      IRQ: 16 (123845 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v00008086d00002572sv00001043sd000080A5bc03sc00i00"
      Driver Info #0:
        XFree86 v4 Server Module: intel
      Driver Info #1:
        XFree86 v4 Server Module: intel
        3D Support: yes
        Extensions: dri
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    
    Primary display adapter: #11
    Hope that helps.
    Last edited by charlie cat; May 21st, 2010 at 08:23 PM. Reason: Reworded slightly

  2. #2
    Join Date
    Mar 2010
    Beans
    36

    Re: 9.10, 10.04 Random Memory Leak

    Just happened again today. This time, I'm fairly sure there were no problems before the login; however, as soon as I logged in, I could tell something was wrong. Could this be something in GNOME?

  3. #3
    Join Date
    Apr 2009
    Location
    Houston, TX
    Beans
    916
    Distro
    Ubuntu Development Release

    Re: 9.10, 10.04 Random Memory Leak

    I don't really have much of a suggestion for you other than to try out Puppy Linux, which uses Ubuntu, and has just released their version using 10.04 just recently. It is designed to work better with less resources, i.e. older hardware, less RAM, etc.
    Earl S. Sharp----------------------------------------
    Ubuntu User # 27653 |Linux user # 491157 | LPI # 183649
    Please mark threads as solved...

  4. #4
    Join Date
    Jul 2005
    Location
    Melbourne, Australia
    Beans
    40
    Distro
    Ubuntu Karmic Koala (testing)

    Re: 9.10, 10.04 Random Memory Leak

    I have the same problem with 10.04 on an eeePC with 1Gb RAM.

    Start the system to esktop, and it's already using ~360Mb RAM. Within a few minutes of sitting idle, it's up to ~480Mb. Give it 10-15mins and it's using ~980Mb and starting to much away at disk swap.

    I have ensured all non-essential services are not active for startup, and even removed any fstab connections to ensure it is not that. It must fundamentally be at the core of Ubuntu 10.04.

    Memory is leaking like a sieve.

    It's a LARGE problem with Ubuntu 10.04 too....

    http://ubuntuforums.org/showthread.php?t=1471320
    http://ubuntuforums.org/showthread.php?t=1477988
    http://ubuntuforums.org/showthread.php?t=1471400
    http://ubuntuforums.org/showthread.php?t=1488493
    http://ubuntuforums.org/showthread.php?t=1489741

    I'm happy to work with someone to diagnose, but just don't know what sort of data reporting I can provide that will be helpful.

    Thanks.

  5. #5
    Join Date
    Mar 2005
    Location
    Sweden, Uppsala
    Beans
    867
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 9.10, 10.04 Random Memory Leak

    Do you have checked 'all processes' under View in 'System monitor' and what do you look at, when you conclude that no processes use more memory than normal? 'Virtual meemory', 'X-server memory' or Memory?

    /Cheers
    /Azyx

    Ubuntu 12.04LTS 64bit, 13.10 Lubuntu 32-bit on eeePCs and OSX on a G4 800MHz iMac (iLamp). I think I have an W7 on one of my Virtualbox machine under 12.04LTS?

  6. #6
    Join Date
    Sep 2007
    Location
    Malaysia
    Beans
    280
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: 9.10, 10.04 Random Memory Leak

    Hey, I have a similar problem with my computer, I am running with 2gb ram. Everytime I log in, ubuntu takes a few extra seconds just to load the wallpaper, panel, and the desktop icons. The first thing that starts up is actually the awn dock manager. It's not a BIG problem for me, but reading this post, I think it might be related to your issue.

    Also, you should try removing some of the processes and programs from startup, the ones you don't use. For example, for me, I remove the bluetooth manager and CUPS, since I don't have bluetooth on my desktop and I don't use a printer. It helps, but really, all in all for my case its not that big of an issue, cause once the desktop is loaded, everything is silky smooth. =)

    I think for me it might be fstab mounting my partitions that causes the slight delay, but who knows.

  7. #7
    Join Date
    Mar 2010
    Beans
    36

    Re: 9.10, 10.04 Random Memory Leak

    Thanks, Azyx. I never realized gnome-resource-monitor wasn't showing all processes. I'll have to see what happens next time I have this memory error.
    Also, I already have unchecked unnecessary processes from the startup list - in fact, when I first installed 10.04, I came close to unchecking stuff that I now realize are probably important!
    However, Mouth, I don't think your problem is the same as mine. I've never noticed a substantial increase in memory while the computer was running - if any, it was maybe 50 MiB. I'll look at some of those links though.

  8. #8
    Join Date
    Oct 2009
    Beans
    20

    Re: 9.10, 10.04 Random Memory Leak

    I have noticed this too

    A reboot cleans it up and keeps the RAM usage down for a couple of days for me.

    HTH
    Mal
    Last edited by Mal Bridgeman; May 26th, 2010 at 09:55 AM. Reason: ooops!

  9. #9
    Join Date
    Apr 2008
    Location
    London
    Beans
    1,873
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: 9.10, 10.04 Random Memory Leak

    I think I have a memory leak in Lucid as well. The RAM usage starts off quite high ~700MB and over the course of a few hours it goes up. It was over 1GB in my last session with only Firefox open - something I've never seen before.

    There's nothing obvious in top or htop, the RAM just increases over time. It doesn't cause me any performance issues though.

    .

  10. #10
    Join Date
    May 2010
    Location
    Faisalabad
    Beans
    1
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 9.10, 10.04 Random Memory Leak

    Don't know if this is something related to the memory leak or may be it's just a feature I don't understand, but 'top' and 'gnome-system-monitor' report different memory statistics.

    And I also have the memory issue. A couple of hours (1 or 2) of continued usage makes the memory usage go up to around 960 MB or so and the system becomes almost unusable. I don't think this is a Xorg issue, as the memory usage for the Xorg process is shown to be quite low when seen using 'top'.

    An image of the difference between the memory stats of 'top' and GSM is attached.
    MemError.jpg

    I'm using Ubuntu 10.04. 'uname -r' gives: 2.6.32-22-generic
    I'd really like to help diagnose this problem in any way I can.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •