Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Ubuntu 10.04 LTS Desktop - No network connection

  1. #1
    Join Date
    May 2010
    Beans
    4

    Ubuntu 10.04 LTS Desktop - No network connection

    I recently installed Ubuntu 10.04 on my Compaq Presario X6000. Since then. I have been struggling to get either wired or wireless network up on it. This is my first serious attempt at installing and setting up a laptop with a Linux distro. Could somebody please help?

    Here's the output of lspci -
    00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 04)
    00:01.0 PCI bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL PCI Express Root Port (rev 04)
    00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
    00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
    00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
    00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
    00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
    00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
    00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
    00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
    00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
    00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
    00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
    01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]
    0b:00.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
    0b:00.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
    0b:00.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
    0b:00.4 SD Host controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller
    0b:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    0b:03.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

    Thanks
    Ashish

  2. #2
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Ubuntu 10.04 LTS Desktop - No network connection

    A couple more things to check/post (from a terminal):
    sudo lshw -C network
    ifconfig -a
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  3. #3
    Join Date
    May 2010
    Beans
    4

    Re: Ubuntu 10.04 LTS Desktop - No network connection

    Thanks Iowan!
    Here's the result of running those commands :
    lshw -
    *-network:0
    description: Ethernet interface
    product: RTL-8139/8139C/8139C+
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 2
    bus info: pci@0000:0b:02.0
    logical name: eth0
    version: 10
    serial: 00:c0:9f:8e:52:82
    size: 10MB/s
    capacity: 100MB/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10MB/s
    resources: irq:20 ioport:5000(size=256) memory:c8209400-c82094ff
    *-network:1
    description: Network controller
    product: BCM4306 802.11b/g Wireless LAN Controller
    vendor: Broadcom Corporation
    physical id: 3
    bus info: pci@0000:0b:03.0
    version: 03
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master
    configuration: driver=b43-pci-bridge latency=64
    resources: irq:17 memory:c8206000-c8207fff
    *-network DISABLED
    description: Wireless interface
    physical id: 2
    logical name: wlan0
    serial: 00:90:4b:a6:17:16
    capabilities: ethernet physical wireless
    configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg
    ------------------------------------------------------------------------------------------
    ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:c0:9f:8e:52:82
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:20 Base address:0x5000

    eth0:avahi Link encap:Ethernet HWaddr 00:c0:9f:8e:52:82
    inet addr:169.254.8.123 Bcast:169.254.255.255 Mask:255.255.0.0
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    Interrupt:20 Base address:0x5000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:652 errors:0 dropped:0 overruns:0 frame:0
    TX packets:652 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:52032 (52.0 KB) TX bytes:52032 (52.0 KB)

    pan0 Link encap:Ethernet HWaddr de:5b:0b:16:a5:5d
    BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    wlan0 Link encap:Ethernet HWaddr 00:90:4b:a6:17:16
    BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    Thanks
    Ashish

  4. #4
    Join Date
    Aug 2009
    Location
    Montreal, Quebec, CANADA
    Beans
    266
    Distro
    Lubuntu 12.04 Precise Pangolin

    Lightbulb Re: Ubuntu 10.04 LTS Desktop - No network connection

    You may need to install the Realtek drivers, available HERE:
    http://www.opendrivers.com/company/2...-download.html

    HTH...
    "You only live once: let's make life better for each other."
    Asus EEE 1000 Dual-Atom 1.6 GHz.Ubuntu 12.10
    Registered Linux User #193975

  5. #5
    Join Date
    May 2010
    Beans
    4

    Re: Ubuntu 10.04 LTS Desktop - No network connection

    Thanks eltonw!
    I did not find an RTL8139 driver for Linux in that list. Am I missing something?

    ~Ashish.

  6. #6
    Join Date
    May 2010
    Beans
    4

    Re: Ubuntu 10.04 LTS Desktop - No network connection

    Hi
    Do I need to provide any other information? Have still not been able to locate a suitable RTL driver for ubuntu. Any suggestions??

    ~Ashish

  7. #7
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Ubuntu 10.04 LTS Desktop - No network connection

    Dunno if there's a newer/better driver than the 8139too that you system is currently using. This is an old thread, but there's an interesting tidbit near the end.
    Quote Originally Posted by Ehtetur View Post
    Finally, I took a look at System --> Preferences --> Sessions... Bluetooth Manger was enabled... my desktop doesn't have bluetooth so I disabled it..
    After rebooting, I got on the network fine.
    Last edited by Iowan; May 10th, 2010 at 10:24 PM.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  8. #8
    Join Date
    Nov 2004
    Location
    Charlotte, NC, USA
    Beans
    208
    Distro
    The Feisty Fawn Testing

    Re: Ubuntu 10.04 LTS Desktop - No network connection

    I'm having the same problem with this chipset. I posted one potential solution that didn't work for me in another thread. Maybe you'll have better luck?

  9. #9
    Join Date
    Nov 2004
    Location
    Charlotte, NC, USA
    Beans
    208
    Distro
    The Feisty Fawn Testing

    Re: Ubuntu 10.04 LTS Desktop - No network connection

    Bump.

  10. #10
    Join Date
    Dec 2006
    Location
    Australia
    Beans
    69
    Distro
    Lubuntu 13.10 Saucy Salamander

    Re: Ubuntu 10.04 LTS Desktop - No network connection

    Seems a very similar problem to the one I'm having here.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •