I have been running Ricardo Salvetri's patched kernel which enabled my LUCID installation to reliably connect to the wifi network. Today, Update Manager popped up with a list of updates. I downloaded and applied all that were available.


BIG MISTAKE!! I should have de-selected the 2.6.22.22/23 kernel. Thankfully, I managed to re-install the salvetri patched kernel. [linux-image-2.6.32-21-generic_2.6.32-21.32rsalveti1_i386.deb] which got me back online.

I am currently connected using the 2.6.33 kernel. As such, I would advise other Asus EEE owners / notebook owners or others with connection problems to steer clear of the 2.6.22.** series.

REFERENCES:

http://ubuntuforums.org/showthread.p...22#post9203922 [#136]

http://ubuntuforums.org/showthread.php?t=1473629