Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38

Thread: A error occurred while mounting 0

  1. #11
    Join Date
    Nov 2010
    Beans
    3

    Re: A error occurred while mounting 0

    I am having the same problem: A error occurred while Mounting O
    When I run sudo blkid, this is what I get:
    /dev/sda1: UUID="d90768a9-0610-4968-943d-69ee257087fa" TYPE="ext4"
    /dev/sda2: LABEL="New Volume" UUID="43b27488-c7dd-4f76-ab90-749571537d50" TYPE="ext4"

    I have deleted the sw 0 0 line from fstab but it did not work.
    I am a newbie and I was messing around with partitions to dual boot windows. Needless to say it did not work!

    Could you please help??

  2. #12
    Join Date
    Apr 2010
    Location
    England
    Beans
    3,286

    Re: A error occurred while mounting 0

    We need the contents of /etc/fstab to examine.

    When trying to edit that file, did you open it with root privileges? Your used doesn't have write permissions on it, so you need root privileges to make the necessary changes.

    Code:
    gksu gedit /etc/fstab
    http://xkcd.com/293/
    There are 10 kinds of people in this world: Those who understand ternary, those who don't, and those who confuse it with binary.

  3. #13
    Join Date
    Nov 2010
    Beans
    3

    Re: A error occurred while mounting 0

    Yes I did. This is what is in fstab now:

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>

    proc /proc proc defaults 0 0
    #Entry for /dev/sda1 :
    #Entry for /dev/sda5 :
    defaults,nls=utf8,umask=0222 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

    Must I still make changes here or do you think there is a different problem?

    Thanks for your fast reply WorMzy.

  4. #14
    Join Date
    Apr 2010
    Location
    England
    Beans
    3,286

    Re: A error occurred while mounting 0

    You need to remove
    defaults,nls=utf8,umask=0222 0 0
    It's another malformed fstab line which is causing the problem.
    http://xkcd.com/293/
    There are 10 kinds of people in this world: Those who understand ternary, those who don't, and those who confuse it with binary.

  5. #15
    Join Date
    Nov 2010
    Beans
    3

    Re: A error occurred while mounting 0

    That fixed the problem. Really appreciate the help. Thanks

  6. #16
    Join Date
    Mar 2010
    Location
    Ankara, Tr
    Beans
    99
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: A error occurred while mounting 0

    Hi,

    the same problem here... When I add a line for sda2, I get this message and when I don't sda2 is not auto-mounted...

    Here is my fstab:
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc                                       /proc        proc  nodev,noexec,nosuid      0  0  
    # / was on /dev/sda5 during installation
    UUID=2dbaac0d-8df8-4630-8a95-b6ba837ba956  /            ext4  defaults                 0  1  
    /dev/sda4                                  /media/sda4  ext4  defaults                 0  0  
    /dev/sda3                                  /media/sda3  ext4  
    defaults                         0  0  
    /dev/sda2                                  /media/sda2  ext4
    defaults                         0  0
    and this is blkid:
    Code:
    /dev/sda2: LABEL="Muzikli" UUID="c913b620-b3dd-4ab3-8b83-3e20184610bf" TYPE="ext4" 
    /dev/sda3: UUID="b7831a23-e4ed-4fd3-b81c-807eebb06d80" TYPE="ext4" 
    /dev/sda4: LABEL="Filmli" UUID="dd990450-e201-4cfa-a195-f833d165f031" TYPE="ext4" 
    /dev/sda5: UUID="2dbaac0d-8df8-4630-8a95-b6ba837ba956" TYPE="ext4"
    What should I change?
    Thanks...

  7. #17
    Join Date
    Apr 2010
    Location
    England
    Beans
    3,286

    Re: A error occurred while mounting 0

    Both sda2 and sda3 entries are on two lines. Remove the linebreaks in these entries. You could also change the last "0" on the sda2/3/4 entries to "2". Your fstab file should read like this (2's optional):

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system>                           <mount point> <type> <options>           <dump><pass>
    proc                                       /proc        proc  nodev,noexec,nosuid      0  0  
    # / was on /dev/sda5 during installation
    UUID=2dbaac0d-8df8-4630-8a95-b6ba837ba956  /            ext4  defaults                 0  1  
    /dev/sda4                                  /media/sda4  ext4  defaults                 0  2  
    /dev/sda3                                  /media/sda3  ext4  defaults                 0  2  
    /dev/sda2                                  /media/sda2  ext4  defaults                 0  2
    http://xkcd.com/293/
    There are 10 kinds of people in this world: Those who understand ternary, those who don't, and those who confuse it with binary.

  8. #18
    Join Date
    Mar 2010
    Location
    Ankara, Tr
    Beans
    99
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: A error occurred while mounting 0

    Quote Originally Posted by WorMzy View Post
    Both sda2 and sda3 entries are on two lines. Remove the linebreaks in these entries. You could also change the last "0" on the sda2/3/4 entries to "2". Your fstab file should read like this (2's optional):

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system>                           <mount point> <type> <options>           <dump><pass>
    proc                                       /proc        proc  nodev,noexec,nosuid      0  0  
    # / was on /dev/sda5 during installation
    UUID=2dbaac0d-8df8-4630-8a95-b6ba837ba956  /            ext4  defaults                 0  1  
    /dev/sda4                                  /media/sda4  ext4  defaults                 0  2  
    /dev/sda3                                  /media/sda3  ext4  defaults                 0  2  
    /dev/sda2                                  /media/sda2  ext4  defaults                 0  2

    Thanks for the swift answer. Now it works.

  9. #19
    Join Date
    May 2010
    Location
    Melbourne, Victoria, Aust
    Beans
    5
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: A error occurred while mounting 0

    Yeah, WorMzy is pretty awesome like that!

  10. #20
    Join Date
    Dec 2010
    Beans
    12

    Re: A error occurred while mounting 0

    I'm very new here, this is my first post. I too upgraded from 9.10 to 10.4. Once the upgrade was complete and requesting a reboot, I get the message "An error occurred while mounting", but unlike the others in this thread, there's no further indication of what it's trying to mount.

    Going into manual recovery mode and looking at other posts here, I tried the 'blkid' command, and compared it to my fstab. My fstab does not mention a /dev/sda drive, but the blkid command does, and it's type 'NTFS'. It appears to be my separate drive for the dual boot system (windoze is other drive). It seems that the ubuntu side has partially forgotten the dual boot, even though GRUB controls the dual boot, and still successfully takes me into Windows if i select it.

    Am I on the right track, and if so how to I tell teh ubuntu side to ignore and not to mount the sda drive? I don't access the windows drive when booted into ubuntu, though i know I could.

    Any tips?

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •