Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 44

Thread: How to install ideviceinstaller

  1. #11
    Join Date
    Sep 2006
    Location
    Heredia, Costa Rica
    Beans
    45
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to install ideviceinstaller

    Hi! I really want to try this! Thanks for the guide! Just a question: isn't libimobiledevice already installed with Lucid? Should I uninstall it before trying this guide?
    Linux User #431836
    Machine #370145

  2. #12
    Join Date
    Jun 2007
    Beans
    12

    Re: How to install ideviceinstaller

    Quote Originally Posted by era506 View Post
    Hi! I really want to try this! Thanks for the guide! Just a question: isn't libimobiledevice already installed with Lucid? Should I uninstall it before trying this guide?
    Hi,

    You are correct, it is installed, but not the latest version which is required for this to work. There is no uninstall needed at the same time it cannot hurt either

  3. #13
    Join Date
    Jun 2007
    Beans
    12

    Re: How to install ideviceinstaller

    Quote Originally Posted by JohnnyBee View Post
    Hey guys I've been trying to get these apps working on my laptop, but I come up with an error concerning libclutter-1.0-dev libclutter-gtk-0.10-dev installation packages.
    The following packages have unmet dependencies:
    libclutter-1.0-dev: Depends: libgtk2.0-dev but it is not going to be installed
    libclutter-gtk-0.10-dev: Depends: libgtk2.0-dev but it is not going to be installed

    Any ideas?
    Hi,

    Like said, I am no expert and still learning. Nevertheless this might help:

    $ sudo apt-get install -f (this fixes dependencies)

    You can also try:

    $ sudo apt-get update
    $ sudo apt-get dist-upgrade

    Hope this helps! Let me know

  4. #14
    Join Date
    May 2007
    Location
    Athens, Greece
    Beans
    4
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: How to install ideviceinstaller

    Thanks for your reply. Already try this, but it does not seem to work.

  5. #15
    Join Date
    May 2010
    Beans
    2

    Re: How to install ideviceinstaller

    Quote Originally Posted by chaosz911 View Post
    Hi,

    You are correct, it is installed, but not the latest version which is required for this to work. There is no uninstall needed at the same time it cannot hurt either
    I tried installing libimobiledevice 1.01 with ur instructions and it seemed to install, but in synaptic it still shows up as 0.97, what am I doing wrong? I am running lucid by the way

  6. #16
    Join Date
    Mar 2007
    Beans
    21

    Re: How to install ideviceinstaller

    Quote Originally Posted by katnenis View Post
    I tried installing libimobiledevice 1.01 with ur instructions and it seemed to install, but in synaptic it still shows up as 0.97, what am I doing wrong? I am running lucid by the way
    It will not show up on Synaptic, so no problemo.
    I made a tutorial with the updated version of libimobiledevice, in case any one of you want to read it, go HERE.
    It's in spanish but it's easy to understand.

  7. #17
    Join Date
    May 2010
    Beans
    2

    Re: How to install ideviceinstaller

    Quote Originally Posted by G@B0 View Post
    It will not show up on Synaptic, so no problemo.
    I made a tutorial with the updated version of libimobiledevice, in case any one of you want to read it, go HERE.
    It's in spanish but it's easy to understand.
    Thank you, but how can I check the version number of libimobiledevice to make sure I'm running 1.01

  8. #18
    Join Date
    Jun 2007
    Beans
    12

    Re: How to install ideviceinstaller

    Howdy,

    The tutorial has been updated (thank you G@b0).
    I ran into some problems myself though which I still cannot solve.
    ideviceinstaller -l works perfectly it shows all apps on the iPhone (3gs). It is not possible to create a backup however. Below is the output, any ideas?

    idevicebackup backup ~/iPhone/
    Backup directory is "~/iPhone/"
    Started "com.apple.mobilebackup" service on port 49222.
    Reading Info.plist from backup.
    Starting backup...
    Reading existing Manifest.
    Could not read Manifest.plist, switching to full backup mode.
    Creating Info.plist for new backup.
    Requesting backup from device...
    Full backup mode.
    Please wait. Device is preparing backup data...
    idevicebackup: /build/buildd/libplist-1.1/src/plist.c:576: plist_get_uint_val: Assertion `length == sizeof(uint64_t)' failed.
    Aborted

  9. #19
    Join Date
    May 2010
    Beans
    3

    Re: How to install ideviceinstaller

    I followed the steps on this site. i have an ipod touch 2g 8gig, with ios4 istalled. I'm using linux mint 9

    when I try to back up the ipod i get this error:
    Backup directory is "/home/dc/ipodbackup"
    Started "com.apple.mobilebackup" service on port 49171.
    Reading Info.plist from backup.
    Starting backup...
    Reading existing Manifest.
    Could not read Manifest.plist, switching to full backup mode.
    Creating Info.plist for new backup.
    Requesting backup from device...
    ERROR: Could not start backup process: device refused to start the backup proces

    Is there somthing else I need to install or is this a result of upgrading to ipod's ios4.

    I get this error when I try and archive an app:

    Archive - Error occured: APIEpicFail

    I'm kind of new with linux so I have no idea what I should do. Any help would be great.

    I can rearange my ipod apps on sbmanager with no problem.

    I don't know if this will help but ideviceinfo gives me this:

    ActivationPublicKey: LS0tLS1CRUdJTiBSU0EgUFVCTElDIEtFWS0tLS0tCk1JR0pBb0 dCQUlpQ1RWOFovNkRCZFNISkxxUGE1NUE1MXpidnZraTZXNlll SDU3TWNtZmdtT2pBMENaQytWY3oKanFoblBueUNDdWNBdDRlS0 hYZjlyakhST0IyODRJak9lNldkT0UxV3BCeU4xUm5mQzA2b3Fs WVNrSnh1TmEreQpVbVJOQUF1K3FoejFLZFF1b3VVcldlSTRWbW VTRS9CSnh0VUJOdGdGelREZHJVdmY1N25UQWdNQkFBRT0KLS0t LS1FTkQgUlNBIFBVQkxJQyBLRVktLS0tLQo=
    ActivationState: Activated
    ActivationStateAcknowledged: true
    BluetoothAddress: d8:30:62:0f:87:be
    BuildVersion: 8A293
    CPUArchitecture: armv6
    CallsInProgress: false
    DeviceCertificate: LS0tLS1CRUdJTiBDRVJUSUZJQ0FURS0tLS0tCk1JSUM0VENDQW txZ0F3SUJBZ0lLQUpPS2dpL3lWejRaRURBTkJna3Foa2lHOXcw QkFRVUZBREJhTVFzd0NRWUQKVlFRR0V3SlZVekVUTUJFR0ExVU VDaE1LUVhCd2JHVWdTVzVqTGpFVk1CTUdBMVVFQ3hNTVFYQndi R1VnYVZCbwpiMjVsTVI4d0hRWURWUVFERXhaQmNIQnNaU0JwVU dodmJtVWdSR1YyYVdObElFTkJNQjRYRFRFd01EWXlOREU0Ck1E WTBObG9YRFRFek1EWXlOREU0TURZME5sb3dnWU14TFRBckJnTl ZCQU1USkVSRk5FVXpRa1kzTFRVME1UQXQKTkRrMlJTMDROVEV6 TFRoRU9UTTJSamcxTXpReU16RUxNQWtHQTFVRUJoTUNWVk14Q3 pBSkJnTlZCQWdUQWtOQgpNUkl3RUFZRFZRUUhFd2xEZFhCbGNu UnBibTh4RXpBUkJnTlZCQW9UQ2tGd2NHeGxJRWx1WXk0eER6QU 5CZ05WCkJBc1RCbWxRYUc5dVpUQ0JuekFOQmdrcWhraUc5dzBC QVFFRkFBT0JqUUF3Z1lrQ2dZRUFpSUpOWHhuL29NRjEKSWNrdW 85cm5rRG5YTnUrK1NMcGJwaDRmbnN4eVorQ1k2TURRSmtMNVZ6 T09xR2MrZklJSzV3QzNoNG9kZC8ydQpNZEU0SGJ6Z2lNNTdwWj A0VFZha0hJM1ZHZDhMVHFpcVZoS1FuRzQxcjdKU1pFMEFDNzZx SFBVcDFDNmk1U3RaCjRqaFdaNUlUOEVuRzFRRTIyQVhOTU4ydF M5L251ZE1DQXdFQUFhT0JnekNCZ0RBZkJnTlZIU01FR0RBV2dC U3kKL2lFalJJYVZhbm5WZ1NhT2N4RFlwMHlPZERBZEJnTlZIUT RFRmdRVW9kMFU4TmIyUENQZEVxai91VDBZM1pvVgpzR0F3REFZ RFZSMFRBUUgvQkFJd0FEQU9CZ05WSFE4QkFmOEVCQU1DQmFBd0 lBWURWUjBsQVFIL0JCWXdGQVlJCkt3WUJCUVVIQXdFR0NDc0dB UVVGQndNQ01BMEdDU3FHU0liM0RRRUJCUVVBQTRHQkFHT0FFbm 4vUW9hNWFWSzUKWmUwejhvendLbEZlQWR3MWtDcHo2elZOMldu UW01d1R5c1cxbXVSbzl2OGFZa29oYWJkeENpcGlUY2dFWnkzUQ p6NkZKbUt0cEY4dWJDa1hWZ1R6Qit4NzgxMkl0OHp1d1pmbUMw cGdzbDkrb1dpMy9BT0FrUVBaVmZoQk1yMFQ4ClpSSVBRL3lXc1 RodVNMdnpqZUdid3Ric1h3a0IKLS0tLS1FTkQgQ0VSVElGSUNB VEUtLS0tLQo=
    DeviceClass: iPod
    DeviceColor: iPodShinyMetal
    DeviceName: Daniel’s iPod
    DevicePublicKey: LS0tLS1CRUdJTiBSU0EgUFVCTElDIEtFWS0tLS0tCk1JR0pBb0 dCQUtJODdKUDliNWU4RTdTblVod2loSDJhQ2N4clJ4QkwrcUhG L2g0TlczblVZdTlZZWNzdDRwcWoKcDF5QW5ablpYQTRINlI0Qk ljWGJmUDFXTnozazFvcGEvb1NrMVB2TDZMWmVJRTBlWExNcFlN VTlzdmlUMmVzdAozdmo0SEFDZWRLUHk3RWp0Z0JLalQxaUJENG l1UGdJZ2syRkthWnBiZmZkYjJhNyt5cmtsQWdNQkFBRT0KLS0t LS1FTkQgUlNBIFBVQkxJQyBLRVktLS0tLQo=
    DieID: 1338124057264
    FirmwareVersion: iBoot-889.24
    HardwareModel: N72AP
    HostAttached: true
    MLBSerialNumber: 9C020324Y8UFA
    MobileSubscriberCountryCode:
    MobileSubscriberNetworkCode:
    ModelNumber: MC086
    PartitionType: GUID_partition_scheme
    PasswordProtected: false
    ProductType: iPod2,1
    ProductVersion: 4.0
    ProductionSOC: true
    ProtocolVersion: 2
    RegionInfo: LL/A
    SBLockdownEverRegisteredKey: false
    SDIOManufacturerTuple:
    IOSDIOManufacturerID: 19792
    IOSDIOProductID: 19784
    SIMGID1: AAAAAAAAAAAAAAAAAAAAAAAAAAAIAAAAAQAAAAAAAAA=
    SIMGID2: AAAAAAAAAAAAAAAAAAAAAAAAAAAIAAAAAQAAAAAAAAA=
    SIMStatus: kCTSIMSupportSIMStatusReady
    SerialNumber: 1C02086075J
    SoftwareBehavior: EQAAAAAAAAAAAAAAAAAAAA==
    SoftwareBundleVersion: 2
    SupportedDeviceFamilies[1]:
    0: 1
    TimeIntervalSince1970: 1277755481
    TimeZone: US/Pacific
    TimeZoneOffsetFromUTC: -25200.000000
    TrustedHostAttached: true
    UniqueChipID: 1199739981199
    UniqueDeviceID: 05b4888873aa0df176bd8d7746f12b4cb3117d99
    Uses24HourClock: false
    WiFiAddress: d8:30:62:01:85:26
    iTunesHasConnected: true

  10. #20
    Join Date
    Feb 2008
    Location
    Argentina
    Beans
    14
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: How to install ideviceinstaller

    Hello,
    I am trying to compile ideviceinstaller, but I have a problem in the dependency on libimobiledevice.

    I am using pmcenery PPA: https://launchpad.net/~pmcenery/+arc...s_filter=lucid ,
    so I have now installed libimobiledevice1, v 1.0.1:
    Code:
    $ apt-cache showpkg libimobiledevice1
    Package: libimobiledevice1
    Versions: 
    1.0.1-1ubuntu1~ppa1 (/var/lib/apt/lists/ppa.launchpad.net_pmcenery_ppa_ubuntu_dists_lucid_main_binary-i386_Packages) (/var/lib/dpkg/status)
    however when I run autogen.sh on ideviceinstaller:
    Code:
    $ ./autogen.sh 
    (...)
    checking for libimobiledevice... configure: error: Package requirements (libimobiledevice-1.0 >= 0.9.7) were not met:
    
    No package 'libimobiledevice-1.0' found
    
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    It does not find my library. I believe it has to do with the naming (libimobiledevice1 vs. libimobiledevice, v1.0), but I am not sure.

    I want to keep using libimobiledevice from the PPA, not install it myself as suggested in this tutorial. Is there any workaround to have the ./configure step find my library version?

    Any help greatly appreciated!

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •