Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: USB devices won't automount in 10.04 Lucid

  1. #11
    Join Date
    May 2010
    Beans
    1

    Unhappy Re: USB devices won't automount in 10.04 Lucid

    Hi, since i upgraded from 9.10 to 10.04 my sandisk and kingston memory sticks stop beign automounted, if i do lsusb, they appear, and they had never appear in the Places|Computer, only my dvd and HD are available, does the usb work so different now??

    one thing i noticed is that once im logged in, if i reinstall mountusb from synaptic my memory sticks get recognized and automounted, any ideas how to solve this frustrating behavior?.

    I've made a strong evangelization in my home to make them use ubuntu but now they are all complaining because of this.

  2. #12
    Join Date
    Mar 2009
    Location
    Kiama, Australia
    Beans
    11
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: USB devices won't automount in 10.04 Lucid

    Problems here, too. My devices that doesn't seem to work anymore;

    - WD external 320Gb HD
    - Sharp Zaurus 5500 (yes, remember those?
    - Tevion MP3 player (crap, but always mounts everywhere, except now)

    None of these mount nor come up in Nautilus, but the WD comes up in lsusb but under a different name "Initio Corporation" (which is the controller chip maker). Odd. Could that be part of the problem?

    I cannot turn floppy support off (not in BIOS, but there's no floppy for booting anyways). Auto-login isn't on, nor does rebooting, in out and in login work. I'm a bit stumped and surprised. I'm not sure what to do as my searches are coming to an end of what to do next. Aargh.

    (I also can no longer watch any video, no matter the codec, but that's a different thread)
    Last edited by shelterit; May 11th, 2010 at 07:35 AM. Reason: update

  3. #13
    Join Date
    Jan 2008
    Beans
    87
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: USB devices won't automount in 10.04 Lucid

    Disabling auto login did it for me in Xubuntu Lucid. But what is strange is that my usb devices auto mounted to the desktop WITH auto login for about a week, then stopped working. I guess I can live with logging in- probably should anyway.

    Thanx all for posting. Who would have ever thunk that auto login could be the culprit?

    I have always had usb issues with Canon cameras, even in Windoze. I just remove the SD card and plug it into a $5 reader.

    This USB thing was causing me more severe problems. Just before the desktop loaded up I was getting a halt where I had to press the S key to skip the mounting problem and continue loading Lucid. Luckily I had made an image file of my system about an hour before these issues arose. I reloaded the system image and THAT problem went away. The rest of the fix came from your posts.

    Slightly off topic, but I HIGHLY recommend downloading the Parted Magic live cd (boot cd) and burn as an iso. It comes with an app called CloneZilla which is awesome- on the idea of Norton Ghost, only more reliable. To use, all you have to do is set the bios to boot from CD, hook up a usb hard drive, and make an image of your ubuntu partition onto the external hard drive. Since it does not image free space, it is very fast (5-10 minutes to back up or restore) and the restores are flawless. Every time my system is running perfectly, I make an image, then restore it if I have issues that I or the community cannot solve quickly. But follow the directions exactly since a few items may be counterintuitive- like you define the target first (external hard drive) and the source (your ubuntu partition) second. And you select save parts (system partition) rather than the entire disk. This program saved me 2 days work of another fresh install with all the tweaks to Firefox etc.
    I just had to send them a donation.
    Last edited by Ron O; May 10th, 2010 at 11:50 PM. Reason: add sentence

  4. #14
    Join Date
    Sep 2009
    Location
    Australia
    Beans
    30
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: USB devices won't automount in 10.04 Lucid

    Heaps of people have the same problem, including me.

    I just got over waiting so I went out and bought a cheap card reader, solves the problem in a roundabout type of way.

  5. #15
    Join Date
    May 2009
    Beans
    5

    Re: USB devices won't automount in 10.04 Lucid

    [solved]

    running xubuntu 10.04 had the same problem as a couple of posts earlier where automount worked for about a week then quit working. soon as i disabled auto login it started working properly, not sure if anyone has filed a bug or not?

  6. #16
    Join Date
    Jun 2008
    Location
    Enschede, Netherlands
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: USB devices won't automount in 10.04 Lucid

    Hi!

    I have the same problem. Disabling the floppy in BIOS makes automount work once for every time i boot my computer. If I insert a USB disk a second time, it doesn't get automounted.

    Regarding IPOD, i have the same problem on an old 512MB ipod. It gets automounted once and only once per boot since i removed libgpod-common as suggested in:

    http://ubuntuforums.org/showthread.php?t=1473082

    Any clues why my disks get mounted only once?

    Thanks,
    Mikael

  7. #17
    Join Date
    Nov 2008
    Beans
    22

    Re: USB devices won't automount in 10.04 Lucid

    I also have problems with automounting my SD card on my ANdroid phone. Worked perfectly in Karmic.

  8. #18
    Join Date
    Apr 2006
    Beans
    31
    Distro
    Ubuntu

    Re: USB devices won't automount in 10.04 Lucid

    Not sure why this started happening to me, but it did after a recent update in Lucid (to the x.32 kernel or something). Disabling the non-existent floppy in the bios did the trick, thanks!
    http://minimallinux.com simplicity + freedom
    http://linuxmusicians.com Create music freely.

  9. #19
    Join Date
    Sep 2008
    Beans
    18
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: USB devices won't automount in 10.04 Lucid

    Funny enough, most of my usb devices work just fine, had to change one firewire HD to usb in order to get it connected. eSATA also fails consistently.

    What really makes me wonder though, is that iPhone 3gs mounts fine when I'm running nautilus (on a Kubuntu Lucid x64 alternative, both clean and upgraded installs,) with KDE 4.4.4 (as the default and open desktop for the moment), but not on dolphin.

    There's apparently something wrong with the way KDE automounts devices, they get listed in ls* commands, so the kernelside is playing nice, but using nautilus I can mount all media. I suspect theres something wrong with the daemon (hdparm).

    One system runs on an Asus P7P55D with ICH10 chipset, another on an Asus P6T Deluxe V2 with the ICH9 chipset and finally an Acer 6920G with ICH8. All are running the latest Kubuntu Lucid x64, kernel 2.6.32-22.36. All systems have AHCI enabled with AHCI APIC 2.0 enabled, since not having these settings caused some external devices to go into a connect/disconnect loop. (eg. the iPhone 3gs and an older WD external HD).
    Last edited by no0ne; June 7th, 2010 at 10:25 AM. Reason: More detail.

  10. #20
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    2,533
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: USB devices won't automount in 10.04 Lucid

    Errors polling for a non-existing floppy in 10.04 interfered with suspend/hibernate, and auto mounting USB mass storage, on an old Dell Inspiron 8200. BIOS already showed floppy "Not Installed" and removing it from boot order did not help. But it has a hot swap drive bay, so Linux was still looking for a floppy.

    I could not sudo rmmod floppy, because it said it was in use. But the following resolved it:


    1. Add blacklist floppy to /etc/modprobe.d/blacklist.conf (or in a new file there using sudo for your editor or gksu for gedit).
    2. Run: sudo update-initramfs -u
    3. Reboot

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •