Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

  1. #21
    Join Date
    Jul 2008
    Location
    Kuala Lumpur, Malaysia
    Beans
    124
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    Quote Originally Posted by cespinal View Post
    Can you help me on this?It seems I cannot download qgis directly from the repositories....
    Glad to


    Copy paste the following commands in a terminal line by line then press ENTER after each line script was done:

    sudo add-apt-repository ppa:jef-norbit/qgis-unstable-ubuntugis-jef
    sudo apt-get update && sudo apt-get upgrade
    sudo apt-get install qgis

  2. #22
    Join Date
    May 2008
    Beans
    517

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    The following packages have unmet dependencies:
    qgis: Depends: libgdal1-1.7.0 but it is not installable
    Depends: libgeos-c1 (>= 3.2.2) but 3.1.0-1 is to be installed
    Depends: libqgis1.5.0 but it is not going to be installed
    Depends: libqt4-svg (>= 4:4.5.3) but it is not going to be installed
    Depends: libqwt5-qt4 but it is not going to be installed
    Recommends: qgis-plugin-grass but it is not going to be installed
    Recommends: python-qgis but it is not going to be installed


    Seems I'm falling in a dependency hell

  3. #23
    Join Date
    Jul 2008
    Location
    Kuala Lumpur, Malaysia
    Beans
    124
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    I had assumed that you hadn't any QGIS or part of QGIS installed and you didn't tell me either but an advise given prior to the script was "Just uninstall your version of qgis (if you have one on your ubuntu)".

    I just followed through and everything works fine so I can't answer why it didn't work for you. I'm not a programmer so can't advise terminal wise but my best advise is for you to be a member of QGIS Forum and the QGIS user mailing list of which response from the latter is quicker. Have you been to http://www.qgis.org/wiki/Download#Ubuntu?

  4. #24
    Join Date
    Jul 2005
    Location
    Hughenden, Australia
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    It seems like there's a little problem of some kind in the repositories, so maybe wait a while and try again later.

    I have a spare fresh new Ubuntu installation I am using for GRUB2 experiments to update my website, so I tried the same commands and I received the same error message.
    Then I tried running through the commands most of us use to install software for playing music in case there might be something we need in that repository, Comprehensive Multimedia & Video Howto and I got even more error messages about packages not being available.

    Finally I tried the steps we posted in the first page of this thread and it worked. I don't know why. I think my clumsy way of blundering into it in post #3 doesn't differ substantially from the way badaveil most eloquently summed it up in post#4, just that I used the GUI more. Unless I was just lucky and something in the repositories was fixed at the same time I tried again.
    I guess the moral of the story is to just keep trying and you will succeed.
    Ubuntu user since 2004 (Warty Warthog)

  5. #25
    Join Date
    Jul 2008
    Location
    Kuala Lumpur, Malaysia
    Beans
    124
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    QGIS site http://www.qgis.org/wiki/Download#Ubuntu recommends:

    Ubuntu
    Release
    Current packages available for jaunty, karmic, lucid and maverick from

    sudo apt-get install add-apt-repository
    sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
    sudo aptitude install qgis

  6. #26
    Join Date
    May 2008
    Beans
    517

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    Quote Originally Posted by badaveil View Post
    QGIS site http://www.qgis.org/wiki/Download#Ubuntu recommends:

    Ubuntu
    Release
    Current packages available for jaunty, karmic, lucid and maverick from

    sudo apt-get install add-apt-repository
    sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
    sudo aptitude install qgis
    Followed your recommendation. Here is the output when I try to install Qgis from the repos.

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      qgis: Depends: libgdal1-1.7.0 but it is not installable
            Depends: libgeos-c1 (>= 3.2.2) but 3.1.0-1 is to be installed
            Depends: libqgis1.5.0 but it is not going to be installed
            Depends: libqt4-svg (>= 4:4.5.3) but it is not going to be installed
            Depends: libqwt5-qt4 but it is not going to be installed
            Recommends: qgis-plugin-grass but it is not going to be installed
            Recommends: python-qgis but it is not going to be installed
    E: Broken packages
    I'm really in need of giving QGIS a try...

  7. #27
    Join Date
    Jul 2008
    Location
    Kuala Lumpur, Malaysia
    Beans
    124
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    cespinal,

    I see from the output the last line state "E: Broken packages"

    From my understanding, you have to fix broken packages first before you can even think of installing a related application.

    So what I can advise is to go to the Synaptic Package Manager then under Edit, select Fix broken packages.

    If it got fixed, the status menu bar will state so. Only then repeat the earlier step.

    If it still persist, under Synaptic, search QGIS and do a total removal of all related QGIS files then repeat the recommended QGIS download steps

    If that still persist, do a total removal of all related QGIS files then repeat download following J.Norbit's repos.

    If that still persist, I've run out of options

  8. #28
    Join Date
    May 2008
    Beans
    517

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    Sorry...tried every one of your suggestions.

    The funny thing is that I haver never installed qgis...let alone had any qgis installation on my system.

  9. #29
    Join Date
    Jul 2008
    Location
    Kuala Lumpur, Malaysia
    Beans
    124
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Ubuntu 10.4 LTS & Quantum GIS (QGIS) 1.4 (Ubuntu version)

    Then the final advice I can give is for you to subcribe to QGIS user mailing list at http://lists.osgeo.org/mailman/listinfo/qgis-user

    Make a query, mention you tried to install QGIS based on :

    sudo apt-get install add-apt-repository
    sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
    sudo aptitude install qgis

    and your output was:


    Code:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    qgis: Depends: libgdal1-1.7.0 but it is not installable
    Depends: libgeos-c1 (>= 3.2.2) but 3.1.0-1 is to be installed
    Depends: libqgis1.5.0 but it is not going to be installed
    Depends: libqt4-svg (>= 4:4.5.3) but it is not going to be installed
    Depends: libqwt5-qt4 but it is not going to be installed
    Recommends: qgis-plugin-grass but it is not going to be installed
    Recommends: python-qgis but it is not going to be installed
    E: Broken packages

    Ask for help.

    Based on my experience, you should get a reply less than 24 hours.

    Best of luck!

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •