Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Lucid (10.04) wont shutdown my computer

  1. #1
    Join Date
    Feb 2008
    Beans
    6

    Lucid (10.04) wont shutdown my computer

    Hello, this will be my first post..

    My ubuntu won't shut down, it stops at the ubuntu logo (with the dots under it). It seems like the OS completely and successfully shuts down, also the harddrive spins down too, except for the computer. I belive this might have happened after I updated my bios. (due to hybrid gpu trouble)

    I did search on the internet, and found that it might be some ACPI related issues, and that I have to edit the grub's menu.lst file and add acpi=force. However my menu.lst file is blank, there is nothing in there.

    I have tried to shutdown via the terminal too, but the same happens there. Last time I checked it successfully reboots, and standby works correctly. For me to shutdown this laptop, I have to remove the battery and the power cord for it to shutdown, or hold the power button for 10 secs, which is really annoing.

    Anyone who have the best answer?
    Thanks.

  2. #2
    Join Date
    Sep 2008
    Beans
    784
    Distro
    Ubuntu Development Release

    Re: Lucid (10.04) wont shutdown my computer

    When you get into the GRUB menu, press "e" to edit your entry and add acpi=force to the parameters.

    GRUB 2 acts slightly differently to legacy and doesnt have the menu.lst

  3. #3
    Join Date
    Mar 2010
    Location
    Oklahoma
    Beans
    156
    Distro
    Ubuntu UNR

    Re: Lucid (10.04) wont shutdown my computer

    open a terminal and type
    "sudo gedit /etc/default/grub"
    you should see something like this:
    ----------------------------------------
    If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT="10"
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    -----------------------------------------
    where it says "GRUB_CMDLINE_LINUX="" is where you will add acpi=force. it should look exactly like this:
    GRUB_CMDLINE_LINUX="acpi=force"

    save your file and get in your terminal again and type:
    "sudo update-grub"
    Last edited by colorlessprism; May 2nd, 2010 at 01:02 PM. Reason: flow
    I would change the world, but they wont give me the source code

    MD5 - Check your Hash | GPG Errors? - Click Here | Remastersys - Guide

  4. #4
    Join Date
    Feb 2008
    Beans
    6

    Re: Lucid (10.04) wont shutdown my computer

    Thanks for your reply(es)!

    Adding the acpi=force to "GRUB_CMDLINE_LINUX" did not help. However I accidetely hit ESC during shutdown, and got some text info (verbose?) on screen

    Code:
    * All processes ended within 2 seconds....           [ OK ]
    
    * Deconfiguring network interfaces...                [ OK ]
    
    * Deactivating swap...                               [ OK ]
    
    * Unmounting weak filesystems...                     [ OK ]
    
    * Will now halt
                   [  150.465539] Power down.
    _
    This were the last lines.
    And the marker on the bottom of the screen " _ " does not blink. There are no advanced settings in bios to config acpi. I might however update the bios firmware to a last newest version as there was 4 different versions avaiable as a last option.

  5. #5
    Join Date
    Mar 2010
    Location
    Oklahoma
    Beans
    156
    Distro
    Ubuntu UNR

    Re: Lucid (10.04) wont shutdown my computer

    try this instead:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

    i guess some people report bugs when adding to options to GRUB_CMDLINE_LINUX. try editing your /etc/default/grub and moving the acpi option as seen above. dont forget to:

    "sudo update-grub"

    i have always thought it was a good idea to keep the latest firmware on my computer. although you dont usually know there is a new one until you start having problems. when i updated to 9.10 i had major screen flickering and serious usb issues. a simple bios update corrected all of that. try changing your grub and if you still have problems update your bios.
    I would change the world, but they wont give me the source code

    MD5 - Check your Hash | GPG Errors? - Click Here | Remastersys - Guide

  6. #6
    Join Date
    Feb 2008
    Beans
    6

    Re: Lucid (10.04) wont shutdown my computer

    Quote Originally Posted by colorlessprism View Post
    try this instead:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

    i guess some people report bugs when adding to options to GRUB_CMDLINE_LINUX. try editing your /etc/default/grub and moving the acpi option as seen above. dont forget to:

    "sudo update-grub"

    i have always thought it was a good idea to keep the latest firmware on my computer. although you dont usually know there is a new one until you start having problems. when i updated to 9.10 i had major screen flickering and serious usb issues. a simple bios update corrected all of that. try changing your grub and if you still have problems update your bios.
    That didnt help either, it seems like the harddrive shuts down (spindown) to early in the shutdown process, preventing the os reading\writing the last data needed for shutdown. Just a theory..

    But thanks anyway, unfortunately I have to use windows to upgrade the Bios firmware. Acer, my computer manufacturer, doesn't provide any way of updating bios through linux. Luckily thats only a harddrive change away.

    By the way, its an Acer Aspire 5810TG (timeline series), which doesn't run win very well.

  7. #7
    Join Date
    Dec 2009
    Location
    United Kingdom
    Beans
    220
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Lucid (10.04) wont shutdown my computer

    Have you updated your bios to the latest version?
    Give that a try. Mine was giving me a few acpi and apm hiccups.
    It solved a suspend/resume problem which may be related to this.

    You will need to change the bios boot order to make sure the cd/dvd drive boots with an Ubuntu CD in it. Apart from that try it with the default settings.
    I had the same shutdown problem and could not find a solution - ended up doing a fresh install. It's ok now.
    Also have you checked your install cd with md5sum?
    A vivid and creative mind characterizes you.
    ATI Radeon HD6850, E7300 Core2duo, Asus P5Q

  8. #8
    Join Date
    Mar 2010
    Location
    Oklahoma
    Beans
    156
    Distro
    Ubuntu UNR

    Re: Lucid (10.04) wont shutdown my computer

    all you need is to download the BIOS update, download UNetBootin, and grab a flash drive. UNetBootin can put freeDOS on a flash drive for you (its in the top dropdown menu). then extract the BIOS update into a folder on the flash drive. print off a copy of the BIOS instructions and boot into FreeDOS. cd into the folder that has the BIOS stuff in it and run the command the instructions tell you to. thats all i had to do to update my wind. good luck
    I would change the world, but they wont give me the source code

    MD5 - Check your Hash | GPG Errors? - Click Here | Remastersys - Guide

  9. #9
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Lucid (10.04) wont shutdown my computer

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

    some users need to remove "splash" from the command above

  10. #10
    Join Date
    Feb 2008
    Beans
    6

    Re: Lucid (10.04) wont shutdown my computer

    Quote Originally Posted by BrokeMahPC View Post
    Have you updated your bios to the latest version?
    Give that a try. Mine was giving me a few acpi and apm hiccups.
    It solved a suspend/resume problem which may be related to this.

    You will need to change the bios boot order to make sure the cd/dvd drive boots with an Ubuntu CD in it. Apart from that try it with the default settings.
    I had the same shutdown problem and could not find a solution - ended up doing a fresh install. It's ok now.
    Also have you checked your install cd with md5sum?
    Everything (most) worked right out of the "box", however, I did not know what graphics card that was in use. Either the ATI 4330 or the Intel integrated. I dont want to use the ATI card, since I dont use graphic heavy applications on this computer (battery time). The only options in bios says SWITCHABLE or dGPU, and I figured that dGPU meant dedicated gpu (ATI). In between here I installed the drivers for the ATI Card, but got black screen during startup of ubuntu, the OS was still running normally tho. So I upgraded the BIOS to the newest version, which could (I hoped) have the option to set to ATI, INTEL or SWITCHABLE, but it didnt. After After som retries I found that dGPU meant Descrete GPU (INTEL), thats why I got black screen (wrong driver). I were able to uninstall the ATI driver and thats when I discovered that the computer wouldnt shut down properly.

    The no shutdown issue might have happened right after I upgraded the bios, but Im not entirely sure since I couldn't see anything. Im gonna try updating (downdating?, sorry my Ingelich) to an older bios, and see if it helps.

    Im going to try the method "colorlessprism" gave me for updating the bios, it seemed to be the easyest way, instad of removing 10 screws and lots of plastic covers to replace the harddrive with the windows one.

    Thanks alot for your help so far guys, and Ill probably post a message here if my bios "downdate"\downgrade helps.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •