Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42

Thread: Known Lucid Lynx issues/bugs with workarounds

  1. #21
    Join Date
    Jul 2009
    Location
    The Netherlands
    Beans
    30
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Exclamation Re: Known Lucid Lynx issues/bugs with workarounds

    Quote Originally Posted by jschille View Post
    In Response to Bootup/Plymoth Instructions:

    The commands will only work for Grub2, not legacy.
    To install Grub2 before following the instructions on how to fix Plymoth screen.

    Code:
    sudo apt-get remove grub
    sudo apt-get install grub-pc
    sudo grub-install /dev/sda
    sudo update-grub2
    Then follow the instructions stated in the OP post.

    ..

    Hope this helps.
    Note that your instructions do not comply with those in the official Ubuntu Documentation > Community Documentation > Grub2 stating:
    ..allows the user to test GRUB 2 by adding an entry to their normal GRUB menu. Select "Yes" to place a Chainload option on the GRUB menu. When GRUB boots the next time, the user can select a normal GRUB entry or transfer control to GRUB 2 via the Chainload entry.
    Starting out with a removal of GRUB might not be an ideal way to go.

  2. #22
    Join Date
    Sep 2008
    Beans
    10

    Re: Known Lucid Lynx issues/bugs with workarounds

    this solution should be added to the bug regarding some UMTS modems stop working in 10.04:
    http://ubuntuforums.org/showthread.p...86#post9244786

    adding the line:
    Code:
    apt-get install usb-modeswitch
    would be sufficient.
    this way, affected users do not have to read through the bug reports and have an easy and working solution at hand.

  3. #23
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,824
    Distro
    Ubuntu Development Release

    Re: Known Lucid Lynx issues/bugs with workarounds

    @qorron, done.

  4. #24
    Join Date
    Oct 2005
    Location
    UK
    Beans
    1,026
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Known Lucid Lynx issues/bugs with workarounds

    Re Printing.
    Anyone else NOT seeing CUPS loaded at boot time?

    https://bugs.launchpad.net/ubuntu/+s...ps/+bug/554172

    Work around..
    Start cups service from terminal

    > sudo service cups restart

    UPDATE: Was using NOUVEAU video driver for my NVIDIA card. Have installed NVIDIA proprietary driver and spent 2 hours booting and restarting. CUPS is now starting at boot time.... (will monitor situation... just in case..)

    EDIT 25 May 2010
    Not solved, still intermittent...
    Last edited by Zimmer; May 25th, 2010 at 09:47 AM. Reason: Still an issue.. fixed link..

  5. #25
    Join Date
    Jul 2009
    Location
    Hamilton, New Zealand
    Beans
    540
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Known Lucid Lynx issues/bugs with workarounds

    If you have both xubuntu-desktop and ubuntu desktop installed then the upgrade from Karmic may fail with the message

    Could not calculate the upgrade
    An unresolvable problem occurred while calculating the upgrade:
    The package 'ubuntu-desktop' is marked for removal but it is in the removal blacklist.
    This can be caused by:
    * Upgrading to a pre-release version of Ubuntu
    * Running the current pre-release version of Ubuntu
    * Unofficial software packages not provided by Ubuntu
    If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report.
    This is a bug in upgrade manager caused by a conflict in audio library requirements.
    https://bugs.launchpad.net/ubuntu/lu...er/+bug/571743
    The bug may also be triggered if other additional desktop combinations are present.

    The Workaround is to uninstall extra desktops - then upgrade - then reinstall extra desktops.

    UPDATE: This bug now seems to be fixed.
    Last edited by hawthornso23; June 19th, 2010 at 12:02 PM.
    Life's a pitch. And then you sing!

  6. #26
    Join Date
    Mar 2008
    Beans
    2
    Distro
    Xubuntu 7.10 Gutsy Gibbon

    Re: Known Lucid Lynx issues/bugs with workarounds

    I noticed that a lot of people are having problems with sound after upgrading. I was totally upset and not thinking clearly when it first happened to me, took an hour or so to realize the obvious fix.

    > Go to Terminal.
    > Type "alsamixer" (without quotes).
    > Make sure that Master, Headphones, Speaker, etc. are turned all the way up (or at least to the point that you want them to be.

    This seems to work for people who say they can see that their system is playing something, but they can't hear anything.

  7. #27
    Join Date
    Mar 2010
    Location
    Sweden
    Beans
    19
    Distro
    Ubuntu UNR

    Re: Known Lucid Lynx issues/bugs with workarounds

    There seems to be a lot of trouble with changing screen brightness on some Asus laptops. I think this applies to some Eee-models, and also UL-models. Here is the launchpad bugreport:

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/543294

    And here two threads about it:

    http://ubuntuforums.org/showthread.php?t=1468734
    http://ubuntuforums.org/showthread.php?t=1481849

    And here is the solution (from the first thread):

    1. Open a terminal (Program - Accessories - Terminal)
    2. Type in "sudo gedit /etc/default/grub" (without the "")
    3. Find the line that says: GRUB_CMDLINE_LINUX="quiet splash"
    4. Edit it so it says: GRUB_CMDLINE_LINUX="quiet splash acpi_backlight=vendor"
    5. Save and exit
    6. Run the command "sudo update-grub" (again without quotes of course)
    7. Reboot and enjoy!

  8. #28
    Join Date
    Nov 2009
    Beans
    8

    Re: Known Lucid Lynx issues/bugs with workarounds

    Regarding VNC (Desktop Sharing)

    It appears that it's necessary to turn off desktop effects for VNC to work from other machines.

    See also:
    http://ubuntuforums.org/showthread.php?t=1417146
    http://ubuntuforums.org/showthread.php?t=1383356

  9. #29
    Join Date
    Apr 2006
    Location
    Galax,Va. USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Known Lucid Lynx issues/bugs with workarounds

    This has to do with the problem Brasero is having not being able to burn an audio CD using an mp3 play-list from Rhythmbox or using nautilus.

    The problem with Brasero has been fixed upstream. Below is a link to the bug report and at the end of the report is a link to a Brasero build with the fix applied. Thanks to all who helped.

    https://bugs.launchpad.net/ubuntu/+s...ro/+bug/543892
    Last edited by Eddie Wilson; May 25th, 2010 at 03:55 PM.
    Iguana

    Registered Linux User #490719

  10. #30
    Join Date
    Jul 2007
    Beans
    9

    Re: Known Lucid Lynx issues/bugs with workarounds

    Sound: Weird/broken surround-sound volume control

    Since Karmic (9.10), a lot of people had and still have problems with correctly changing the volume of their speakers within a surround sound setup. An according launchpad link is https://bugs.launchpad.net/ubuntu/+s...io/+bug/410948.

    The background is PulseAudio trying to make everyone's life easier and providing simpler volume controls, which hide the actual hardware controls, as these are often not to easy to understand for the average user, and different settings may lead to the same output volume but with different quality (see here: http://pulseaudio.org/wiki/PulseAudioStoleMyVolumes). Unfortunately, this good approach seems to have trouble with certain sound cards, e.g., with my SoundBlaster Live. I do not know who is to blame for that (PulseAudio, Alsa, Hardware), and this question is clearly beyond the scope of this guide.

    The problem is known (e.g., see launchpad link above, or http://ubuntuforums.org/showthread.php?t=1234894&page=3), and several workarounds can be found, e.g., https://wiki.ubuntu.com/DebuggingSou...ge%20anomalies, but none did suffice for me, as they all left me with some channel controls disabled.

    I think I found another workaround which has not been posted here yet. The post is rather long. I'm sorry for that, but I wanted to provide at least a little background information, as well as a (hopefully) foolproof step-by-step guide to this workaround (ment to be usable by the average or even beginning user).

    My (sound) system setup
    • Ubuntu 10.04 (Lucid)
    • Sound Blaster Live Value, a PCI card with two 2channel analog output jacks
    • a traditional surround-4.0 speaker setup, i.e., two front and two rear speakers


    What I want
    The traditional 4.0 surround sound and the ability, to control the individual speakers properly.

    What I get
    The sound preferences gui lets me choose "Analog 4.0 output and Mono input", which matches my physical setup so far. All speakers are indeed working, but changing the volume results in very strange changes of the individual channel volumes: The rear speakers reach a high volume very quickly, and only after that, the front speakers catch up and finally even drown out the rear ones.

    Running "alsamixer" from a terminal reveals: Among others, my sound card has controls named Master, PCM, and, Surround. The first strange thing is: Master only controls the front speakers, Surround only the back speakers, and PCM both, but not in the same way. When increasing only the PCM control, the front speaker volume is actually increasing (much!) more than the rear speaker volume!

    Anyway, this first strangeness is totally up to ALSA, and not PulseAudio. In fact, PulseAudio correctly identifies the responsible channels. However, when increasing the volume via PulseAudio (now using the volume applet at the panel), at first, PCM is JUMPING to a high level, shortly afterwards followed by Surround, and finally, followed by Master. Furthermore, all unused channels (for me: Center and LFE) are set to 100% by PulseAudio.

    Apparently, this strange behavior has been observed many times before (see links provided above). Starting with Ubuntu 9.10 (Karmic), it happens each time, anything else than classical stereo sound is used.


    Which workarounds did NOT work
    If you don't understand everything/anything in here, don't mind, and skip to the next section.

    1. Passing "ignore_dB=yes" to module "module-udev-detect" or to module "module-alsa-card". This resulted in PulseAudio only controlling the master channel, i.e., my front speakers.
    2. Restrict controls to PCM-only, as has been proposed by others before. First of all, I want to control ALL of my four channels. Second of all, my PCM control itself is weird (as mentioned above).
    3. Using "module-detect" instead of "module-udev-detect". I didn't manage to get surround sound then, even if the number of channels has been set to 4 in daemon.conf.


    What finally DID work
    The solution for me was to deactivate any auto-detection and to use "module-alsa-sink" instead of "module-alsa-card" (which is used as the result of auto-detection via "module-udev-detect").

    Step-by-Step guide:

    1. Please start with a clean system, i.e., you have not tampered with any files in "/etc/pulse/", "~/.pulse/", "/usr/share/pulseaudio", or "/usr/share/alsa" (if you don't know what that is, you haven't).
    2. Open a terminal (Applications->Accessories->Terminal). From this point, any commands have to be typed in there, if not stated otherwise.
    3. Find the ALSA number of your sound card. If you only have one sound card, it is "0". Otherwise, run "aplay -l | grep card" (within the terminal, without the qoutes). See the word "card" followed by a digit followed by a string with the name of the sound card? Pick the digit. And don't worry that the same card is there multiple times.
    4. Run "cp /etc/pulse/default.pa ~/.pulse/". Now run "gedit ~/pulse/default.pa". A text editor with that file opened should pop up.
    5. Within the text editor, find line ".ifexists module-udev-detect.so". Outcomment this line by prepending a "#" to it. From this line, outcomment all following lines until the first ".endif", inclusively (you should now have typed in five "#" letters).
    6. Still within the text editor, and after the ".endif" line you just outcommented, add a line "load-module module-alsa-sink device=surround40:0" (without the qoutes, of course). Change the digit after the colon to the one of your card (see step 3). Change the "surround40" to your speaker setup accordingly. For example, for two front, one center, and two rear speakers, as well as a subwoofer (that has a separate jack at the sound card), change it to "surround51". Don't forget to save.
    7. Restart pulseaudio by running within the terminal "killall pulseaudio". PulseAudio will restart immediately with the new configuration. Please note, that any previous volume adjustments within the panel volume applet need to be done again (from PulseAudio's view, we now have a new device, for which no user settings exist yet).
    8. Make the terminal window wider and run "alsamixer". Now move the panel applet's volume slider around. If everything is ok, the sliders within alsamixer do NOT move, i.e., the hardware sliders do not move, but the volume is nevertheless actually changing. This means, PulseAudio now does the volume control in software, but this volume cannot exceed the maximum hardware settings. Therefore, within alsamixer, adjust the sliders to the balance and maximum volume you desire. For example, I have chosen Master and Surround to be 87%, and PCM to be 65%.


    Congratulations, you made it.

    Shortcomings of the approach
    Is this a solution? No, it is merely a workaround with several issues:
    1. Probably most severe, we now have a static setup. So forget your usb headset plugged in during runtime. Actually, currently we don't even have setup any static input (microphone).
    2. Volume control is done in software instead of hardware, which may result in suboptimal noise-loudness ratios.
    3. A verbose log showed that this method neither allowed for memory-mapped IO, nor for PulseAudio's timer-based scheduling method, although my card actually provides the required capabilities (shown in a log with the original flawed method). This means, both CPU load and latency may be suboptimal.
    4. From a user's point of view, setting up such a workaround is inacceptable.


    So lets hope that this issue is actually resolved eventually (it's known for over half a year now, *sigh*). Unless this isn't done, I will have to stick to the workaround.

    I hope this will help at least some of you.
    May the force be with you

    Best wishes,
    -- Stefan
    Last edited by stefan_g; May 26th, 2010 at 06:34 PM.

Page 3 of 5 FirstFirst 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •