Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 10.04 splash logo. Problem with NVIDIA?

  1. #1
    Join Date
    Apr 2008
    Location
    Waukesha, WI
    Beans
    56
    Distro
    Ubuntu 10.04 Lucid Lynx

    10.04 splash logo. Problem with NVIDIA?

    Took the plunge and installed 10.04 from scratch on my PanP4 and so far, so good. Very impressed and no problems to speak of. A lot quicker, but I have not bothered with Compiz this time (can go without the bell-whistles that I hardly used anyway).

    Only complaint is the new Ubuntu splash screen, which looks really bad (640x480). It was ok just running the Live CD, but changed to a lower resolution when I installed the NVIDIA driver (173).

    Anyone else had this problem and got a fix or will it be a wait for a new driver?

  2. #2
    Join Date
    Dec 2008
    Beans
    27

    Re: 10.04 splash logo. Problem with NVIDIA?

    You aren't alone. I'm very surprised that something this observable was allowed to pass through without being fixed by the Maintainers before final release.


    Some solutions (I can't comment what works yet)

    http://news.softpedia.com/news/How-t...4-140810.shtml
    http://www.ubuntuforums.org/showthread.php?t=1446132

  3. #3
    Join Date
    Apr 2008
    Location
    Waukesha, WI
    Beans
    56
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 splash logo. Problem with NVIDIA?

    The solution in the first link worked for me. Got the splash working at 1280x1024 on my 1680x1050 screen. Ta very much.
    Last edited by bgreenaway; May 2nd, 2010 at 04:11 PM.

  4. #4
    Join Date
    Sep 2006
    Location
    Denver, Colorado
    Beans
    5,638
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: 10.04 splash logo. Problem with NVIDIA?

    Yeah, it's a nasty Plymouth bug. For such a nice looking OS, that splash screen is a little embarrassing. I have a feeling the devs will send down an official fix for that one sooner rather than later.
    To err is human, to forgive is very ... dog-like.

    Thomas Aaron
    FetchMasters, LLC

  5. #5
    Join Date
    Dec 2008
    Beans
    35
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: 10.04 splash logo. Problem with NVIDIA?

    So Tom we should wait for the update?

  6. #6
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,544
    Distro
    Ubuntu

    Re: 10.04 splash logo. Problem with NVIDIA?

    Our official opinion is to wait for an update. It shouldn't be long since that is a pretty invasive bug.

    For those who really can't wait, if you have an Nvidia card installed, you can follow the following fix:

    Open a terminal (Applications > Accessories > Terminal) and run the following command:
    Code:
    sudo gedit /etc/default/grub
    You should get a text editor window. Add the following lines to the bottom of the file:
    Code:
    GRUB_GFXMODE=XXXXxYYYx32
    GRUB_GFXPAYLOAD_LINUX=keep
    where XXXXxYYY is your screen resolution, for example, 1280x800. leave the x32 on the end.

    Next, save and close the file. From the terminal, run
    Code:
    sudo update-grub2
    Once that command finishes, you should be set. Try rebooting to check.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  7. #7
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Question Re: 10.04 splash logo. Problem with NVIDIA?

    What bug are y'all talking about. As I understand it, the problem is an incompatibility between the proprietary nVidia driver and Lucid's Kernel Mode Setting (KMS). There is no bug in either, they just don't work together.

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  8. #8
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,544
    Distro
    Ubuntu

    Re: 10.04 splash logo. Problem with NVIDIA?

    It is actually a bug in plymouth. It happens across both proprietary drivers (Nvidia and ATI), plus if Mode Setting didn't work properly, plymouth should fall back to a text-mode boot. And, plymouth works fine with the open-source versions of the graphics drivers (on both ATI and Nvidia)
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  9. #9
    Join Date
    Aug 2010
    Beans
    2
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 splash logo. Problem with NVIDIA?

    This bug will be fixed in Ubuntu 10.04 yet or only in Ubuntu 10.04?

  10. #10
    Join Date
    Jan 2008
    Beans
    14

    Re: 10.04 splash logo. Problem with NVIDIA?

    Quote Originally Posted by Colt45 View Post
    The solution in the firs link works fine, thanks

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •