I just found this thread because I was looking for a solution to this very long standing annoyance - only this is the case in Debian, too (which I use, with Gnome3 no less). So it's a general GTK issue which can be configured I would assume...but I can't find anything online after a half an hour search frenzy (just confirmations).

There should really be a gconf setting for this, at least.