Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to disable splashscreen ?

  1. #1
    Join Date
    Dec 2007
    Beans
    28

    Smile How to disable splashscreen ?

    Hello,

    I have no interest in eye-candy. I want to know how do I disable the boot splashscreen completely. I prefer a text-only boot screen, without any images or animation.

    Thank you.


    NOTE: I am using Ubuntu 10.04 .
    Last edited by nomemory; May 1st, 2010 at 09:07 PM.

  2. #2
    Join Date
    Apr 2010
    Location
    England
    Beans
    3,286

    Re: How to disable splashscreen ?

    Edit /boot/grub/menu.lst. Remove "splash" from the kernel argument.

    If you're using grub2, I can't help. Try consulting the man pages.

  3. #3
    Join Date
    Mar 2008
    Location
    /home/evan
    Beans
    532
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to disable splashscreen ?

    To change the boot screen to text only, run the first command and choose option 2. Then run the command below it.
    Code:
    sudo update-alternatives --config default.plymouth
    sudo update-initramfs -u
    FX-4100, GA-970A-D3, CM Hyper 212+, 8GB G.Skill Ripjaws 1333, Kingston HyperX 3K 90GB SSD, 1TB Seagate 7200.12, nVidia GTX 480
    Windows 7 Pro (Ubuntu 12.04 VM), Ubuntu Server 12.04, Ubuntu User #31355
    Dropbox!

  4. #4
    Join Date
    Dec 2007
    Beans
    28

    Re: How to disable splashscreen ?

    Quote Originally Posted by linuxman94 View Post
    To change the boot screen to text only, run the first command and choose option 2. Then run the command below it.
    Code:
    sudo update-alternatives --config default.plymouth
    sudo update-initramfs -u
    I've tried the above command, unfortunately I don't have any option 2:
    Code:
    sudo update-alternatives --config default.plymouth
    There is only one alternative in link group default.plymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
    Nothing to configure.
    Any suggestions ?

  5. #5
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to disable splashscreen ?

    How about editing /etc/default/grub? Find the following line and remove 'splash'.
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    When done, run sudo update-grub

  6. #6
    Join Date
    Mar 2008
    Location
    /home/evan
    Beans
    532
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to disable splashscreen ?

    Oops. I forgot you have to install the text theme.

    Code:
    sudo apt-get install plymouth-theme-ubuntu-text
    Then run:

    Code:
    sudo update-alternatives --config default.plymouth
    sudo update-initramfs -u
    FX-4100, GA-970A-D3, CM Hyper 212+, 8GB G.Skill Ripjaws 1333, Kingston HyperX 3K 90GB SSD, 1TB Seagate 7200.12, nVidia GTX 480
    Windows 7 Pro (Ubuntu 12.04 VM), Ubuntu Server 12.04, Ubuntu User #31355
    Dropbox!

  7. #7
    Join Date
    Dec 2005
    Beans
    136

    Re: How to disable splashscreen ?

    Quote Originally Posted by linuxman94 View Post
    Oops. I forgot you have to install the text theme.

    Code:
    sudo apt-get install plymouth-theme-ubuntu-text
    Then run:

    Code:
    sudo update-alternatives --config default.plymouth
    sudo update-initramfs -u
    While this does get rid of the fancy graphics, it doesn't get rid of the splash screen, and still hides the important text that used to show. You must still press escape to see this, and it doesn't even show all of it. Is there any way to tell plymouth to not splash at all? If not, there should be. This has caused me plenty of headaches, the most important being that I can no longer see the progress of fsck on my very large data partition (even after pressing escape).

  8. #8
    Join Date
    Sep 2008
    Location
    Singapore
    Beans
    125
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to disable splashscreen ?

    Quote Originally Posted by mikewhatever View Post
    How about editing /etc/default/grub? Find the following line and remove 'splash'.
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    When done, run sudo update-grub
    remove the quiet too to show boot messages.

  9. #9
    Join Date
    Apr 2008
    Location
    Arizona
    Beans
    398
    Distro
    Ubuntu

    Question Re: How to disable splashscreen ?

    I'm running UBUNTU 9.10 and I want to keep my BOOT splash screen but I would like to remove the SHUTDOWN splash screen.

    The reason I ask is because the shutdown splash is extremely distorted and the Ubuntu logo runs across the screan Diagionally from right to left and slowly moving down... it looks like poop!

    So my ultimate solution would be to have the splash fixed to show a solid flashing ubuntu logo just like in boot up.

    Is that possible?
    (PS my netbook is posted in my sig)

    EDIT: I found this post. Look at post number 3, Would this help?
    http://ubuntuforums.org/showthread.php?t=865670
    Last edited by emoguitarist06; July 16th, 2010 at 02:20 AM.

  10. #10
    Join Date
    Mar 2008
    Location
    /home/evan
    Beans
    532
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to disable splashscreen ?

    @emoguitarist06

    You will get better help if you create a new thread.
    FX-4100, GA-970A-D3, CM Hyper 212+, 8GB G.Skill Ripjaws 1333, Kingston HyperX 3K 90GB SSD, 1TB Seagate 7200.12, nVidia GTX 480
    Windows 7 Pro (Ubuntu 12.04 VM), Ubuntu Server 12.04, Ubuntu User #31355
    Dropbox!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •