Results 1 to 6 of 6

Thread: Mygica X8550 - CX23885

  1. #1
    Join Date
    May 2010
    Beans
    2

    Exclamation Mygica X8550 - CX23885

    Hello all,
    I am new here as a registered user, but have been using and referring to ubuntu forums for the past 3 years now. I have always found my answers here and never really had to register, but this question is driving me to the edge of my seat.
    Some details- Ubuntu 10.04, 64 bit computer.
    I have a MygicaX8550A TV Tuner(PCI-E) and am unable to get it up and running in ubuntu. here is what lshw show it as:
    Code:
    *-pci:3
              description: PCI bridge
              product: MCP78S [GeForce 8200] PCI Bridge
              vendor: nVidia Corporation
              physical id: 13
              bus info: pci@0000:00:13.0
              version: a1
              width: 32 bits
              clock: 33MHz
              capabilities: pci pm msi ht pciexpress bus_master cap_list
              configuration: driver=pcieport
              resources: irq:26 memory:fea00000-febfffff
            *-multimedia
                 description: Multimedia video controller
                 product: CX23885 PCI Video and Audio Decoder
                 vendor: Conexant Systems, Inc.
                 physical id: 0
                 bus info: pci@0000:04:00.0
                 version: 02
                 width: 64 bits
                 clock: 33MHz
                 capabilities: pciexpress pm vpd msi bus_master cap_list
                 configuration: driver=cx23885 latency=0
                 resources: irq:17 memory:fea00000-febfffff
    And here is dmesg:
    [ 643.452852] cx23885 0000:04:00.0: PCI INT A disabled
    [ 674.043717] Linux video capture interface: v2.00
    [ 674.051917] cx23885 driver version 0.0.2 loaded
    [ 674.052193] cx23885 0000:04:00.0: PCI INT A -> Link[LN3A] -> GSI 17 (level, low) -> IRQ 17
    [ 674.052205] cx23885[0]: Your board isn't known (yet) to the driver.
    [ 674.052207] cx23885[0]: Try to pick one of the existing card configs via
    [ 674.052209] cx23885[0]: card=<n> insmod option. Updating to the latest
    [ 674.052211] cx23885[0]: version might help as well.
    [ 674.052215] cx23885[0]: Here is a list of valid choices for the card=<n> insmod option:
    [ 674.052219] cx23885[0]: card=0 -> UNKNOWN/GENERIC
    [ 674.052222] cx23885[0]: card=1 -> Hauppauge WinTV-HVR1800lp
    [ 674.052226] cx23885[0]: card=2 -> Hauppauge WinTV-HVR1800
    [ 674.052230] cx23885[0]: card=3 -> Hauppauge WinTV-HVR1250
    [ 674.052233] cx23885[0]: card=4 -> DViCO FusionHDTV5 Express
    [ 674.052236] cx23885[0]: card=5 -> Hauppauge WinTV-HVR1500Q
    [ 674.052239] cx23885[0]: card=6 -> Hauppauge WinTV-HVR1500
    [ 674.052242] cx23885[0]: card=7 -> Hauppauge WinTV-HVR1200
    [ 674.052245] cx23885[0]: card=8 -> Hauppauge WinTV-HVR1700
    [ 674.052248] cx23885[0]: card=9 -> Hauppauge WinTV-HVR1400
    [ 674.052252] cx23885[0]: card=10 -> DViCO FusionHDTV7 Dual Express
    [ 674.052255] cx23885[0]: card=11 -> DViCO FusionHDTV DVB-T Dual Express
    [ 674.052258] cx23885[0]: card=12 -> Leadtek Winfast PxDVR3200 H
    [ 674.052262] cx23885[0]: card=13 -> Compro VideoMate E650F
    [ 674.052265] cx23885[0]: card=14 -> TurboSight TBS 6920
    [ 674.052268] cx23885[0]: card=15 -> TeVii S470
    [ 674.052271] cx23885[0]: card=16 -> DVBWorld DVB-S2 2005
    [ 674.052274] cx23885[0]: card=17 -> NetUP Dual DVB-S2 CI
    [ 674.052277] cx23885[0]: card=18 -> Hauppauge WinTV-HVR1270
    [ 674.052280] cx23885[0]: card=19 -> Hauppauge WinTV-HVR1275
    [ 674.052283] cx23885[0]: card=20 -> Hauppauge WinTV-HVR1255
    [ 674.052286] cx23885[0]: card=21 -> Hauppauge WinTV-HVR1210
    [ 674.052289] cx23885[0]: card=22 -> Mygica X8506 DMB-TH
    [ 674.052292] cx23885[0]: card=23 -> Magic-Pro ProHDTV Extreme 2
    [ 674.052295] cx23885[0]: card=24 -> Hauppauge WinTV-HVR1850
    [ 674.052298] cx23885[0]: card=25 -> Compro VideoMate E800
    [ 674.052539] CORE cx23885[0]: subsystem: 14f1:8503, board: UNKNOWN/GENERIC [card=0,autodetected]
    [ 674.179960] cx23885_dev_checkrevision() Hardware revision = 0xb0
    [ 674.179967] cx23885[0]/0: found at 0000:04:00.0, rev: 2, irq: 17, latency: 0, mmio: 0xfea00000
    [ 674.179975] cx23885 0000:04:00.0: setting latency timer to 64
    [ 674.179979] IRQ 17/cx23885[0]: IRQF_DISABLED is not guaranteed on shared IRQs
    Please help me get this up and running, I have scoured through this forum and the INTERNET to find an answer, but to no avail. Please help me get this card running because this is the only thing that is holding me from completely moving away from 7.
    I shall be here all day waiting for responses. If you need more information, let me know.

    Thanks,
    KB
    Last edited by kochu_baby; May 1st, 2010 at 04:58 PM. Reason: Added details

  2. #2
    Join Date
    May 2010
    Beans
    2

    Re: Mygica X8550 - CX23885

    Some help guys. really need this to work

  3. #3
    Join Date
    Aug 2009
    Beans
    3

    Re: Mygica X8550 - CX23885

    Create a config file:

    Code:
    sudo nano -w /etc/modprobe.d/cx23885.conf
    and type in the following line:

    Code:
    options cx23885 card=20
    save the file and reboot.

    This worked for me... thanks to kc on #ubuntu-mythtv on the freenode irc network for helping me figure this one out. I would imagine that if this doesn't work for you, you could also try using the other Hauppauge HVR-12xx card numbers and hopefully one would work.

    Edit: sorry. I was looking for a different post that I had come across involving the HVR-1250 card. After posting this, I realised that you aren't using a Hauppauge card. I should have looked closer. Anyway, maybe it can't hurt to just go down the list until one hopefully works?
    Last edited by Inflatable Soulmate; June 26th, 2010 at 03:09 AM.

  4. #4
    Join Date
    Nov 2007
    Beans
    4

    Re: Mygica X8550 - CX23885

    Sorry to dredge up an old topic, but I was curious if a solution had been figured out to get the X8550 card working?

  5. #5
    Join Date
    Jan 2013
    Beans
    1

    Re: Mygica X8550 - CX23885

    Hy I had the same problem with my PCI-E TV Card based on cx23885.
    Then I create config file in /etc/modprobe.d after resetting PC
    with Ubuntu 12.04 LTS the driver cx23885.ko was loaded and then PCI-E TV Card are defines correctly. But I stil have not /dev/video{N} or /dev/dvb{N} in udev parent root.
    I`d read RTFM about udev, udevd and udevadm but really nothing understand how can I make the rule for this device.
    So I want to ask somebody help me
    Give me please for an example a listing of its files-of-rules.rules from /etc/udev/rules.d directory
    Thanks heaps all.
    Last edited by sirota; January 9th, 2013 at 01:23 AM. Reason: syntax mistake

  6. #6
    Join Date
    Feb 2007
    Beans
    23,515
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Mygica X8550 - CX23885

    From the Ubuntu Forums Code of Conduct.
    If a post is older than a year or so and hasn't had a new reply in that time, instead of replying to it, create a new thread. In the software world, a lot can change in a very short time, and doing things this way makes it more likely that you will find the best information. You may link to the original discussion in the new thread if you think it may be helpful.
    Thread closed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •