Results 1 to 9 of 9

Thread: mplayer went missing

  1. #1
    Join Date
    Jun 2008
    Beans
    17

    mplayer went missing

    Hi,
    I have upgraded (so it's not a clean new installation) from Karmic to Lucid yesterday and all is smooth with the exception of mplayer. It's shortcut disappeared from the Main Menu, it also cannot be found in the Open With tab, Preferences menu of files.
    I removed it and downloaded it again (sudo apt-get install mplayer), but it's still the same. I tried using SMplayer then but it shows me an error (MPlayer has finished unexpectedly. Exit code: 1), no matter what type of file I choose (or what type of output driver). In the meantime, VLC works with pretty much everything.
    Lastly: I tried running mplayer from the terminal and it worked (no gui though, gmplayer gives me an error that there's no skin file in specified directory, but I don't think it's my main concern right now).
    I also downloaded mplayer source from their website and compiled & installed it. It came up in the Main Menu and Open With but wasn't even working and I'm not quite sure where it did actually go and what happens with it now (My Ubuntu's system partition is kind of a dark well to me - I drop things inside and sometimes don't even hear the splash).

    If it's not the lucid or mplayers fault then it must be, because I'm not really grasping the whole picture here. I'm a beginner, as you can tell

    Any help will be appreciated, any smiting will be humbly born.
    Last edited by greebothecat; May 1st, 2010 at 02:55 PM.

  2. #2
    Join Date
    Aug 2009
    Location
    UK
    Beans
    204
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: mplayer went missing

    You could try this :-


    Install Mplayer in Ubuntu 10.04 (Lucid)
    You have to make sure you have enabled universe,multiverse repositories
    Now you need to run the following command to update the source list
    sudo apt-get update
    Install mplayer using the following command
    sudo apt-get install mplayer
    or
    Click on the following link
    If you want to open mplayer go to Applications—>Sound&Video—> Mplayer Movie Player
    Install w32 video codecs and libdvdcss2 in Ubuntu 10.04 (Lucid)



    The following command adds Medibuntu’s repository to Ubuntu. It also adds Medibuntu’s GPG key to your keyring, which is needed to authenticate the Medibuntu packages.
    sudo wget http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list --output-document=/etc/apt/sources.list.d/medibuntu.list
    sudo apt-get -q update
    sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring
    sudo apt-get -q update
    For i386 Users install Codecs using the following command
    sudo apt-get install w32codecs libdvdcss2
    For amd64 Users install Codecs using the following command
    sudo apt-get install w64codecs libdvdcss2
    Using above download locations you can install most of the mutimedia codecs for ubuntu.
    Mplayer Plugin for Firefox
    If you want to install Mplayer with plug-in for Mozilla Firefox run the following command
    sudo apt-get install mozilla-mplayer
    or click on the following link
    apt://mozilla-mplayer
    This is in Open Office Format.

    This is MS Office format



    Install Mplayer in Ubuntu 10.04 (Lucid)
    You have to make sure you have enabled universe,multiverse repositories
    Now you need to run the following command to update the source list
    sudo apt-get update
    Install mplayer using the following command
    sudo apt-get install mplayer
    or
    Click on the following link
    If you want to open mplayer go to Applications—>Sound&Video—> Mplayer Movie Player
    Install w32 video codecs and libdvdcss2 in Ubuntu 10.04 (Lucid)



    The following command adds Medibuntu’s repository to Ubuntu. It also adds Medibuntu’s GPG key to your keyring, which is needed to authenticate the Medibuntu packages.
    sudo wget http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list --output-document=/etc/apt/sources.list.d/medibuntu.list
    sudo apt-get -q update
    sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring
    sudo apt-get -q update
    For i386 Users install Codecs using the following command
    sudo apt-get install w32codecs libdvdcss2
    For amd64 Users install Codecs using the following command
    sudo apt-get install w64codecs libdvdcss2
    Using above download locations you can install most of the mutimedia codecs for ubuntu.
    Mplayer Plugin for Firefox
    If you want to install Mplayer with plug-in for Mozilla Firefox run the following command
    sudo apt-get install mozilla-mplayer
    or click on the following link


  3. #3
    Join Date
    Jun 2008
    Beans
    17

    Re: mplayer went missing

    Yeah, I can google this Ubuntugeek Tutorial too. I've tried that already.
    (libdvdcss2 is not available at the moment from Medibuntu's repository..)

    I have wiped my system partition clean and did a fresh new Lucid installation (kept the old /home partition, though) and the problem is still there: after installing mplayer, it's not shown in the Apps menu, nor does it work with SMplayer..

    Is the lucid mplayer release broken or is it just me?

  4. #4
    Join Date
    Aug 2008
    Beans
    1

    Smile Re: mplayer went missing

    Hello here is the reason

    From synaptic package "gecko-mediaplayer"
    Multimedia plug-in for Gecko browsers

    Gecko Media Player is a browser plug-in that uses GNOME MPlayer
    and Mplayer to play media in a browser.
    It uses the NS4 API and is therefore compatible with all NS4 derived browsers:
    Iceweasel, Firefox, Iceape, Epiphany, Galeon, Midbrowser, Xulrunner, etc.

    It is the modern replacement for mplayerplug-in (from the same author).
    So install gecko-mediaplayer insted of mozilla-mplayer, it is exact as mozilla-mplayer but a bit better and nicer look,

    You will also get a try-icon near the clock where you can control the player without changing tab in Firefox, I like it

  5. #5
    Join Date
    Jun 2008
    Beans
    17

    Re: mplayer went missing

    Thanks, but I don't even use Firefox (Chrome user here), so I don't have a problem with the browser plug-in.

    My problem is with mplayer not working other than from terminal and not being compatible with SMplayer (and not showing in the Main Menu or Open With menu).
    Last edited by greebothecat; May 3rd, 2010 at 05:34 PM.

  6. #6
    Join Date
    Jun 2007
    Beans
    13,059

    Re: mplayer went missing

    My problem is with mplayer not working other than from terminal
    The lucid repo mplayer and your svn build are command line only, for a gui you need to install one. the most common being smplayer or gnome-mplayer
    not showing in the Main Menu
    being only cli you shouldn't expect it to.
    not being compatible with SMplayer
    That's what you should look at - there is a log viewer in smplayer's options - the mplayer log, the smplayer log

    You mentioned building mplayer and installing the repo version - you shouldn't have both installed at the same time.

    How did you install your svn build - sudo make install or checkinstall?

  7. #7
    Join Date
    Jun 2008
    Beans
    17

    Re: mplayer went missing

    I used sudo apt-get install to get mplayer

    Thanks, I found the log and I'll try to figure out now what it says.

    Here it is, if you could cast an eye on it, I'd be grateful!

    Code:
    /usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xvidix -ao alsa, -nokeepaspect -framedrop -nodr -double -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 79692294 -monitorpixelaspect 1 -*** -embeddedfonts -***-line-spacing 0 -***-font-scale 1 -***-styles /home/greebo/.config/smplayer/styles.*** -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -vid 0 -aid 1 -subpos 100 -cache 2000 -ss 17 -osdlevel  -vf-add screenshot -slices -channels 2 -af equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/greebo/Videos/anime/Afro Samurai/Afro Samurai episode 1.avi
    
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    bt_audio_service_open: connect() failed: Connection refused (111)
    MPlayer SVN-r1.0~rc3+svn20090426-4.4.3 (C) 2000-2009 MPlayer Team
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    Terminal type `unknown' is not defined.
    
    Playing /home/greebo/Videos/anime/Afro Samurai/Afro Samurai episode 1.avi.
    
    Cache fill:  0.00% (0 bytes)   
    AVI file format detected.
    ID_VIDEO_ID=0
    [aviheader] Video stream found, -vid 0
    ID_AUDIO_ID=1
    [aviheader] Audio stream found, -aid 1
    VIDEO:  [XVID]  592x320  12bpp  23.976 fps  1085.1 kbps (132.5 kbyte/s)
    Clip info:
     Software: VirtualDubMod 1.5.10.2 (build 2540/release)
    ID_CLIP_INFO_NAME0=Software
    ID_CLIP_INFO_VALUE0=VirtualDubMod 1.5.10.2 (build 2540/release)
    ID_CLIP_INFO_N=1
    ID_FILENAME=/home/greebo/Videos/anime/Afro Samurai/Afro Samurai episode 1.avi
    ID_DEMUXER=avi
    ID_VIDEO_FORMAT=XVID
    ID_VIDEO_BITRATE=1085112
    ID_VIDEO_WIDTH=592
    ID_VIDEO_HEIGHT=320
    ID_VIDEO_FPS=23.976
    ID_VIDEO_ASPECT=0.0000
    ID_AUDIO_FORMAT=85
    ID_AUDIO_BITRATE=127008
    ID_AUDIO_RATE=0
    ID_AUDIO_NCH=0
    ID_LENGTH=1575.62
    ID_SEEKABLE=1
    ID_CHAPTERS=0
    No vidix driver name provided, probing available ones (-v option for details)!
    [VO_SUB_VIDIX] Couldn't find working VIDIX driver.
    Error opening/initializing the selected video_out (-vo) device.
    [cyberblade] Error occurred during pci scan: Operation not permitted
    [mach64] Error occurred during pci scan: Operation not permitted
    [mga] Error occurred during pci scan: Operation not permitted
    [mga] Error occurred during pci scan: Operation not permitted
    [nvidia_vid] Error occurred during pci scan: Operation not permitted
    [pm3] Error occurred during pci scan: Operation not permitted
    [radeon] Error occurred during pci scan: Operation not permitted
    [rage128] Error occurred during pci scan: Operation not permitted
    [s3_vid] Error occurred during pci scan: Operation not permitted
    [SiS] Error occurred during pci scan: Operation not permitted
    [unichrome] Error occurred during pci scan: Operation not permitted
    ==========================================================================
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
    ID_AUDIO_BITRATE=128000
    ID_AUDIO_RATE=48000
    ID_AUDIO_NCH=2
    Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
    ==========================================================================
    AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
    ID_AUDIO_CODEC=mp3
    Video: no video
    Starting playback...
    
    
    MPlayer interrupted by signal 11 in module: seek
    ID_SIGNAL=11
    - MPlayer crashed by bad usage of CPU/FPU/RAM.
      Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
      disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
    - MPlayer crashed. This shouldn't happen.
      It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
      gcc version. If you think it's MPlayer's fault, please read
      DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
      won't help unless you provide this information when reporting a possible bug.
     [ This binary of MPlayer in Debian is currently compiled with
       '--enable-debug'; the debugging symbols are in the package
       'mplayer-dbg'.]

  8. #8
    Join Date
    Jun 2007
    Beans
    13,059

    Re: mplayer went missing

    /usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xvidix
    I gotta go to work so only a quick mention of a few of your options here (which are numerous as far as mplayer, smplayer, using a built version, the repo version or from any number of ppa's

    smplayer is using the mplayer in /usr/bin, did you configure your build to install there or do you also have the repo mplayer installed?

    The video output of xvidix is not going to work - no such thing

    Assuming your build of mplayer is good and it works from the cli I'd try this
    open synaptic, search mplayer and remove if installed (inc. mplayer-nogui
    also search smplayer and remove

    Then open a terminal and
    Code:
    sudo apt-get install checkinstall
    When done then cd to your mplayer build source folder and run
    Code:
    sudo make uninstall
    when done use this to install as a package
    Code:
    sudo checkinstall -D --install=yes --fstrans=no --pakdir "$HOME/Desktop" --pkgname mplayer --backup=no --deldoc=yes --deldesc=yes --delspec=yes --default --pkgversion "3:1.0~svn-`grep "#define VERSION" version.h | cut -d"-" -f2`"
    Then open home folder, ( view -> show hidden files) and open .config and delete the smplayer folder
    Then re-install smplayer

    If your not sure about your mplayer build then you could check out this how to or just remove your checkinstall mplayer build in synaptic and try the repo one or a ppa ,ect.
    http://ubuntuforums.org/showthread.p...ht=svn+mplayer

    an updated build dep list for lucid is in post 241 (last page

    because you keep your /home I'd delete the smplayer folder as described - you'll may also have a .mplayer folder with a config file inside - don't delete, just look and see if anything is improper

    You could also install gnome-mplayer to d. check your mplayer build

  9. #9
    Join Date
    Jul 2007
    Location
    Prague, Czech Republic
    Beans
    4
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: mplayer went missing

    Quote Originally Posted by oussama View Post
    Hello here is the reason

    From synaptic package "gecko-mediaplayer"


    So install gecko-mediaplayer insted of mozilla-mplayer, it is exact as mozilla-mplayer but a bit better and nicer look,

    You will also get a try-icon near the clock where you can control the player without changing tab in Firefox, I like it
    Thanks a lot Oussama
    Didn't know that, you saved a lot of my time.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •