Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Issues with FN keys - Ubuntu 10.04

  1. #11
    Join Date
    Mar 2007
    Beans
    10

    Re: [SOLVED] Issues with FN keys - Ubuntu 10.04

    For anyone that has the backlight working with the Fn + F5 and Fn + F6 keys could you answer these questions?

    1) Which UL30? (A, Vt, or ?)
    2) Which kernel (Default lucid? Something newer from PPA? Which?)
    3) Which GPU are you using (if a Vt)?
    4) Which driver? (Default lucid, noveau, proprietary nvidia?)
    5) Did you apply the acpi_backlight=vendor grub tweak?
    6) Do you see the alpha blended brightness display when changing the
    brightness?
    7) Does the brightness actually change?

  2. #12
    Join Date
    Apr 2010
    Location
    Phoenix, Arizona
    Beans
    19
    Distro
    Ubuntu

    Re: Issues with FN keys - Ubuntu 10.04

    Has this issue been figured out? I have a UL80VT and can't change my brightness. I get the brightness indicator, but the brightness never actually changes.

  3. #13
    Join Date
    Apr 2010
    Beans
    33

    Re: Issues with FN keys - Ubuntu 10.04

    @sbik:

    1) Ul30A
    2) Default kernel, 2.6.33 I guess
    3) onboard...
    4) see 3)
    5) yes
    6) yes
    7) yes

  4. #14
    Join Date
    May 2010
    Beans
    10

    Re: Issues with FN keys - Ubuntu 10.04

    How do I update my kernel to .34rc6?

    Just curious about the power consumption no 9.9 watts in laptopmode


    FYI:

    1) Which UL30? A
    2) Which kernel Default lucid?
    3) Which GPU are you using intel
    4) Which driver? Default lucid
    5) Did you apply the acpi_backlight=vendor grub tweak? Yes
    6) Do you see the alpha blended brightness display when changing the
    brightness? Yes
    7) Does the brightness actually change? YES
    Last edited by Orcie; May 12th, 2010 at 12:59 PM.

  5. #15
    Join Date
    Sep 2009
    Beans
    11

    Re: [SOLVED] Issues with FN keys - Ubuntu 10.04

    1) Which UL30? A
    2) Which kernel? 2.6.32-22
    3) Which GPU are you using (if a Vt)?
    4) Which driver? Default lucid
    5) Did you apply the acpi_backlight=vendor grub tweak? yup
    6) Do you see the alpha blended brightness display when changing the
    brightness?yes
    7) Does the brightness actually change? Sporadically

  6. #16
    Join Date
    Apr 2006
    Beans
    140

    Re: Issues with FN keys - Ubuntu 10.04

    Well,

    for me the solution works. I have an ul30a.

    Just a tip. I use burg instead of grub.

    so you have to put
    Code:
    GRUB_CMDLINE_LINUX="acpi_backlight=vendor"
    in the file
    Code:
    /etc/default/burg
    Edit: do not forget to sudo update-burg after editing the file
    Last edited by loko; May 31st, 2010 at 03:25 PM. Reason: forgot the tip to update-burg

  7. #17
    Join Date
    Mar 2009
    Beans
    41

    Re: Issues with FN keys - Ubuntu 10.04

    This thread ROCKS!

    This method also works for the Asus U81A laptop. I have a U81A, and 2 things have to be done in order for the fn keys screen brightness to work:

    1) update the BIOS to version 210. This Bios hasn't been released yet, but I used the U80 BIOS as they are essentially the same hardware, but the U81A was exclusive to Best Buy.
    2) use the method described in this thread.

    Thanks a bunch!!

  8. #18
    Join Date
    Jul 2010
    Beans
    1

    Re: Issues with FN keys - Ubuntu 10.04

    For users like me which this method didn't work. I found a new method working on Asus PC.
    check here and modify your GRUB_CMDLINE_LINUX_DEFAULT
    http://www.webupd8.org/2010/05/enabl...eeepc-and.html

  9. #19
    Join Date
    Jul 2010
    Beans
    1

    Re: Issues with FN keys - Ubuntu 10.04

    Hey I have a Toshiba Satellite M45-S331, and my function keys don't work either. I've tried the options in this thread, but none of them have worked for me. Is there anything else I can do to fix the issue?

  10. #20
    Join Date
    Jul 2010
    Beans
    6

    Re: Issues with FN keys - Ubuntu 10.04

    This is what worked for me.Thanx Silvan

    1. Find out the vendor string used by hal:
    $ lshal | grep system.hardware.vendor
    (In my case: system.hardware.vendor = 'Sony Corporation )
    2. Find out the product string:
    $ lshal | grep system.hardware.product
    (In my case: system.hardware.product = 'VGN-CR35G_R' )
    3. Open /usr/share/hal/fdi/information/10freedesktop/10-laptop-panel-hardware.fdi in an editor with root privileges
    4. Add this line
    <match key="/org/freedesktop/Hal/devices/computer:system.hardware.vendor" string="Sony Corporation">
    <match key="/org/freedesktop/Hal/devices/computer:system.hardware.product" contains_outof="VGN-CR35G_R">
    <!-- needed since the acpi video module reports it handle the events, but it don't work on this machines-->
    <merge key="laptop_panel.brightness_in_hardware" type="bool">false</merge>
    </match>
    </match>
    5. Reboot!

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •