Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: HOWTO: Disable password request after suspend

  1. #1
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Beans
    593
    Distro
    Ubuntu 14.04 Trusty Tahr

    HOWTO: Disable password request after suspend

    An annoying feature/bug of Ubuntu is:

    When the computer resumes from suspend, the screen will be locked. In fact, the screen will be locked even if you have enabled automatic login and set the computer not-to-lock, when screen saver is activated.

    Initially this post only included my own solution, but for convenience I've also added the (IMO) most promising solutions suggested by other users in this thread as well. If none of these suggestions worked for you, and you've found another solution that does, please post it here so I can add it as well.


    How to fix?


    10.04 Solution

    1. As you've probably already done, uncheck:
    "lock screen when screen saver is activated"
    in the System->Preferences->Screen Saver menu.

    2. Type gconf-editor in a terminal. Under apps/gnome-power-manager/locks check:
    "use_screensaver_settings".

    3. If still asked for password, you can (also in gconf-editor) go to desktop/gnome/lockdown and check:
    "disable_lock_screen"
    Credit to itslofty below for this tip!

    PS. For some reason my mouse doesn't show up after resume. To get it back I just switch to another workspace and then back again, i.e: ctrl+alt+rightarrow and then ctrl+alt+leftarrow.


    11.10 Solution

    1. First try the Lock/Unlock button in System Settings -> Personal -> Screen (suggested by brallan, below).

    2. If this doesn't work, try the command
    Code:
    gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true'
    see RaymandJr's post below for further info.
    Last edited by tom4everitt; November 2nd, 2011 at 10:49 AM.
    Since when is floor not a synonym of horizontal wardrobe?

  2. #2
    Join Date
    Feb 2008
    Beans
    19

    Re: HOWTO: Disable password request after suspend

    ...same solution, slightly different method:
    Under System > Preferences I don't have a "screensaver" control panel enabled, but I can access it through Gconf.
    I start gconf from an icon that I enabled:
    Applications > System Tools > Configuration Editor
    Then:
    Under apps/gnome-power-manager/locks, check:
    "use_screensaver_settings".
    And then:
    Under apps/gnome-screensaver, uncheck:
    "lock_enabled".
    Thanks for the lead on this, tom4everitt!
    Last edited by MetroPietro; May 2nd, 2010 at 09:52 PM. Reason: acknowledgment of previous poster

  3. #3
    Join Date
    Sep 2009
    Location
    Alabama, USA
    Beans
    8
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Disable password request after suspend

    The method described by tom4everitt to disable lock after resume from suspend works for me when I suspend with ctrl-alt-delete, but not when I suspend by clicking the power button.

    This is not a critical problem, but stumped me until I discovered the work around.
    Last edited by oldwismn; May 3rd, 2010 at 11:21 PM.

  4. #4
    Join Date
    Jul 2008
    Beans
    Hidden!

    Re: HOWTO: Disable password request after suspend

    Clean install of 10.4 nettop ed I can confirm suspend still wants a password even with all the correct options check/unchecked in gconf.

    Please someone a solution.

  5. #5
    Join Date
    Jul 2005
    Location
    Hughenden, Australia
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Disable password request after suspend

    EDIT: Reply not relevant to thread title, deleted.
    Last edited by Herman; May 4th, 2010 at 08:13 AM.
    Ubuntu user since 2004 (Warty Warthog)

  6. #6
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Beans
    593
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Disable password request after suspend

    Apparently there is one more place where you can disable the password request. In the file /etc/default/acpi-support there is a line
    Code:
    LOCK_SCREEN=true
    which can be commented out to disable screen lock. So just put a '#' in front of it, making it:
    Code:
    # LOCK_SCREEN=true
    If someone can confirm that this works better for him/her, I'll add it to the top post.
    Since when is floor not a synonym of horizontal wardrobe?

  7. #7
    Join Date
    Sep 2009
    Location
    Alabama, USA
    Beans
    8
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Disable password request after suspend

    I tried commenting out the "LOCK_SCREEN=true" line in /etc/default/acpi-support and also changing the line to "LOCK_SCREEN=false". Neither of these changes allowed resume from suspend without a password when I suspended by clicking the button at the right top of the screen (the "Indicator Applet Session" button) . The changes listed by tom4everitt in the top post allowed me to resume without a password when I suspended by hitting Ctrl+Alt+Delete and then selecting Suspend or used the "Shut Down" applet button.
    Last edited by oldwismn; May 8th, 2010 at 03:28 PM. Reason: Added new information.

  8. #8
    Join Date
    Nov 2009
    Beans
    16

    Re: HOWTO: Disable password request after suspend

    There are more than one way to initiate a suspend in Ubuntu, not all of them use the same settings.. For more discussion on this also see this bug report
    Last edited by MoarningSun; May 5th, 2010 at 07:58 PM.

  9. #9
    Join Date
    Jan 2010
    Beans
    9
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Disable password request after suspend

    This was driving me nuts, I was hunting everywhere for autologin not working... took me a while to realize it was a totally separate issue.

    Thanks to tom4everitt, his first post worked for me perfectly.

  10. #10
    Join Date
    May 2010
    Location
    Norway
    Beans
    22
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Disable password request after suspend

    Can I use the gconf-editor to disable password when using user switch?
    If so, could anyone please point me in the right direction?

    I have two user accounts, neither needs password on first login but when switching users, they are prompted for pw. Not needed at all in my enviroment.
    Screensaver pw is disabled for both accounts.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •