Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: 10.04 wireless RT2860 bug 545443 in need of extra love?

  1. #1
    Join Date
    Aug 2008
    Location
    Sweden
    Beans
    77

    10.04 wireless RT2860 bug 545443 in need of extra love?

    Hi!

    "Lucid on Asus EEE PC 901 and 1000H fails to connect to any wireless network" https://bugs.launchpad.net/ubuntu/+s...ux/+bug/545443

    Edit: This bug is marked as a dupe of this more active bug: https://bugs.launchpad.net/ubuntu/+s...ux/+bug/496093 So, it isn't as unloved as I previously thought. [/Edit]


    Seems this affects quite popular netbooks and was working in 9.10, making it a regression.

    Apparently not all eee pc 901 or eee pc 1000H users are affected, but still, the bugs importance is "undecided" and it is also "unassigned", which to me doesn't seem proper.

    If someone could explain why I might be wrong or how to contribute to the bug report (I have an affected eee pc 901), that'd be swell. Peace.
    Last edited by tahina; April 30th, 2010 at 10:01 AM.

  2. #2
    Join Date
    Apr 2008
    Beans
    33

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?

    Does anybody know how to fix the non-working RT2860 in the Asus eee 901 in a manner that would allow us to use all wireless networks through the network manager GUI AND continue to work after any official updates ?

  3. #3
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?


  4. #4
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?

    other way, download and install (with gdebi, install it first) the deb file:

    http://packages.debian.org/en/sid/al...ource/download
    then, check wifi quality, if it dont work, download the source and do into console:

    sudo apt-get install debhelper module-assistant
    sudo m-a a-i rt2860
    sudo modprobe rt2860sta
    sudo echo rt2860sta >> /etc/modules

    ( use copy/paste its easier)
    Last edited by dino99; April 30th, 2010 at 10:09 AM.

  5. #5
    Join Date
    Aug 2008
    Location
    Sweden
    Beans
    77

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?

    I just noticed this bug, #545443 is marked as a duplicate of bug #496093 with the somewhat misleading title "[lucid] rt2860 frequently fails to connect to mixed mode WPA/WPA2 secured wireless networks".

    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/496093

    The title is misleading in the sense that I don't have mixed mode, just wpa2. But it seems other people on that bug report don't have mixed mode either, so it being duplicate may be right.

    So, it seems this bug isn't as unloved as I previously thought. That's good.

  6. #6
    Join Date
    Apr 2008
    Beans
    33

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?

    Thanks for the post dino99, I'll have a look when I get home tonight but I'm a bit concerned that the post you linked refers to Intrepid and N connection speed. I really want to be able to use Lucid with ALL network types.

    Any further assistance would be greatly appreciated.

  7. #7
    Join Date
    Aug 2008
    Location
    Sweden
    Beans
    77

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?

    Thanks dino99!

    I'll still hang tight for a while and follow the official progress, though, since my eee pc 901 is just for testing the new release and constantly hooked up to the wired network. If this hasn't been updated before I need to take the computer with me, I'll be sure to follow your instructions.

    Edit: The duplicate, Bug #496093, is aimed at the milestone "Ubuntu lucid-updates", which I presume will trickle out little by little after the release, hence the hanging tight for a while at least, for my part.
    Last edited by tahina; April 30th, 2010 at 10:11 AM.

  8. #8
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?

    Quote Originally Posted by Strange_Movement View Post
    Thanks for the post dino99, I'll have a look when I get home tonight but I'm a bit concerned that the post you linked refers to Intrepid and N connection speed. I really want to be able to use Lucid with ALL network types.

    Any further assistance would be greatly appreciated.
    look at post 4

  9. #9
    Join Date
    Apr 2008
    Beans
    33

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?

    Doh ! I just read some more of the post. Thanks dino99 I'll have a better look at what I can do later.

  10. #10
    Join Date
    Aug 2008
    Location
    Sweden
    Beans
    77

    Re: 10.04 wireless RT2860 bug 545443 in need of extra love?

    Ahem, now I'm somewhat confused as to the meaning of mixed mode... I assumed that related to WPA/WPA2, but I had set my router to WPA2 and set security algorithms to TKIP+AES. Maybe that effectively meant mixed mode?

    When I set the "WPA algorithm" to just "AES", the 901 connected fine. So, it seems I might have been wrong about the title of the dupe bug (#496093) being misleading and that it indeed affects just "mixed" mode, if that is what I actually had previously without knowing it. But the routers web interface did give me a choice for mixed security mode which wasn't set, so maybe I had two ways of setting the same thing?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •