Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: setting the default file manager back to nautilus

  1. #11
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,100
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: setting the default file manager back to nautilus

    can you please answer me? when you boot up the computer and are presented with GDM (where you put in your username and password) is there an option for changing the session from lxde to gnome or someother session's (desktop environments) than what the default is currently?
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  2. #12
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    503
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: setting the default file manager back to nautilus

    Yes there is. I get the GDM login screen and i also am allowed to choose between lxde, fluxbox and gnome.
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

  3. #13
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,100
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: setting the default file manager back to nautilus

    Quote Originally Posted by nitstorm View Post
    Yes there is. I get the GDM login screen and i also am allowed to choose between lxde, fluxbox and gnome.
    and you're saying that when you chose gnome, you still have pcman file manager or whatever?
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  4. #14
    Join Date
    May 2006
    Location
    Wichita, Kansas
    Beans
    2,967
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: setting the default file manager back to nautilus

    Quote Originally Posted by dannyboy79 View Post
    and you're saying that when you chose gnome, you still have pcman file manager or whatever?
    Sticking my nose in, to answer the question posed, yes, that is what happens if the OP's experience is the same as mine.

  5. #15
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,100
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: setting the default file manager back to nautilus

    is this set in gconf editor?
    gconf-editor -> apps -> nautilus -> preferences -> always_use_browser (check mark).

    found this elsewhere, maybe it'll help:
    start nautilus (from the terminal if you have to)
    go to your /home
    right click on a folder > properties
    open with... tab
    click add
    find file browser (if you have thunar aswell, its complicated as its .desktop file calls itself file manager or browser aswell. However, they use different icons and you can figure out which is which using the applications menu)
    add that then set that to default

    also, did you read this?
    http://ubuntuforums.org/showthread.php?t=692238
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  6. #16
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    503
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: setting the default file manager back to nautilus

    is this set in gconf editor?
    gconf-editor -> apps -> nautilus -> preferences -> always_use_browser (check mark).
    yes, checked that already. the check mark is still there.

    found this elsewhere, maybe it'll help:
    start nautilus (from the terminal if you have to)
    go to your /home
    right click on a folder > properties
    open with... tab
    click add
    Followed the steps by opening up nautilus from the terminal and right-clicked and gave the open with and selected nautilus. Then closed all the windows and tried opening up my drive from places and still pcman opens it up.
    Set the default application to nautilus even via pcmanfm. Still nothing

    this is my output of the two files, highlighted the exec line jus for reference
    /usr/share/applications/nautilus-folder-handler.desktop :
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Name=Open Folder
    TryExec=nautilus
    Exec=nautilus --no-desktop %U
    NoDisplay=true
    Terminal=false
    Icon=folder-open
    StartupNotify=true
    Type=Application
    MimeType=x-directory/gnome-default-handler;x-directory/normal;inode/directory;application/x-gnome-saved-search;
    OnlyShowIn=GNOME;
    X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Product=nautilus
    X-GNOME-Bugzilla-Component=general
    X-GNOME-Bugzilla-Version=2.28.1
    X-Ubuntu-Gettext-Domain=nautilus


    gedit /usr/share/applications/nautilus-computer.desktop
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Name=Computer
    Comment=Browse all local and remote disks and folders accessible from this computer
    TryExec=nautilus
    Exec=nautilus --no-desktop computer:
    Icon=computer
    Terminal=false
    StartupNotify=true
    Type=Application
    Categories=GNOME;GTK;Core;
    OnlyShowIn=GNOME;
    X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Product=nautilus
    X-GNOME-Bugzilla-Component=general
    X-GNOME-Bugzilla-Version=2.28.1
    X-Ubuntu-Gettext-Domain=nautilus
    Also there is a line in /usr/bin/applications/pcmanfm-folder-handler.desktop called NotShownIn=GNOME; which was commented(#) earlier. I removed the comment. I mean i changed it from
    Code:
    #NotShownIn=GNOME;
    to
    Code:
    NotShownIn=GNOME;
    Logged out and logged back in. No change still!!!

    Also I am missing a file : /usr/share/gnome/default.session !!! I am using karmic so I don't know if that file should exist or not, but in the last link it was mentioned to tweak that file but it's missing!!!!!
    Last edited by nitstorm; April 28th, 2010 at 06:17 PM.
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

  7. #17
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    503
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: setting the default file manager back to nautilus

    Ok found the solution. No matter what I did nothing worked, until I installed ubuntutweak. There under file type manager i looked up folder and it said PCFileManager and I changed it there to nautilus file browser and now it's all good. Thanks for all the effort @dannyboy79

    THREAD SOLVED!!!

    Cheers guys!
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

  8. #18
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,100
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: setting the default file manager back to nautilus

    can you at least let us know did that install the /usr/share/gnome/default.session file and what are it's contents so others can solve possibly without having to install ubuntu tweek.
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  9. #19
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    503
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: setting the default file manager back to nautilus

    can you at least let us know did that install the /usr/share/gnome/default.session file and what are it's contents so others can solve possibly without having to install ubuntu tweek.
    I just looked into the folder. No default.session file there even now...
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

  10. #20
    Join Date
    May 2007
    Beans
    3
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: setting the default file manager back to nautilus

    I solved this issue by running exo-preferred-applications. This program gave me the option to change my file manager back to nautilus.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •