Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: setting the default file manager back to nautilus

  1. #1
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    504
    Distro
    Ubuntu 11.04 Natty Narwhal

    setting the default file manager back to nautilus

    Hey guys,

    I just wanted to try out LXDE and Fluxbox yesterday so I got them installed and checked them out but changed no settings anywhere. But when I logged back into Gnome, if i go to places and then browse a drive, PCManFM opens it up (NOTE: the drive icons on the desktop when clicked open up with nautilus, these two drive icons are in place coz i added them to fstab)
    I want to go back to nautilus when I am in Gnome. Please help.
    Thanks & Cheers!
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

  2. #2
    Join Date
    Jul 2009
    Beans
    441
    Distro
    Lubuntu

    Re: setting the default file manager back to nautilus

    More likely than not, (I use KDE), there is a Default Applications listing in Gnome. System>Administration (or Preferences, possibly) and look for something regarding default applications. If you can't find it there, look up how to do it in gconf-editor in a search engine.

  3. #3
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    504
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: setting the default file manager back to nautilus

    Quote Originally Posted by HarrisonNapper View Post
    More likely than not, (I use KDE), there is a Default Applications listing in Gnome. System>Administration (or Preferences, possibly) and look for something regarding default applications. If you can't find it there, look up how to do it in gconf-editor in a search engine.

    There is no option for default or preferred file manager in the preferred applications. Now looking into the gconf-editor thing. Thanks for the pointing out the way
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

  4. #4
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    504
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: setting the default file manager back to nautilus

    Quote Originally Posted by HarrisonNapper View Post
    More likely than not, (I use KDE), there is a Default Applications listing in Gnome. System>Administration (or Preferences, possibly) and look for something regarding default applications. If you can't find it there, look up how to do it in gconf-editor in a search engine.
    Found something here http://bbs.archlinux.org/viewtopic.php?pid=709810 .
    So went to gconf-editor-> Apps-> Nautilus->Preferences but the always_use_browser is already ticked.

    What do I do now ???? :S
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

  5. #5
    Join Date
    Jul 2009
    Beans
    441
    Distro
    Lubuntu

    Re: setting the default file manager back to nautilus

    You can do it this way (undo the change you made in gconf-editor first):

    Code:
    sudo dpkg-reconfigure nautilus
    Cheers.

  6. #6
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    504
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: setting the default file manager back to nautilus

    nope, that didn't work
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

  7. #7
    Join Date
    Jul 2009
    Beans
    441
    Distro
    Lubuntu

    Re: setting the default file manager back to nautilus

    http://www.ubuntugeek.com/how-to-cha...e-manager.html

    The above link says it should be in there somewhere. This should be stop number one.

    Failing that, you can try this rather contrived method:

    The script at this link sets Thunar as the default file manager, but accepts an argument to set nautilus back to default:

    https://help.ubuntu.com/community/DefaultFileManager

    So what you can do is install Thunar, run the script, then run the script with the "restorenautilusdefault" option. That should set nautilus back to default whereupon you can uninstall Thunar.

    EDIT: for future users who are troubleshooting this problem, visit the link provided for the Thunar work around and pay careful attention to the part where you set Thunar to default FIRST. Then you set nautilus BACK to default using the restorenautilus default argument which would look like this:


    ./scriptname restorenautilusdefault
    Last edited by HarrisonNapper; April 29th, 2010 at 05:54 PM.

  8. #8
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,094
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: setting the default file manager back to nautilus

    are you sure you chose Gnome session as your desktop manager at the login prompt (gdm or kdm or xdm)? i have tried a million desktop managers but i know that when I chose the one I want within xdm, gdm, or kdm (example: openbox, lxde, xfce, xfce-session, gnome, gnome-session) the file manager has always reverted back to what the default is for that desktop manager. gnome's default file manager is nautilus
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  9. #9
    Join Date
    Jul 2009
    Beans
    441
    Distro
    Lubuntu

    Re: setting the default file manager back to nautilus

    Quote Originally Posted by dannyboy79 View Post
    are you sure you chose Gnome session as your desktop manager at the login prompt (gdm or kdm or xdm)? i have tried a million desktop managers but i know that when I chose the one I want within xdm, gdm, or kdm (example: openbox, lxde, xfce, xfce-session, gnome, gnome-session) the file manager has always reverted back to what the default is for that desktop manager. gnome's default file manager is nautilus
    I didn't think of that. Assuming that this is the case, let's set gdm back to the default login:

    Code:
    sudo dpkg-reconfigure gdm
    Cheers.

  10. #10
    Join Date
    Nov 2009
    Location
    Chennai, India
    Beans
    504
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: setting the default file manager back to nautilus

    @HarrisonNapper:

    Tried both of your links. The first one says go to system->Preferences->System Settings. There is no such things as System Settings(I am on Karmic btw), but there is an option called Default Session. Went in there to see if there was an option for Nautilus but there isn't. But there is something called GNOME Settings Daemon but it is unchecked. Should I check it?

    And the script. I had looked into it earlier but i never thought of installing thunar and uninstalling it again. back to the point, Zilch, it just installed thunar. Nautilus wasn't restored when i ran the script again so just uninstalled thunar.

    And the dpkg-reconfigure gdm & dpkg-reconfigure nautilus didn't work either
    I like to keep it respectful with OpenRespect
    I write at The Void Ghost and 2buntu

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •