Results 1 to 6 of 6

Thread: Rt2800 Wireless disconnecting frequently

  1. #1
    Join Date
    Oct 2006
    Location
    California
    Beans
    Hidden!

    Rt2800 Wireless disconnecting frequently

    My wireless card disconnects frequently and sometimes it won't even connect at all. I've googled the card and the driver and it looks like others are having similar issues as well. http://bbs.archlinux.org/viewtopic.php?id=94929 http://ubuntuforums.org/showthread.php?t=1082812

    My lspci | grep -i network is as follows
    Code:
    02:01.0 Network controller: RaLink RT2800 802.11n PCI
    Under iwconfig, it's identified as wlan0, and I'm running kernel x86_64 2.6.32.9
    Last edited by pissedoffdude; April 24th, 2010 at 03:53 AM.

  2. #2
    Join Date
    May 2010
    Beans
    1

    Cool Re: Rt2800 Wireless disconnecting frequently

    same problem. I am running 10.04 LTS. It worked fine with 9.04 and 9.10.

  3. #3
    Join Date
    Jun 2010
    Beans
    2

    Re: Rt2800 Wireless disconnecting frequently

    I am also running 10.04 LTS, it can 't work , some people can solve ? help !!!

  4. #4
    Join Date
    Jun 2010
    Beans
    2

    Angry Re: Rt2800 Wireless disconnecting frequently

    Quote Originally Posted by ibobo View Post
    I am also running 10.04 LTS, it can 't work , some people can solve ? help !!!
    someone can help me?

  5. #5
    Join Date
    Jun 2010
    Beans
    1

    Re: Rt2800 Wireless disconnecting frequently

    The problem may be specific to AES encryption. I've changed my encryption type to TKIP and haven't have any issues (16 hours up so far).

    I've also seen reference to conflicts between two modules doing the same job. run:

    Code:
    lsmod | grep rt2
    Either rt2800pci should be present, or rt2860sta. Not both.

    Note: I'm a debian user, so the solution for me may not apply to Ubuntu, but I saw this while I was digging and thought I'd offer the solutions I found anyway.

  6. #6
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Beans
    192
    Distro
    Ubuntu 15.10 Wily Werewolf

    Re: Rt2800 Wireless disconnecting frequently

    Same problem here. After upgrading from 9 to 10.04 (using the same wireless card)the card does not work any more. It finds the network, but then keeps prompting me for the password (I have WPA & WPA2 enabled) without connecting successfully. It has, however, connected once since the upgrade.

    output from various commands follows.

    Thanks

    llist@MusicPc:~$ lsmod | grep rt2
    rt2860sta 542482 0


    llist@MusicPc:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 RT2860 Wireless ESSID:"TheAustrians2" Nickname:"RT2860STA"
    Mode:Managed Frequency=2.422 GHz Access Point: 00:1F:33:23:E7:3C
    Bit Rate=130 Mb/s
    RTS thrff Fragment thrff
    Link Quality=100/100 Signal level:-51 dBm Noise level:-71 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0


    irq:21 memory:fdef0000-fdefffff



    llist@MusicPc:~$ sudo lshw -c network
    *-network
    description: Wireless interface
    product: RT2800 802.11n PCI
    vendor: RaLink
    physical id: 7
    bus info: pci@0000:03:07.0
    logical name: wlan0
    version: 00
    serial: 00:1f:1f:34:56:d2
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=rt2860 latency=32 maxlatency=4 mingnt=2 multicast=yes wireless=RT2860 Wireless
    resources: irq:21 memory:fdef0000-fdefffff

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •