Page 1 of 2 12 LastLast
Results 1 to 10 of 21

Thread: Headphones not working (but detected on alsamixer)

Hybrid View

  1. #1
    Join Date
    Mar 2009
    Beans
    7

    Headphones not working (but detected on alsamixer)

    Hi,

    My headphones used to work on ubuntu on my dell studio 1558, but when I reinstalled the system they seems to stop working.

    When I plug them in I don't hear anything, the speaker stop working but there is no sound on the headphones.

    The headphone is detected on alsa mixer, and they work normally on Windows, I tried this workaround here http://ubuntuforums.org/showthread.php?t=302543&page=2 without a solution.

    Any idea how to get them to work, thank you.
    laptop:~$ cat /proc/asound/cards
    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xf0b00000 irq 22
    1 [HDMI ]: HDA-Intel - HDA ATI HDMI
    HDA ATI HDMI at 0xcfeec000 irq 17

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,883
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Headphones not working (but detected on alsamixer)

    Can you post the output of these terminal commands for me please:
    Code:
    uname -a
    aplay -l
    cat /proc/asound/version
    head -n 1 /proc/asound/card*/codec#*
    Terminal="Applications->Accessories->Terminal"
    Please post text output using code tags. Also helpful is the make/model of your PC/Laptop.

  3. #3
    Join Date
    Nov 2008
    Beans
    7

    Re: Headphones not working (but detected on alsamixer)

    Hi,
    I was having the exact same problem on my Dell Studio 1558 (sound through the speakers, but none when using headphones). After some more google-ing around, I found this doco: https://help.ubuntu.com/community/HdaIntelSoundHowto

    I found my card model using this:
    Code:
    cat /proc/asound/card0/codec#* | grep Codec
    which returned:
    Code:
    Codec: IDT 92HD73C1X5
    This file: /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz lists the sound models with available modprobe modules to use.
    Code:
    zless /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz
    The full model number wasn't in there, because the model has been wildcarded. I searched for
    Code:
    92HD73
    In this section there are several PC models listed, find the one that best suites you (I used 'dell-eq').
    After a reboot, I had headphone sound again.

    Cheers,
    Paul

  4. #4
    Join Date
    May 2010
    Beans
    1

    Re: Headphones not working (but detected on alsamixer)

    Thank you for the post pgmac,

    Just what I needed to fix headphone sound on the same Dell studio 1558.

    I do not want to moan about others, especially when they volunteer ... this problem is quite old ... so without your post, I'd probably be lost ...

    Hello Dell maybe you can volunteer some to help to fix this in alsa ...

  5. #5
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: Headphones not working (but detected on alsamixer)

    Many thanks, pgmac. It worked for my dell 1558!

  6. #6
    Join Date
    Aug 2005
    Location
    Bardstown, KY, USA
    Beans
    200
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Headphones not working (but detected on alsamixer)

    Thanks! Fixed my wife's headphone problem on her Dell Studio 1558.

    /Kevin

  7. #7
    Join Date
    Sep 2008
    Location
    I Live in India
    Beans
    20
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Headphones not working (but detected on alsamixer)

    Thank you very much for this post.
    It really fixed my issue.

    Venk!!

  8. #8
    Join Date
    Apr 2010
    Beans
    50
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Headphones not working (but detected on alsamixer)

    Quote Originally Posted by pgmac View Post
    Hi,
    I was having the exact same problem on my Dell Studio 1558 (sound through the speakers, but none when using headphones). After some more google-ing around, I found this doco: https://help.ubuntu.com/community/HdaIntelSoundHowto

    I found my card model using this:
    Code:
    cat /proc/asound/card0/codec#* | grep Codec
    which returned:
    Code:
    Codec: IDT 92HD73C1X5
    This file: /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz lists the sound models with available modprobe modules to use.
    Code:
    zless /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz
    The full model number wasn't in there, because the model has been wildcarded. I searched for
    Code:
    92HD73
    In this section there are several PC models listed, find the one that best suites you (I used 'dell-eq').
    After a reboot, I had headphone sound again.

    Cheers,
    Paul
    HI Paul,

    How did you select " dell-eg " and reboot,
    i've followd the steps in " Terminal" but hasent worked for me =[
    it also say:
    zless /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz - Permission Denied

    * * EDIT * *

    Hi All,
    re-read the post and wrote full command into Terminal.. and almost fixed =]
    Am Stuck on how to select " dell-eg "
    Last edited by Simon_WM; May 22nd, 2010 at 10:42 PM. Reason: Update

  9. #9
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,883
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Headphones not working (but detected on alsamixer)

    Quote Originally Posted by Simon_WM View Post
    HI Paul,

    How did you select " dell-eg " and reboot,
    i've followd the steps in " Terminal" but hasent worked for me =[
    it also say:
    zless /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz - Permission Denied

    * * EDIT * *

    Hi All,
    re-read the post and wrote full command into Terminal.. and almost fixed =]
    Am Stuck on how to select " dell-eg "
    Don't worry about that. If you want to use dell-eq (that's a q, not a g), do as directed in post #9. This is entered in a terminal:
    Code:
    gksu gedit /etc/modprobe.d/alsa-base.conf
    and will open the file in your text editor. There you will add the options line.

  10. #10
    Join Date
    May 2010
    Beans
    3

    Re: Headphones not working (but detected on alsamixer)

    How would i apply this fix (which worked for me in gnome on 10.04) to Kubuntu 10.04 which i am now running. it is a clean install and of course these commands do not work. I am very new to linux and would appreciate step by step commands for the Konsole that would help out quite a bit

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •