Results 1 to 6 of 6

Thread: Perl configuration problem with dpkg

  1. #1
    Join Date
    Apr 2010
    Beans
    4

    Exclamation Perl configuration problem with dpkg

    Hello all,

    I've encountered a large problem with my Ubuntu server.
    Suddenly my Perl started giving hickups when trying to install/upgrade via apt.
    A better explanation may be by showing the error log:
    Code:
    bartv.be:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    8 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "nl_BE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    debconf: Perl may be unconfigured (Can't locate strict.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at (eval 1) line 2.
    BEGIN failed--compilation aborted at (eval 1) line 2.
    ) -- aborting
    Setting up perl (5.10.0-19lenny2) ...
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "nl_BE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Can't locate strict.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/sbin/update-alternatives line 7.
    BEGIN failed--compilation aborted at /usr/sbin/update-alternatives line 7.
    dpkg: error processing perl (--configure):
     subprocess post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of apache2.2-common:
     apache2.2-common depends on perl; however:
      Package perl is not configured yet.
    dpkg: error processing apache2.2-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apache2-mpm-prefork:
     apache2-mpm-prefork depends on apache2.2-common (= 2.2.9-10+lenny7); however:
      Package apache2.2-common is not configured yet.
    dpkg: error processing apache2-mpm-prefork (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apache2:
     apache2 depends on apache2-mpm-worker (>= 2.2.9-10+lenny7) | apache2-mpm-prefork (>= 2.2.9-10+lenny7) | apache2-mpm-event (>= 2.2.9-10+lenny7); however:
      Package apache2-mpm-worker is not installed.
      Package apache2-mpm-prefork is not configured yet.
      Package apache2-mpm-event is not installed.
    dpkg: error processing apache2 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxml-sax-perl:
     libxml-sax-perl depends on perl (>= 5.6.0-16); however:
      Package perl is not configured yet.
    dpkg: error processing libxml-sax-perl (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxml-sax-expat-perl:
     libxml-sax-expat-perl depends on perl (>= 5.6.0-16); however:
      Package perl is not configured yet.
     libxml-sax-expat-perl depends on libxml-sax-perl (>= 0.03); however:
      Package libxml-sax-perl is not configured yet.
    dpkg: error processing libxml-sax-expat-perl (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxml-simple-perl:
     libxml-simple-perl depends on perl (>= 5.8); however:
      Package perl is not configured yet.
     libxml-simple-perl depends on libxml-sax-perl; however:
      Package libxml-sax-perl is not configured yet.
     libxml-simple-perl depends on libxml-libxml-perl | libxml-sax-expat-perl; however:
      Package libxml-libxml-perl is not installed.
      Package libxml-sax-expat-perl is not configured yet.
    dpkg: error processing libxml-simple-perl (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of phpmyadmin:
     phpmyadmin depends on perl; however:
      Package perl is not configured yet.
    dpkg: error processing phpmyadmin (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     perl
     apache2.2-common
     apache2-mpm-prefork
     apache2
     libxml-sax-perl
     libxml-sax-expat-perl
     libxml-simple-perl
     phpmyadmin
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    I figured dpkg was the one causing the problem here, digging through the errors, I could see that Perl couldn't find any imports.
    I don't remember changing or upgrading perl.

    I tried
    Code:
    bartv.be:~# dpkg-reconfigure perl
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "nl_BE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Can't locate strict.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/sbin/dpkg-reconfigure line 8.
    BEGIN failed--compilation aborted at /usr/sbin/dpkg-reconfigure line 8.
    and
    Code:
    bartv.be:~# apt-get --reinstall install perl
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      sensible-mda
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
    8 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "nl_BE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    debconf: Perl may be unconfigured (Can't locate strict.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at (eval 1) line 2.
    BEGIN failed--compilation aborted at (eval 1) line 2.
    ) -- aborting
    Setting up perl (5.10.0-19lenny2) ...
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "nl_BE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Can't locate strict.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/sbin/update-alternatives line 7.
    BEGIN failed--compilation aborted at /usr/sbin/update-alternatives line 7.
    dpkg: error processing perl (--configure):
     subprocess post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of apache2.2-common:
     apache2.2-common depends on perl; however:
      Package perl is not configured yet.
    dpkg: error processing apache2.2-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apache2-mpm-prefork:
     apache2-mpm-prefork depends on apache2.2-common (= 2.2.9-10+lenny7); however:
      Package apache2.2-common is not configured yet.
    dpkg: error processing apache2-mpm-prefork (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of apache2:
     apache2 depends on apache2-mpm-worker (>= 2.2.9-10+lenny7) | apache2-mpm-prefork (>= 2.2.9-10+lenny7) | apache2-mpm-event (>= 2.2.9-10+lenny7); however:
      Package apache2-mpm-worker is not installed.
      Package apache2-mpm-prefork is not configured yet.
      Package apache2-mpm-event is not installed.
    dpkg: error processing apache2 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxml-sax-perl:
     libxml-sax-perl depends on perl (>= 5.6.0-16); however:
      Package perl is not configured yet.
    dpkg: error processing libxml-sax-perl (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxml-sax-expat-perl:
     libxml-sax-expat-perl depends on perl (>= 5.6.0-16); however:
      Package perl is not configured yet.
     libxml-sax-expat-perl depends on libxml-sax-perl (>= 0.03); however:
      Package libxml-sax-perl is not configured yet.
    dpkg: error processing libxml-sax-expat-perl (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libxml-simple-perl:
     libxml-simple-perl depends on perl (>= 5.8); however:
      Package perl is not configured yet.
     libxml-simple-perl depends on libxml-sax-perl; however:
      Package libxml-sax-perl is not configured yet.
     libxml-simple-perl depends on libxml-libxml-perl | libxml-sax-expat-perl; however:
      Package libxml-libxml-perl is not installed.
      Package libxml-sax-expat-perl is not configured yet.
    dpkg: error processing libxml-simple-perl (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of phpmyadmin:
     phpmyadmin depends on perl; however:
      Package perl is not configured yet.
    dpkg: error processing phpmyadmin (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     perl
     apache2.2-common
     apache2-mpm-prefork
     apache2
     libxml-sax-perl
     libxml-sax-expat-perl
     libxml-simple-perl
     phpmyadmin
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    As you can see, without success.

    Does anyone have any ideas so I don't have to do a reinstall?


    Thanks a million!

  2. #2
    Join Date
    Feb 2005
    Location
    Spain
    Beans
    149
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Perl configuration problem with dpkg

    Same problem here. I lost spanish language.

    BR.
    AMD Athlon 64 3000+ Core Venice
    Abit KN8-Ultra
    2x512 DDR400 Dual Channel (Geil kit)
    MSI NX6600GT-TD128
    SB X-FI XM

    ASUS A4K Laptop
    AMD Athlon 64 mobile 3200+
    2*256 DDR 400
    Mobo ASUS Nforce3-150
    Ati Radeon Mobility 9700

  3. #3
    Join Date
    Feb 2010
    Beans
    5

    Smile Re: Perl configuration problem with dpkg

    1: run
    Code:
    dpkg-reconfigure locales
    2: select all locales
    3: selct your default language, in my case da_DK.UTF8
    VOILA!!!


  4. #4
    Join Date
    Feb 2010
    Beans
    5

    Re: Perl configuration problem with dpkg

    remember to be root also

  5. #5
    Join Date
    Feb 2010
    Beans
    5

    Thumbs down Re: Perl configuration problem with dpkg

    UPDATE!!! if you want english/american output, in mos programs select en_US.UTF8

  6. #6
    Join Date
    Feb 2010
    Beans
    5

    Wink Re: Perl configuration problem with dpkg

    UPDATE AGAIN!!!:

    Remember if that dosen't work run
    Code:
    sudo apt-get install locales
    sory for the many updates!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •