Page 4 of 7 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 70

Thread: 10.04 won't boot without monitor / keyboard (headless)

  1. #31
    Join Date
    Sep 2009
    Beans
    3

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Well I'll be damned. I really thought bapool's and paosms' solutions would fix it for me, but so far nothing is working.

  2. #32
    Join Date
    Nov 2006
    Beans
    11

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Quote Originally Posted by bapool View Post
    YEA! I got it.

    The answer is actually a combination of two separate solutions, each of which did not work separately. I have 10.04 now working headless on two different servers (different MB, Video...) and both are working great.

    Step 1. Create a xorg.conf in /etc/X11 with the following. I tried Step 2 without doing this and it failed exactly as it had before.

    Section "Device"
    Identifier "VNC Device"
    Driver "vesa"
    EndSection

    Section "Screen"
    Identifier "VNC Screen"
    Device "VNC Device"
    Monitor "VNC Monitor"
    SubSection "Display"
    Modes "1024x768"
    EndSubSection
    EndSection

    Section "Monitor"
    Identifier "VNC Monitor"
    HorizSync 30-70
    VertRefresh 50-75
    EndSection

    Step 2. Disable KMS for your video card as described here https://wiki.ubuntu.com/X/KernelModeSetting

    The jist is to know which video card manufacturer you have and use the command line entry below it to create the appropriate kms.conf file with the line "options...modeset=0" line in it. If you have access to the GUI you could just are easily create/modify the file and put the "options...modeset=0" in as appropriate.

    The following are input into the terminal windows as a line command.

    # ATI Radeon:
    echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

    # Intel:
    echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

    # Nvidia (this should revert you to using -nv or -vesa):
    echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf

    Step 3. Reboot...Putty In...startx...GTG!


    Brian
    This worked for me, but I had to change

    Driver "vesa"

    to

    Driver "nv"

    For some reason I didn't have the vesa drivers and since I have a old nvidia card in the server I just went for the nv.

  3. #33
    Join Date
    Aug 2010
    Beans
    1

    Re: 10.04 won't boot without monitor / keyboard (headless)

    thanks to paosms and bapool for the solution!

    props from brazil

  4. #34
    Join Date
    Nov 2009
    Location
    Whitley Bay
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Just like to say thanks to bapool for his solution which works for me.
    Only one fly in the ointment; when I VNC into my (now headless) server the only resolution I can get is 640 x 480.
    Any ideas on how I can get this up?

    Actually it's not just when I VNC in, I hooked up the monitor again and the screen resolution is fixed at 640 x 480
    Last edited by GiganticDays; August 29th, 2010 at 12:10 PM. Reason: Additional info

  5. #35
    Join Date
    Dec 2009
    Beans
    13

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Hi, the posted solution works well for me, but as GiganticDays said the resolution is fixed.

    I will continue with "temporary" fix, an external monitor so that only x11vnc install and configuration is needed.

  6. #36
    Join Date
    Nov 2009
    Location
    Whitley Bay
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 won't boot without monitor / keyboard (headless)

    I found a solution to the resolution issue.

    I stopped using TightVNC and am now using FreeNX instead. Works a treat and you can set whatever resolution you like.

  7. #37
    Join Date
    Jun 2008
    Location
    Long way from there..
    Beans
    44
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 won't boot without monitor / keyboard (headless)

    I wasnt able to boot without monitor.

    Followed paosms steps (including bapool xorg).
    Now it works perfectly.

    First time trying to do this.

    Thanks guys.

    PD: o also coulnt access modprobe.d, nor as user or root.
    AMD Phenon X6 1090T/8gb 1333/1tb/radeon 5670/ ubuntu 11.04
    ASUS UL30VT-A1 win7 / ubuntu 11.04 / Fedora 15
    Ubuntu Server 10.04 on old laptop (headless lol)
    Linux User #: 525691

  8. #38
    Join Date
    Nov 2009
    Location
    Whitley Bay
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Check your BIOS and disable Halt on keyboard and any other "Halt On" options.

  9. #39
    Join Date
    Aug 2010
    Location
    Cleveland, OH, USA
    Beans
    119
    Distro
    Ubuntu

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Quote Originally Posted by GiganticDays View Post
    Check your BIOS and disable Halt on keyboard and any other "Halt On" options.
    Yeah, I would think that this could be a BIOS issue.

    I found these settings, but I am unsure which selection will fix the issue.
    Halt on............ [All , But keyboard] <<< Was default setting
    [All errors]
    [No errors] <<<< I assume this is the one I want

    I guess I'll just try them all...

    -Kurt

  10. #40
    Join Date
    Oct 2007
    Beans
    8

    Re: 10.04 won't boot without monitor / keyboard (headless)

    I just tried bapool's solution (making /etc/X11/xorg.conf with the specified content, and then switching to root then running 'echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf' since My graphics card was Intel) and it works!

    Thanks for the solution

Page 4 of 7 FirstFirst ... 23456 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •