Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 70

Thread: 10.04 won't boot without monitor / keyboard (headless)

  1. #21
    Join Date
    Jan 2008
    Location
    Ohio
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Smile Re: 10.04 won't boot without monitor / keyboard (headless)

    YEA! I got it.

    The answer is actually a combination of two separate solutions, each of which did not work separately. I have 10.04 now working headless on two different servers (different MB, Video...) and both are working great.

    Step 1. Create a xorg.conf in /etc/X11 with the following. I tried Step 2 without doing this and it failed exactly as it had before.

    Section "Device"
    Identifier "VNC Device"
    Driver "vesa"
    EndSection

    Section "Screen"
    Identifier "VNC Screen"
    Device "VNC Device"
    Monitor "VNC Monitor"
    SubSection "Display"
    Modes "1024x768"
    EndSubSection
    EndSection

    Section "Monitor"
    Identifier "VNC Monitor"
    HorizSync 30-70
    VertRefresh 50-75
    EndSection

    Step 2. Disable KMS for your video card as described here https://wiki.ubuntu.com/X/KernelModeSetting

    The jist is to know which video card manufacturer you have and use the command line entry below it to create the appropriate kms.conf file with the line "options...modeset=0" line in it. If you have access to the GUI you could just are easily create/modify the file and put the "options...modeset=0" in as appropriate.

    The following are input into the terminal windows as a line command.

    # ATI Radeon:
    echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf

    # Intel:
    echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

    # Nvidia (this should revert you to using -nv or -vesa):
    echo options nouveau modeset=0 > /etc/modprobe.d/nouveau-kms.conf

    Step 3. Reboot...Putty In...startx...GTG!


    Brian
    Last edited by bapool; July 4th, 2010 at 07:13 PM.

  2. #22
    Join Date
    Sep 2008
    Beans
    5

    Re: 10.04 won't boot without monitor / keyboard (headless)

    hi there,
    how to you actually turn the kms off?
    i mean, where do i have to put the line

    # Intel:
    echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf


    ?

    or maybe i'm getting this wrong, i just have to create

    a i915-kms.conf file

    into modprobe.d

    with a single line in it saying "echo options i915 modeset=0"

    thanks

  3. #23
    Join Date
    Jan 2008
    Location
    Ohio
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Quote Originally Posted by paosms View Post
    hi there,
    how to you actually turn the kms off?
    i mean, where do i have to put the line

    # Intel:
    echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf


    ?

    or maybe i'm getting this wrong, i just have to create

    a i915-kms.conf file

    into modprobe.d

    with a single line in it saying "echo options i915 modeset=0"

    thanks
    The entire line that you put in the terminal (or command line) is
    echo options i915 modeset=0 > /etc/modprobe.d/i915-kms.conf

    This creates the file i915-ams.conf in the /etc/modprobe.d/ directory with one line in it

    options i915 modeset=0

    It worked on both of my boxes (although mine is an ati card). Hope that gets it for you!

    Brian
    Last edited by bapool; July 4th, 2010 at 07:25 PM.

  4. #24
    Join Date
    Sep 2008
    Beans
    5

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Hi there!
    I found another solution, perhaps simpler than the one just shown because it doesn't require to know or look for the video card supplier.

    Since I couldn't access the /etc/modprobe.d/ directory (not even as root, dunno why!) I found that you can disable the kms at startup by modifying the grub file, it's really simple.

    For systems -and for those only!- that use GRUB2 (like 10.04) do as follow, it worked for me:

    STEP 1

    #
    sudo gedit /etc/default/grub

    this will open the grub file. Now find the line that says GRUB_CMDLINE_LINUX and add "nomodeset".

    you'll have to end up with something like this:
    GRUB_CMDLINE_LINUX="nomodeset"

    now update the grub from terminal with

    #
    update-grub

    STEP 2
    use bapool's xorg.conf file

    STEP 3
    You're done! reboot and unplug the monitor, ubuntu 10.04 will work headless and load vesa driver without any problems!

  5. #25
    Join Date
    Mar 2010
    Beans
    28

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Installed 10.04 Lucid server with/for raid 1.
    Installed Ubuntu desktop with tasksel.

    Failed to boot headless, without a monitor.

    Used the above posts to achieve a headless install.

    Created the xorg.conf in /etc/X11 with the following:

    Section "Device"
    Identifier "VNC Device"
    Driver "vesa"
    EndSection

    Section "Screen"
    Identifier "VNC Screen"
    Device "VNC Device"
    Monitor "VNC Monitor"
    SubSection "Display"
    Modes "1024x768"
    EndSubSection
    EndSection

    Section "Monitor"
    Identifier "VNC Monitor"
    HorizSync 30-70
    VertRefresh 50-75
    EndSection

    Then, edited the grub file: sudo gedit /etc/default/grub
    and added the following line as such:

    GRUB_CMDLINE_LINUX="nomodeset"

    Thanks to the original posters.

  6. #26
    Join Date
    Feb 2007
    Location
    Ardsley, NY
    Beans
    102
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Tried the above solutions, but they did not work for me, but I did find a quick fix that did work .

    I have a little different set up then above due my set up is for Mythtv.

    The connections are as follows.

    Code:
    PC FX5200 DVI -> DVI+SPIF to HDMI "monoprice unit" -> 4-WAY HDMI selector "monoprice unit" -> TV "Sony 52 inch"
    I narrowed it down that the PC would boot if a regular monitor was plugged into the PC FX5200 DVI, or if there was nothing plugged in to the PC. Looking at my logs there was never any boot log made when the PC was connected up normally as above, so the boot process must had been stopping at Grub. As report above I had no issue when running 8.04 but this used the old Grub, and 10.04 uses the new Grub. To fix the issue I did as follows.

    Open a terminal and type in this command

    Code:
    sudo gedit /etc/default/grub
    Find the line below and remove the "#" save the file and close gedit

    Code:
    GRUB_TERMINAL=console
    Next update grub by doing this command in the terminal

    Code:
    sudo update-grub
    Reboot the machine.

  7. #27
    Join Date
    May 2007
    Beans
    5

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Got it working! I've tried several methods, but #24 (paosms' post) got it to work. I used his edit to grub, and bapool's xorg.conf file, and my Ubuntu 10.04 box now boots cleanly without a monitor attached (for the first time ever).

    Thanks!

  8. #28
    Join Date
    Jul 2010
    Beans
    1

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Quote Originally Posted by zurkog View Post
    Got it working! I've tried several methods, but #24 (paosms' post) got it to work. I used his edit to grub, and bapool's xorg.conf file, and my Ubuntu 10.04 box now boots cleanly without a monitor attached (for the first time ever).

    Thanks!
    Please help me. I am new at linux community. I cannot create the xorg.conf inside the x11 folder. It does not let me do anything in this folder. If somebody can tell how to create the fbapool's xorg.conf file, i would be grateful.

    Thanks

  9. #29
    Join Date
    Feb 2007
    Location
    Ardsley, NY
    Beans
    102
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Quote Originally Posted by Steverman View Post
    Please help me. I am new at linux community. I cannot create the xorg.conf inside the x11 folder. It does not let me do anything in this folder. If somebody can tell how to create the fbapool's xorg.conf file, i would be grateful.

    Thanks
    open an terminal run "sudo gedit" open the file edit it then save and close gedit.
    reboot machine.

  10. #30
    Join Date
    May 2007
    Beans
    5

    Re: 10.04 won't boot without monitor / keyboard (headless)

    Quote Originally Posted by Steverman View Post
    Please help me. I am new at linux community. I cannot create the xorg.conf inside the x11 folder. It does not let me do anything in this folder. If somebody can tell how to create the fbapool's xorg.conf file, i would be grateful.

    Thanks
    That's because the /etc/X11 folder is owned by root, with permissions that only allow the root user to add/change/delete files within it. If you open up the terminal application, and enter:

    sudo gedit /etc/X11/xorg.conf

    and then enter your password, it will let you create that file (just remember to click "Save" when you're done). Copy and paste the config from post #21 into the Gedit window.

Page 3 of 7 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •