Results 1 to 4 of 4

Thread: 32 bit version of libgd

  1. #1
    Join Date
    Apr 2010
    Beans
    6

    Question 32 bit version of libgd

    Dear forum,

    I have installed packages libgd2-xpm and libgd2-xpm-dev, and I get the following error:

    /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.1/../../../libgd.so when searching for -lgd
    /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.1/../../../libgd.a when searching for -lgd
    /usr/bin/ld: skipping incompatible /usr/lib/libgd.so when searching for -lgd
    /usr/bin/ld: skipping incompatible /usr/lib/libgd.a when searching for -lgd

    What is the correct package which I should install?

    Thanks!

  2. #2
    Join Date
    Apr 2010
    Beans
    6

    Re: 32 bit version of libgd

    Any help?

    I forgot to mention I get the above errors while trying to compile some C++ code.

    Thanks

  3. #3
    Join Date
    Nov 2005
    Location
    Bordeaux, France
    Beans
    11,297
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 32 bit version of libgd

    If you really want to compile 32-bit code on a 64-bit machine, you will need the packges gcc-multilib and ia32-libs.
    「明後日の夕方には帰ってるからね。」


  4. #4
    Join Date
    Apr 2010
    Beans
    6

    Re: 32 bit version of libgd

    Thanks but I have already installed these packages and it still gives me this -lgd error.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •