Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: Network Manager Disabled

  1. #21
    Join Date
    Aug 2006
    Beans
    3

    Re: Network Manager Disabled

    I have a similar problem on a desktop system with a wired ethernet connection - eth0 is disabled on startup. A quick check of Chaosgrimm's suggestions revealed that the first file ( /etc/NetworkManager/nm-system-settings.conf ) wasn't present on my system, and in the second file ( /var/lib/NetworkManager/NetworkManager.state ) the NetworkingEnabled parameter was set to false. I can only conclude that was reset by an recent update as until a couple of weeks ago, everything worked fine. I'l give your settings a try...

  2. #22
    Join Date
    Jul 2010
    Location
    Melbourne, Australia
    Beans
    10
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Network Manager Disabled

    Quote Originally Posted by agniruc View Post
    Thanks for posting this, chaosgrimm! Saved my day!

    All happened when I tried to put my laptop on 'sleep mode'. For some reason it did not sleep and stopped working (no response at all, even the SysReq + R, E, I, S, U, B trick wasn't working).

    After I reset it, the networkmanager seemed dead. 'dhclient' was working, though. Then I found this post and discovered that all the options in those configuration files were set to 'false'!
    This happened to me just now. I guess sleep mode is broken. Thank the Gods I had a laptop here so I could Google the answer. I had to reboot after changing the file though. Logout didn't fix.

  3. #23
    Join Date
    Apr 2008
    Beans
    122

    Re: Network Manager Disabled

    Quote Originally Posted by walter_jnr View Post
    This happened to me just now. I guess sleep mode is broken. Thank the Gods I had a laptop here so I could Google the answer. I had to reboot after changing the file though. Logout didn't fix.
    You don't need to reboot, just restart the network manager service:

    Code:
    sudo /etc/init.d/network-manager restart
    I made a small script to repair network, might be useful for you. You just make a file with the following code:

    Code:
    sudo rm /var/lib/NetworkManager/NetworkManager.state 
    sudo /etc/init.d/network-manager restart
    Call the file network_repair and give it execution permissions:
    Code:
    chmod +x network_repair
    Then you can repair the network just typing ./network_repair

    By the way, can you give the link to the launchpad bug please?

    And now, a message to LifeTheHound:
    utter incompetence?
    Don't be a hater. Are you aware that linux developers are many times volunteers that in their free time they program stuff for other people? That's what made linux the incredible computing experience that it is right now. It's not only about security, it's about the right to access the code you are running, the freedom to do with your system whatever you want and the possibility to participate in a community of people making this possible. I think you should think about it and be more grateful.

  4. #24
    Join Date
    Jul 2010
    Location
    Melbourne, Australia
    Beans
    10
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Network Manager Disabled

    Quote Originally Posted by andreselsuave View Post
    You don't need to reboot, just restart the network manager service:
    I tried doing that but it didn't seem to work. Of course I'm still pretty new to Linux so I was most likely doing something wrong.

    I made a small script to repair network, might be useful for you.
    Thanks for going to the effort of helping me but, to be honest, at this point I'd rather stay away from scripts just so I can learn as much as I can about all the various command line functions. I don't think I'll learn as much just running scripts that other people have written for me. The effort is definitely appreciated though so thanks.


    By the way, can you give the link to the launchpad bug please?
    https://bugs.launchpad.net/ubuntu/+bug/555571

    This is where I got the idea to edit the NetworkManager.state. I'm not sure exactly what this bug is caused by (for me it was waking up after suspending to RAM) or whether it is related to my problem but it helped.

  5. #25
    Join Date
    Apr 2008
    Beans
    122

    Re: Network Manager Disabled

    Nice attitude Walter_jnr!

    I also like to always learn somethiing in the way. But I think in this case, rebooting is the way you wont learn something. I am not a linux expert, but I think I can help you understand how this works, since you like to learn:

    There is something called daemons in linux, which is similar to services in MS windows. They are programms that normaly start when you boot up and run in the background waiting for you to do something to produce some kind of output. For example:

    there is a bluetooth daemon waiting for you to connect with a mobile phone to make the proper connection. Other daemons make many different tasks. If you want to see which programs you are currently running, you can do it in the console:
    1)Interactively (like a task manager):
    Code:
    top
    2)Statically (like a process list):
    Code:
    ps -aux
    -aux is to tell ps to give you all the programs instead of only your user's. you can learn even more here:
    Code:
    man ps
    So, arriving to the point... There is a network manager daemon, running in a background and managing your connections, to ease the task of connecting to the internet. Because of this bug related to sleep to RAM, or something like that, it stays disabled, so to restart it, you can use a program stored in /etc/init.d where they are more daemon-controlling programs, by doing (you need superuser privileges)
    Code:
    sudo /etc/init.d/network-manager restart
    There is a more modern way to do this, im not sure but I think its something like
    Code:
    sudo services network-manager restart
    Hope you learnt something today and keep on with that attitude !
    Andres.

  6. #26
    Join Date
    Jun 2008
    Beans
    2

    Cool Re: Network Manager Disabled

    At work so I haven't tried this yet with my home laptop. Using an older Alienware laptop, it has this very same problem with 10.04 after booting but not every single time. 9.10 had no such issue. I didn't know how to re-enable the network, even using 'service networking restart' didn't work. Booting into GNOME and using the nm applet to re-enable the network did work. After that, I could log out then back into KDE and have network access.

    Without doing this, there was no network icon in any KDE panel, and going through the network config GUI wouldn't fix it either.

    Here's hoping this is cleared up. Thanks for the workaround for the interim!

  7. #27
    Join Date
    Apr 2006
    Beans
    19
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Network Manager Disabled

    Quote Originally Posted by chaosgrimm View Post
    If the network manager isn't crashing check these, should be set as:

    /etc/NetworkManager/nm-system-settings.conf

    [main]
    plugins=ifupdown,keyfile

    [ifupdown]
    managed=true

    -------
    and

    /var/lib/NetworkManager/NetworkManager.state



    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    Hola, this almost worked for me, but my Network Manager was still unavailable. However I did find this, which worked perfectly in conjuntion with the above. Thanks!

    http://linux-software-news-tutorials...-1004disabled-
    network.html?m=1

  8. #28
    Join Date
    Aug 2008
    Beans
    34

    Re: Network Manager Disabled

    happened to me when i was in a rush so i forced shutdown by holding down power. that was a mistake

  9. #29
    Join Date
    Jun 2011
    Beans
    1

    Re: Network Manager Disabled

    The same problem on Kubuntu 10 and Dell latitude D360. After it went on RAM going out of battery the next restart made all keys equal to false ! After editing them and setiing to true, the network runs normal as before. Thanks for the solution.

    Regards
    M. H.

  10. #30
    Join Date
    Aug 2009
    Beans
    2

    Re: Network Manager Disabled

    Quote Originally Posted by agniruc View Post
    Thanks for posting this, chaosgrimm! Saved my day!

    All happened when I tried to put my laptop on 'sleep mode'. For some reason it did not sleep and stopped working (no response at all, even the SysReq + R, E, I, S, U, B trick wasn't working).

    After I reset it, the networkmanager seemed dead. 'dhclient' was working, though. Then I found this post and discovered that all the options in those configuration files were set to 'false'!
    The same exact thing happened :C

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •