Results 1 to 2 of 2

Thread: Samba has stopped working.

  1. #1
    Join Date
    Feb 2012

    Samba has stopped working.

    I am running Ubuntu 11.10, and using samba, it WAS sat happily as a file sever for several Windows Vista/7 PC's. I have a DLink Router acting as an Internet Gateway and a DHCP Server. I was Happily running on IP Range - 255 on a Subnet of With the router as and the Ubuntu Box a fixed IP of

    For many reasons (mainly because I want to install openvpn) I changed the Subnet that the whole lot works on. to use - ( The router is Now on and the Ubuntu box is on everything is working fine EXCEPT Samba, the Unbuntu box has Disappear from "Network" on the Windows PC's.

    I have got desperate enough, to uninstall iptables, UFW, and samba, them reinstall them and have started the Samba config from scratch, and still I cannot get it to appear on the Windows PC's

    This a copy of my smb.conf file at the moment.

    netbios name = Father1
    workgroup = CCS
    security = user
    server string = CCS File Server

    path = /var/CCSshares/Public
    comment = CCS Members Common Share
    valid users = ccsadmin jamesm robinac arnoldb markr beng jeanh ginnyb danm
    write list = ccsadmin jamesm robinac arnoldb markr beng jeanh ginnyb danm
    read only = no
    available = no
    browseable = no
    writable = no
    guest ok = yes
    public = no
    printable = no
    locking = no
    strict locking = no

    If have have missed something, to with the change in the IP Addressing, but what?

  2. #2
    Join Date
    Apr 2008
    Birmingham UK
    Ubuntu 14.04 Trusty Tahr

    Re: Samba has stopped working.

    available = no
    browseable = no
    writable = no

    At a first glance, these settings should be yes.
    I'd also set

    locking = no

    to yes.

    Remember with SMB/CIFS browsing changes can take up to 15 minutes to refresh.

    Are your DNS settings right?

    Also, make sure that the users can access /var/CCSshares/public.
    Just a comment, but I would use /home instead of /var for shared folders, but that's just my preference.
    Last edited by wyliecoyoteuk; February 24th, 2012 at 04:58 PM. Reason: comment
    The sig between the asterisks is SO COOL that only REALLY COOL people can even see it!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts