Results 1 to 4 of 4

Thread: GMA500 : trouble after updating using poulsbo script

  1. #1
    Join Date
    Jan 2005
    Beans
    65
    Distro
    Ubuntu 7.04 Feisty Fawn

    GMA500 : trouble after updating using poulsbo script

    Hi all! today I updated my dell inspiron mini and for some reason the video driver stopped to work as expected. I'm getting the following errors:

    Ubuntu is running in low-graphics mode
    The following error was encountered. You may need to update your configuration to solve this.

    (EE) PSB(0): the stolenBase is:0x3f8000000
    (EE) PSB(0): screnIndex is:0;fbPhys is:0x3f9000000; fbsize is:0x007df000
    (EE) PSB(0): First SDVO output reported failure to sync or input is not trainded!!!
    (EE) [drm]: drmOpen failed. Disabling DRI.
    (EE) [drm] Could not uninstall irq handler.
    (EE) PSB(0): This driver currently needs DRM to operate.

    When I installed Karmic a couple of months ago I ran the poulsbo.sh script as described here https://wiki.ubuntu.com/HardwareSupp...Poulsbo#karmic

    Now for some reason it's not working with the new kernel (2.6.31-20-generic), there're some errors like:

    Loading new psb-kernel-source-4.41.6 DKMS files...
    Error! Could not find module source directory.
    Directory: /usr/src/psb-kernel-source-4.41.6 does not exist.

    I've all the files (11) related to this script under /tmp.

    Any idea on how to solve this problem?
    TIA!
    LU

    PS: I tried to rollback to 2.6.31-14-generic and re-run the script but got the same results.

  2. #2
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: GMA500 : trouble after updating using poulsbo script

    You need to run sudo dpkg-reconfigure psb-kernel-source after every kernel update. If that doesn't work, try reinstalling the psb-kernel-source package.
    Last edited by mikewhatever; April 6th, 2010 at 04:49 PM.

  3. #3
    Join Date
    Jan 2005
    Beans
    65
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: GMA500 : trouble after updating using poulsbo script

    Quote Originally Posted by mikewhatever View Post
    You need to run sudo dpkg-reconfigure psb-kernel-source after every kernel update. If that doesn't work, try reinstalling the psb-kernel-source package.
    OK, thanks so much, I finally managed to solve this by running dpkg -i /tmp/psb-kernel-source.

    Best regards
    LU

  4. #4
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: GMA500 : trouble after updating using poulsbo script

    Great! Now, you can make dkms take care of it for future kernel updates.
    (dkms - Dynamic Kernel Module Support)

    All you need to do is add AUTOINSTALL="yes" to the following two config files:

    /usr/src/psb-kernel-source-4.41.6/dkms.conf

    /var/lib/dkms/psb-kernel-source/4.41.6/build/dkms.conf
    Last edited by mikewhatever; April 7th, 2010 at 03:22 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •