Results 1 to 1 of 1

Thread: making Wacom Bamboo pen tablet CTL-460 work for Ubuntu 8.04 Hardy

  1. #1
    Join Date
    May 2008

    making Wacom Bamboo pen tablet CTL-460 work for Ubuntu 8.04 Hardy

    Sat, 03 Apr 2010, 11:27:03 EDT

    Summary for ubuntu forum (and also for my documentation):

    There are many web documents on how to download and install the
    linux drivers for wacom tablet devices, starting with

    but there was no document dedicated to show how to make the Wacom
    Bamboo pen tablet CTL-460 work for Ubuntu 8.04 Hardy.

    This document is intended for newbies (like me) who are new to
    Wacom devices, in particular the Bamboo pen tablet CTL-460, and
    want to make this device work under Ubuntu 8.04 Hardy.

    I first downloaded the linux wacom driver linuxwacom-0.8.4-4.tar.bz2,
    then followed the instructions in

    That was the only howto section for Ubuntu.

    Clearly this method did not work ... since it was intended for
    Ubuntu 9.04 64-bit system.

    A web search led to the following web sites:

    I next followed the instructions in the above web site for the
    following linux wacom driver versions



    None worked... even though the device properties obtained using the command lsusb in Step 2 gave

    vql@io: tcsh 22> lsusb | grep -i wacom
    Bus 004 Device 002: ID 056a:00d4 Wacom Co., Ltd
    vql@io: tcsh 23>
    i.e., the Wacom pen tablet CTL-460 is a "056a" device, and the web
    site said that

    Most models beginning with "056a" should work

    The procedure did not work for the Wacom pen tablet CTL-460.

    I looked into the file wacom.udev described in Step 16 in

    but did not find any wacom device corresponding to the USB device
    CTL-460 with ID 056a:00d4:

    Bus 004 Device 002: ID 056a:00d4 Wacom Co., Ltd

    It turned out that the Wacom Bamboo pen tablet CTL-460 was not
    yet supported by the stable release of the linuxwacom drivers,
    such as version 0.8.4-4.

    The inclusion of these newer devices was being incorporated in the
    development versions of linuxwacom.

    Another search revealed the following web document:

    where they were talking about development linuxwacom version 0.8.5-10
    or even 0.8.5-11.

    The development versions of linuxwacom can be obtained from the
    sourceforge of linuxwacom under linuxwacom-dev. Only the newer
    version 0.8.5-12 was available; so I downloaded this version.
    But following the above document did not work for the Wacom pen
    tablet CTL-460.

    UPDATE: I had to reinstall ubuntu 8.04.4 due to a root partition problem when I unplugged the laptop before a complete shutdown! After that, yum broke down (it is needed in the linuxwacom version 0.8.5-12); it no longer worked for the newer linux kernel 2.4.6-28. I decided to go with the latest linuxwacom version 0.8.8-8 as of Sep 2010. Following the same steps described here; it worked (yum was not needed).

    See also

    So I went back to follow the steps in

    with the following modification to Step 16. After downloading the file wacom.udev, edit it to add the
    following line for the Wacom Bamboo pen tablet CTL-460:

    ATTRS{idVendor}=="056a", ATTRS{idProduct}=="00d4", SYMLINK+="input/tablet-wacom-bamboo-pen"

    Back up the file


    and then copy to overwrite the above file with the modified wacom.udev.

    After the above, follow through to Step 19 to reboot; it should work.

    To adjust the properties of the pen, run the command wacomcpl:

    vql@io: tcsh 29> wacomcpl
    wacomcpl: using TCLLIBPATH="[list /usr/local/lib ]"
    vql@io: tcsh 30>

    to bring up a GUI window. On the left subwindow, click at "stylus"
    (pen) to select this device. On the right, appear the buttons
    "Feel", "Tool Buttons", "Tracking", "Screen Mapping". Click the
    button "Feel" allows you to adjust the Tip Sensitivity (soft to
    firm, default 4), the Click Force (low to high, default 11), the
    Smoothness (low to high, default 4), the Suppress Point (low to high,
    default 2).

    There are 2 positioning modes: Absolute and relative (like a mouse).
    For use as a mouse, it is better to use the relative positioning;
    for use to write, it is better to use the absolute positioning.
    To select the positioning mode, run wacomcpl to bring up the Wacom
    Control Panel, then click "Tool Buttons", and under "Positioning
    Mode", select "Absolute" or "Relative".

    Check out also the web document

    Linux Wacom Project HOWTO
    5.1 - Adding the InputDevices

    After an upgrade of the linux kernel, the pen tablet stopped
    working; for example, I had ffmpeg and the wacom pen tablet work
    for 2.6.24-26; for linux kernel 2.6.24-{27,28}, ffmpeg misbehaved,
    and the wacom tablet did not work. (I may have compiled ffmpeg
    under 2.6.24-26.)

    To reinstall the wacom pen tablet for a specific linux kernel,
    you will need to redo the installation of the linux wacom driver
    from Step 7 (reconfigure and recompile), skip Steps 8-12, redo
    Steps 13-19.

    For Ubuntu 10.04 Lucid LTS, see

    On the other hand, there are reasons to stay with ubuntu 8.04, and not upgrade to ubuntu 10.04, since there are programs working under ubuntu 8.04, but not under ubuntu 10.04, e.g.,

    If it is working, don't fix it; wait till you have a new laptop to install a newer OS, such as ubuntu 10.04, which by that time may have all the bugs cleared out, and to find an alternative to programs such as Ekee (if you need them). I am glad that I decided to reinstall ubuntu 8.04.4 and not ubuntu 10.04, so programs that have been working for me continue to work for me.
    Last edited by statmech; September 6th, 2010 at 11:31 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts