Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Language Support Problems

  1. #1
    Join Date
    Jan 2009
    Location
    China
    Beans
    57
    Distro
    Ubuntu 12.04 Precise Pangolin

    Language Support Problems

    Hi all,

    I have been trying to activate iBus and install Chinese Language packs on my reasonably new Karmic 64-bit install. When I go to the Language Support in the Administration menu I get a message saying that...

    Language support is not installed completely. Some translations or writing aids available for your chosen languages are not installed yet. Do you want to install them now?
    I have the option to be reminded later or install them now. Choose install them now and I get a new message.

    Could not apply changes. Fix broken packages first!
    In the details of the error messages these are the packages that are listed....

    thunderbird-locale-en-gb
    gimp-help-en
    kde-l10n-engb
    gnome-user-guide-en
    openoffice.org-help-en-gb
    openoffice.org-l10n-en-gb
    language-pack-kde-en
    openoffice.org-l10n-en-za


    I have scoured Synaptic for each, and none are installed. I have run the broken packages fix and also followed another guide which did not work which suggested running a few commands...

    Code:
    sudo apt-get -configure -a
    Code:
    sudo apt-get -f install
    Code:
    sudo apt-get --fix-missing install
    Code:
    sudo apt-get clean
    Code:
    sudo apt-get update
    The sudo apt-get update returned an error that disappeared after re-rerunning it again and the first configure command returned a small error too about not understanding the code and then

    E: Opening configuration file onfigure - ifstream::ifstream (2: No such file or directory)
    After all of these still no joy. It will not fix the problem. If I ignore the problem and move on to the next box and select ibus as the input method and go select Add a new language and choose Chinese the language support box greys out and remains this way eternally (until I go into the process in System Monitor and manually kill it.

    Can anyone help me out here please?

    Cheers and thanks,

    Nick

  2. #2
    Join Date
    Jan 2009
    Location
    China
    Beans
    57
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language Support Problems

    No-one out there is able to give me any help on this?

    Also the last couple of times I have run the Update Manager I am getting these error messages back.

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...ic/Release.gpg Could not connect to mirror.pacific.net.au:80 (61.8.0.17), connection timed out

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...es/Release.gpg Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...ty/Release.gpg Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://mirror.pacific.net.au/linux/u...tion-en_AU.bz2 Unable to connect to mirror.pacific.net.au http:

    W: Failed to fetch http://packages.medibuntu.org/dists/karmic/Release.gpg Could not connect to packages.medibuntu.org:80 (88.191.82.11), connection timed out

    W: Failed to fetch http://packages.medibuntu.org/dists/...tion-en_AU.bz2 Unable to connect to packages.medibuntu.org http:

    W: Failed to fetch http://packages.medibuntu.org/dists/...tion-en_AU.bz2 Unable to connect to packages.medibuntu.org http:

    W: Some index files failed to download, they have been ignored, or old ones used instead.

    I have tried a number of different servers but with no luck. I can see language packs amongst this. Is this problem linked?

    If not any ideas what is going on here?

    Please...

    Thanks,

    Nick

  3. #3
    Join Date
    Jan 2009
    Location
    China
    Beans
    57
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language Support Problems

    Fixed the downloads for update problem but still no solution for the Language Support Problems. It is preventing me from installing new language packs as, when I choose a language pack to install, it says it is going about this but it actually seems to be doing nothing. I have left it running for a long time and still it seems to be unable to complete the task. I can't kill it either once it is started. The only way to stop the process is to restart.

    Anyone any ideas?

    Thanks,

    Nick

  4. #4
    Join Date
    Jan 2010
    Location
    Wuerzburg / Germany
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Language Support Problems

    I have the same problem. The commands above don't work for me neither. I just want to say, that you are not the only one having this problem. However I just installed Ubuntu Version 10.04 and it is the first time this problem occurs.

    A second install of Ubuntu showed, that the setup procedure is able to fetch the approbriate packets from the internet, while the PC is connected to the Internet during installation. Maybe this helps to find a solution.

  5. #5
    Join Date
    Jan 2009
    Location
    China
    Beans
    57
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language Support Problems

    Thanks for your info. Anyone else can weight in here as to what the problem is and/or how to fix it?

    This has been going on for quite a while now.

    Any help would make me atleast a little happy...

    Nick

  6. #6
    Join Date
    May 2007
    Beans
    314
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language Support Problems

    No help or fix - just tried to purge all Russian language support files and install them again - no effect.

  7. #7
    Join Date
    May 2007
    Beans
    314
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language Support Problems

    It turns out there's no full language support for Russian. The package "language-support-input-ru" isn't installable - there's no such a package in repositories.

  8. #8
    Join Date
    Oct 2007
    Location
    Japan
    Beans
    637
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language Support Problems

    try installing them from synaptic. When I type "Chinese" into the search I can see all of the language packs and input methods. Not sure which Chinese you need "simplified" or one of the others.
    "Don't Panic"

  9. #9
    Join Date
    May 2007
    Beans
    314
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language Support Problems

    There's no such a package (language-support-input-ru) in Synaptic.

    $ aptitude search language-support-input-ru
    c language-support-input-ru - Input methods metapackage for Russian
    $ aptitude show language-support-input-ru
    No current or candidate version found for language-support-input-ru
    Package: language-support-input-ru
    State: not installed
    Version: 1:9.10+20090909
    Priority: optional
    Section: translations
    Maintainer: Language pack maintainers <language-packs@ubuntu.com>
    Uncompressed Size: 41,0k
    Depends: im-switch
    Description: Input methods metapackage for Russian
    This metapackage depends on input method packages which might be useful in a
    Russian language environment.

    If you also want your applications and the desktop to be translated, please
    additionally install language-pack-ru.

    Language: Russian
    There was the package in Ubuntu-9.10 but current stable (10.04) doesn't have one.

  10. #10
    Join Date
    Jan 2009
    Location
    China
    Beans
    57
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Language Support Problems

    Don't know if it's any help to anyone but I went back to the language administration and tried to install what I wanted and everything went smoothly and I now have iBus and all the language input methods I want up and running. Don't know what changed or fixed it but it is. I did nothing.

    Nick
    Last edited by nicknefarious; August 21st, 2010 at 04:46 AM. Reason: spelling error

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •