Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Waltop tablet stop work in Lucid

  1. #11
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Waltop tablet stop work in Lucid

    At your command

    Code:
    mato@R2-D2:~$ ls /dev/input
    by-id    event0  event2  event4  event6  mouse0  mouse2
    by-path  event1  event3  event5  mice    mouse1
    mato@R2-D2:~$

  2. #12
    Join Date
    Feb 2010
    Location
    Louisville, KY
    Beans
    414
    Distro
    Ubuntu Development Release

    Re: Waltop tablet stop work in Lucid

    After taking another look at your log and xorg.conf file im thinking it may not work.

    Notice for Serial Graphics Tablet Users: This quote is from a LWP developer (2-17-10):
    Quote:
    If it is not an ISDv4 model, i.e., the digitizer is not embedded in your laptop/desktop, you will have to
    use an X server older than XOrg 1.7. We do not support regular serial tablets on X server 1.7 or later.
    In other words, if this is correct, external Serial Graphics Tablets connecting via a serial cable will not be supported on X server 1.7 (Lucid) and up. If true do not update to Lucid! Waiting on further clarification.

    http://ubuntuforums.org/showpost.php...12&postcount=1

    Im thinking this applies to you.
    I may be wrong though, someone feel free to correct me if I am.

  3. #13
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Waltop tablet stop work in Lucid

    Mine is USB not Serial.
    By the way... I can't compile linuxwacom it gives me errors at "make" step

    Code:
    mato@R2-D2:~/Escritorio/linuxwacom-0.8.4-4$ make
    Making all in src
    make[1]: se ingresa al directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src'
    Making all in .
    make[2]: se ingresa al directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src'
    make[2]: No se hace nada para `all-am'.
    make[2]: se sale del directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src'
    Making all in wacomxi
    make[2]: se ingresa al directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src/wacomxi'
    make[2]: No se hace nada para `all'.
    make[2]: se sale del directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src/wacomxi'
    Making all in util
    make[2]: se ingresa al directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src/util'
    make[2]: No se hace nada para `all'.
    make[2]: se sale del directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src/util'
    Making all in xdrv
    make[2]: se ingresa al directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src/xdrv'
    gcc -g -O2 -D__amd64__ -I/usr/include/tcl8.4  -fPIC -pipe -std=c99 \
    		-pedantic -Wall -Wpointer-arith -fno-merge-constants \
    		-fno-stack-protector -I. -I../include -I/usr/include/xorg  -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1   \
    		-D_XSERVER64 -fvisibility=hidden -I/usr/include/xorg -I/usr/include/pixman-1   \
    		-o xf86Wacom.o -c ./xf86Wacom.c
    In file included from ./xf86Wacom.h:27,
                     from ./xf86Wacom.c:93:
    /usr/include/xorg/xorg-server.h:183:1: warning: "XFree86LOADER" redefined
    In file included from ./xf86Wacom.h:25,
                     from ./xf86Wacom.c:93:
    ./../include/xdrv-config.h:9:1: warning: this is the location of the previous definition
    In file included from ./xf86Wacom.h:159,
                     from ./xf86Wacom.c:93:
    ./xf86WacomDefs.h:129:1: warning: "MAX_BUTTONS" redefined
    In file included from /usr/include/xorg/xf86str.h:38,
                     from /usr/include/xorg/xf86.h:46,
                     from ./xf86Wacom.h:68,
                     from ./xf86Wacom.c:93:
    /usr/include/xorg/input.h:80:1: warning: this is the location of the previous definition
    ./xf86Wacom.c: In function ‘xf86WcmInitialCoordinates’:
    ./xf86Wacom.c:368: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:395: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c: In function ‘xf86WcmRegisterX11Devices’:
    ./xf86Wacom.c:630: warning: passing argument 3 of ‘InitButtonClassDeviceStruct’ from incompatible pointer type
    /usr/include/xorg/input.h:290: note: expected ‘Atom *’ but argument is of type ‘CARD8 *’
    ./xf86Wacom.c:630: error: too few arguments to function ‘InitButtonClassDeviceStruct’
    ./xf86Wacom.c:670: warning: passing argument 3 of ‘InitValuatorClassDeviceStruct’ makes pointer from integer without a cast
    /usr/include/xorg/input.h:296: note: expected ‘Atom *’ but argument is of type ‘int’
    ./xf86Wacom.c:670: error: too few arguments to function ‘InitValuatorClassDeviceStruct’
    ./xf86Wacom.c:712: warning: implicit declaration of function ‘InitKeyClassDeviceStruct’
    ./xf86Wacom.c:720: warning: implicit declaration of function ‘InitKbdFeedbackClassDeviceStruct’
    ./xf86Wacom.c:751: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:756: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:757: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:765: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:766: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:772: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:773: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:781: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:786: error: too few arguments to function ‘InitValuatorAxisStruct’
    ./xf86Wacom.c:790: error: too few arguments to function ‘InitValuatorAxisStruct’
    make[2]: *** [xf86Wacom.o] Error 1
    make[2]: se sale del directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src/xdrv'
    make[1]: *** [all-recursive] Error 1
    make[1]: se sale del directorio `/home/mato/Escritorio/linuxwacom-0.8.4-4/src'
    make: *** [all-recursive] Error 1
    So, I can't follow that guide

  4. #14
    Join Date
    Feb 2010
    Location
    Louisville, KY
    Beans
    414
    Distro
    Ubuntu Development Release

    Re: Waltop tablet stop work in Lucid

    Try seeing what events give you a response when using the stylus.
    sudo xxd /dev/input/eventx

    Try events 1-6

  5. #15
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Waltop tablet stop work in Lucid

    Quote Originally Posted by mcoleman44 View Post
    Try seeing what events give you a response when using the stylus.
    sudo xxd /dev/input/eventx

    Try events 1-6
    Nothing... the tablet in lshal at least is /dev/input/event5... nothing happens.
    the other are not the tablet.. event3 is keyboard and event4 mouse.

    I'm out of my mind.... I think Lucid is not an option to me.

    I go back to Karmic and stay there for ever..

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •