Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Waltop tablet stop work in Lucid

  1. #1
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Waltop tablet stop work in Lucid

    Hi, I have a Genius F509 tablet, in Jaunty/Karmic with Hal the talbet work fine.
    I have a test PC where I test new releases.. I put Lucid beta1 there and when I try to make work the tablet... guess what? yes, are dead
    Now Hal are gone, so, how to manage tablets right now??
    In Xorg.log it appear, also in lshal... but the tablet are dead.

    lshal
    Code:
    udi = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial'
      info.linux.driver = 'usb' (string)
      info.parent = '/org/freedesktop/Hal/devices/usb_device_1d6b_1_0000_00_0b_0' (string)
      info.product = ' Tablet' (string)
      info.subsystem = 'usb_device' (string)
      info.udi = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial' (string)
      info.vendor = 'Waltop International Corp.' (string)
      linux.device_file = '/dev/bus/usb/002/003' (string)
      linux.hotplug_type = 2 (0x2) (int)
      linux.subsystem = 'usb' (string)
      linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.0/usb2/2-4' (string)
      usb_device.bus_number = 2 (0x2) (int)
      usb_device.can_wake_up = false (bool)
      usb_device.configuration_value = 1 (0x1) (int)
      usb_device.device_class = 0 (0x0) (int)
      usb_device.device_protocol = 0 (0x0) (int)
      usb_device.device_revision_bcd = 257 (0x101) (int)
      usb_device.device_subclass = 0 (0x0) (int)
      usb_device.is_self_powered = false (bool)
      usb_device.linux.device_number = 3 (0x3) (int)
      usb_device.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.0/usb2/2-4' (string)
      usb_device.max_power = 100 (0x64) (int)
      usb_device.num_configurations = 1 (0x1) (int)
      usb_device.num_interfaces = 1 (0x1) (int)
      usb_device.num_ports = 0 (0x0) (int)
      usb_device.product = ' Tablet' (string)
      usb_device.product_id = 56 (0x38) (int)
      usb_device.speed = 12.0 (12) (double)
      usb_device.vendor = 'Waltop International Corp.' (string)
      usb_device.vendor_id = 5935 (0x172f) (int)
      usb_device.version = 1.1 (1.1) (double)
    
    udi = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial_if0'
      info.linux.driver = 'usbhid' (string)
      info.parent = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial' (string)
      info.product = 'USB HID Interface' (string)
      info.subsystem = 'usb' (string)
      info.udi = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial_if0' (string)
      linux.hotplug_type = 2 (0x2) (int)
      linux.subsystem = 'usb' (string)
      linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.0/usb2/2-4/2-4:1.0' (string)
      usb.bus_number = 2 (0x2) (int)
      usb.can_wake_up = false (bool)
      usb.configuration_value = 1 (0x1) (int)
      usb.device_class = 0 (0x0) (int)
      usb.device_protocol = 0 (0x0) (int)
      usb.device_revision_bcd = 257 (0x101) (int)
      usb.device_subclass = 0 (0x0) (int)
      usb.interface.class = 3 (0x3) (int)
      usb.interface.number = 0 (0x0) (int)
      usb.interface.protocol = 0 (0x0) (int)
      usb.interface.subclass = 0 (0x0) (int)
      usb.is_self_powered = false (bool)
      usb.linux.device_number = 3 (0x3) (int)
      usb.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.0/usb2/2-4/2-4:1.0' (string)
      usb.max_power = 100 (0x64) (int)
      usb.num_configurations = 1 (0x1) (int)
      usb.num_interfaces = 1 (0x1) (int)
      usb.num_ports = 0 (0x0) (int)
      usb.product = 'USB HID Interface' (string)
      usb.product_id = 56 (0x38) (int)
      usb.speed = 12.0 (12) (double)
      usb.vendor = 'Waltop International Corp.' (string)
      usb.vendor_id = 5935 (0x172f) (int)
      usb.version = 1.1 (1.1) (double)
    
    udi = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial_if0_logicaldev_input'
      info.capabilities = {'input', 'input.mouse', 'input.tablet'} (string list)
      info.category = 'input' (string)
      info.parent = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial_if0' (string)
      info.product = 'stylus' (string)
      info.subsystem = 'input' (string)
      info.udi = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial_if0_logicaldev_input' (string)
      input.device = '/dev/input/event5' (string)
      input.originating_device = '/org/freedesktop/Hal/devices/usb_device_172f_38_noserial_if0' (string)
      input.product = ' WALTOP Tablet' (string)
      input.x11_driver = 'wacom' (string)
      input.x11_options.BottomX = '17679' (string)
      input.x11_options.BottomY = '10686' (string)
      input.x11_options.TopX = '21' (string)
      input.x11_options.TopY = '21' (string)
      input.x11_options.Type = 'stylus' (string)
      linux.device_file = '/dev/input/event5' (string)
      linux.hotplug_type = 2 (0x2) (int)
      linux.subsystem = 'input' (string)
      linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0b.0/usb2/2-4/2-4:1.0/input/input5/event5' (string)
    Xorg.log
    Code:
    (II) config/udev: Adding input device WALTOP Tablet (/dev/input/event5)
    (**) WALTOP Tablet : Applying InputClass "evdev pointer catchall"
    (**) WALTOP Tablet : Applying InputClass "evdev tablet catchall"
    (**) WALTOP Tablet : Applying InputClass "Wacom class"
    (II) LoadModule: "wacom"
    (II) Loading /usr/lib/xorg/modules/input/wacom_drv.so
    (II) Module wacom: vendor="X.Org Foundation"
     compiled for 1.7.6, module version = 0.10.5
     Module class: X.Org XInput Driver
     ABI class: X.Org XInput driver, version 7.0
    (**) Option "Device" "/dev/input/event5"
    (II) WALTOP Tablet : type not specified, assuming 'stylus'.
    (II) WALTOP Tablet : other types will be automatically added.
    (**) WALTOP Tablet : always reports core events
    (II) WALTOP Tablet : hotplugging dependent devices.
    (**) Option "Device" "/dev/input/event5"
    (**) WALTOP Tablet eraser: always reports core events
    (II) XINPUT: Adding extended input device " WALTOP Tablet eraser" (type: ERASER)
    (--) WALTOP Tablet eraser: using pressure threshold of 61 for button 1
    (--) WALTOP Tablet eraser: Wacom Unknown USB tablet speed=38400 maxX=17920 maxY=10752 maxZ=1023 resX=1016 resY=1016 tilt=enabled
    (--) WALTOP Tablet eraser: top X=0 top Y=0 bottom X=17920 bottom Y=10752 resol X=1016 resol Y=1016
    (II) WALTOP Tablet : hotplugging completed.
    (II) XINPUT: Adding extended input device " WALTOP Tablet " (type: STYLUS)
    (--) WALTOP Tablet : top X=0 top Y=0 bottom X=17920 bottom Y=10752 resol X=1016 resol Y=1016
    (II) config/udev: Adding input device WALTOP Tablet (/dev/input/mouse2)
    [b]lsusb]
    Code:
    Bus 002 Device 003: ID 172f:0038 Waltop International Corp.
    xinput
    Code:
    mato@R2-D2:~$ xinput --list
    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ Genius Optical Mouse                    	id=8	[slave  pointer  (2)]
    ⎜   ↳          WALTOP             Tablet      	id=10	[slave  pointer  (2)]
    ⎜   ↳          WALTOP             Tablet     eraser	id=9	[slave  pointer  (2)]
    ⎜   ↳ Macintosh mouse button emulation        	id=12	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Power Button                            	id=6	[slave  keyboard (3)]
        ↳ Power Button                            	id=7	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]
    mato@R2-D2:~$
    xsetwacom
    Code:
    mato@R2-D2:~$ xsetwacom --list -v
    ... Display is '(null)'.
    ... 'list' requested.
    ... Found device 'Virtual core XTEST pointer' (4).
    ... Found device 'Virtual core XTEST keyboard' (5).
    ... Found device 'Power Button' (6).
    ... Found device 'Power Button' (7).
    ... Found device 'Genius Optical Mouse' (8).
    ... Found device '         WALTOP             Tablet    ' (10).
             WALTOP             Tablet     STYLUS    
    ... Found device '         WALTOP             Tablet     eraser' (9).
             WALTOP             Tablet     eraser ERASER    
    ... Found device 'AT Translated Set 2 keyboard' (11).
    ... Found device 'Macintosh mouse button emulation' (12).
    mato@R2-D2:~$
    Well.... I need it, so, if that don't have fix.... I can't use Lucid when become released

    Any idea??? someone?? thanks in advance.....

  2. #2
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Waltop tablet stop work in Lucid

    Bump!!!

  3. #3
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Waltop tablet stop work in Lucid

    2nd Bump

  4. #4
    Join Date
    Sep 2007
    Location
    Tōkyō, Japan
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Waltop tablet stop work in Lucid


  5. #5
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Waltop tablet stop work in Lucid

    Quote Originally Posted by NCLI View Post
    Yes, I know....... there's somes

    But, I ask for the metod to make it work without Hal...
    If I uninstall xserver-xorg-input-wacom the tablet began to work like a mouse... but there's no way (that I know) to configure it.
    wacom.fdi not work anymore and with xsetwacom either.
    With xserver-xorg-input-wacom the tablet comes to dead state

    If someone know how to make work tablets without Hal... please advice

  6. #6
    Join Date
    Feb 2010
    Location
    Louisville, KY
    Beans
    414
    Distro
    Ubuntu Development Release

    Re: Waltop tablet stop work in Lucid

    Code:
    sudo apt-get install git-core
    
    cd ./Desktop
    
    git clone git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/xf86-input-wacom
    
    sudo apt-get build-dep xf86-input-wacom
    
    cd xf86-input-wacom
    
    ./autogen.sh --prefix=/usr
    
    make
    
    sudo make install
    This should get things working.

    You need to configure it using an xorg.conf by the way.
    Last edited by mcoleman44; April 4th, 2010 at 12:02 AM.

  7. #7
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Waltop tablet stop work in Lucid

    Quote Originally Posted by mcoleman44 View Post
    Code:
    sudo apt-get install git-core
    
    cd ./Desktop
    
    git clone git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/xf86-input-wacom
    
    sudo apt-get build-dep xf86-input-wacom
    
    cd xf86-input-wacom
    
    ./autogen.sh --prefix=/usr
    
    make
    
    sudo make install
    This should get things working.

    You need to configure it using an xorg.conf by the way.
    I already try it with no luck.... thanks any way...
    The tablet use the udev....
    I change The xorg.conf like this:

    Code:
    Section "InputDevice"
    	Identifier 	"stylus"
            Driver 		"wacom"
            Option 		"Device"	"/dev/input/event5"
            Option  	"Type"		"stylus"
    	Option 		"Mode" 		"Relative"
    	Option  	"USB"           "on"
    	Option 		"TopX" 		"21"
    	Option 		"TopY" 		"21"
    	Option 		"BottomX"	"17679"
    	Option 		"BottomX" 	"10686"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	DefaultDepth	24
    	SubSection "Display"
                    Depth     24
                    Modes     "1280x1024"
            EndSubSection
    EndSection
    
    Section "Module"
    	Load	"glx"
    EndSection
    
    Section "Device"
    	Identifier	"Default Device"
    	Driver	"nvidia"
    	Option	"NoLogo"	"True"
    EndSection
    
    Section "ServerLayout"
      Identifier    "Default Layout"
      Screen        "Default Screen"
      InputDevice   "stylus"  "SendCoreEvents"
    EndSection
    And the log of xorg are:

    Code:
    (II) config/udev: Adding input device          WALTOP             Tablet     (/dev/input/event5)
    (**)          WALTOP             Tablet    : Applying InputClass "evdev pointer catchall"
    (**)          WALTOP             Tablet    : Applying InputClass "evdev tablet catchall"
    (**)          WALTOP             Tablet    : always reports core events
    (**)          WALTOP             Tablet    : Device: "/dev/input/event5"
    (II)          WALTOP             Tablet    : Found 9 mouse buttons
    (II)          WALTOP             Tablet    : Found scroll wheel(s)
    (II)          WALTOP             Tablet    : Found relative axes
    (II)          WALTOP             Tablet    : Found x and y relative axes
    (II)          WALTOP             Tablet    : Found absolute axes
    (II)          WALTOP             Tablet    : Found x and y absolute axes
    (II)          WALTOP             Tablet    : Found absolute tablet.
    (II)          WALTOP             Tablet    : Configuring as tablet
    (**)          WALTOP             Tablet    : YAxisMapping: buttons 4 and 5
    (**)          WALTOP             Tablet    : EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    (II) XINPUT: Adding extended input device "         WALTOP             Tablet    " (type: TABLET)
    (WW)          WALTOP             Tablet    : touchpads, tablets and touchscreens ignore relative axes.
    (II)          WALTOP             Tablet    : initialized for absolute axes.
    (II) config/udev: Adding input device          WALTOP             Tablet     (/dev/input/mouse2)
    (II) No input driver/identifier specified (ignoring)
    The wacom's module is loaded



    I don't know other changes to do it...... any sugestion??

  8. #8
    Join Date
    Feb 2010
    Location
    Louisville, KY
    Beans
    414
    Distro
    Ubuntu Development Release

    Re: Waltop tablet stop work in Lucid

    see if you get any results when trying this. Type this command and try using your finger or the stylus to see if you get any results
    sudo xxd /dev/hidraw1

    press ctrl+c to exit the application.
    if you get no response from hidraw1 try hidraw0 and hidraw2

  9. #9
    Join Date
    Jun 2006
    Location
    Argentina - La Plata
    Beans
    85
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Waltop tablet stop work in Lucid

    Quote Originally Posted by mcoleman44 View Post
    see if you get any results when trying this. Type this command and try using your finger or the stylus to see if you get any results
    sudo xxd /dev/hidraw1

    press ctrl+c to exit the application.
    if you get no response from hidraw1 try hidraw0 and hidraw2
    Yes.. it start to move like a mouse and responds on buttons clicks....

  10. #10
    Join Date
    Feb 2010
    Location
    Louisville, KY
    Beans
    414
    Distro
    Ubuntu Development Release

    Re: Waltop tablet stop work in Lucid

    Post the results of ls /dev/input
    please

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •