Oh, ...I see


Cause you need some serious search skills to work with Gentoo.

Anyway, I recommend downloading the latest stage3 tarballs from one of Gentoo mirrors and using your installed Ubuntu.