Results 1 to 5 of 5

Thread: need some help with octave

Hybrid View

  1. #1
    Join Date
    Aug 2005
    Location
    Braga,Portugal
    Beans
    118
    Distro
    Ubuntu 10.10 Maverick Meerkat

    need some help with octave

    Hello people!

    I'm trying collect a data from a cvs file.
    But I can't run plot.

    I'm noob at octave, I'm a ex matlab user.

    Code:
    clear
    clc
    [ndata, headertext] = xlsread('Data100M_11.csv', 'sheet1');
    
    [a,b]=size(headertext);
    
    text = headertext(1,:); %save strings from LSD Header
    data=headertext(2:a,:) %data from LSD res file
    
    [c,d]=size(data)
    
    k=1:1:c; %creates a K vector to discrete time steps
    x1=(data(:,1)) %assign to x1 first column from file
    
    %plot() %I wanna plot, I don't know how... I think is because it's a cell array?!
    (file in attach)
    Attached Files Attached Files

  2. #2
    Join Date
    Mar 2010
    Beans
    1

    Re: need some help with octave

    Quote Originally Posted by clapton View Post
    Hello people!

    I'm trying collect a data from a cvs file.
    But I can't run plot.

    I'm noob at octave, I'm a ex matlab user.

    Code:
    clear
    clc
    [ndata, headertext] = xlsread('Data100M_11.csv', 'sheet1');
    
    [a,b]=size(headertext);
    
    text = headertext(1,:); %save strings from LSD Header
    data=headertext(2:a,:) %data from LSD res file
    
    [c,d]=size(data)
    
    k=1:1:c; %creates a K vector to discrete time steps
    x1=(data(:,1)) %assign to x1 first column from file
    
    %plot() %I wanna plot, I don't know how... I think is because it's a cell array?!
    (file in attach)
    We used a variable-sized headline style for our ads in the '90s. It was a PITA to get the copywriters to give us headlines that worked. We typically used two different sizes in the heds, but the key in compositing was using LOTS of negative space.

  3. #3
    Join Date
    Dec 2007
    Location
    In the lab
    Beans
    122

    Re: need some help with octave

    Quote Originally Posted by clapton View Post
    Hello people!

    I'm trying collect a data from a cvs file.
    But I can't run plot.

    I'm noob at octave, I'm a ex matlab user.

    Code:
    clear
    clc
    [ndata, headertext] = xlsread('Data100M_11.csv', 'sheet1');
    
    [a,b]=size(headertext);
    
    text = headertext(1,:); %save strings from LSD Header
    data=headertext(2:a,:) %data from LSD res file
    
    [c,d]=size(data)
    
    k=1:1:c; %creates a K vector to discrete time steps
    x1=(data(:,1)) %assign to x1 first column from file
    
    %plot() %I wanna plot, I don't know how... I think is because it's a cell array?!
    (file in attach)
    Eheheh, olha um companheiro de Braga!

    Hi

    I also started using octave recently. Maybe I could help but you don't say what you are trying to plot. Your code only plays around with the text extracted from the xls file, not with any numbers. Basically,plot works

    Code:
    plot (xData, yData)
    I think in your case

    Code:
    plot(k, ndata(:,1))  #this should plot m_cmax
    plot(k, ndata)       #this will plot all columns
    Run 'help plot' to see how it works

    You could also try the octave help mailing list. They are very helpful.

  4. #4
    Join Date
    Mar 2011
    Beans
    1

    Question Re: need some help with octave

    Hi,
    Is this the right place to post a question about trying to run Octave within Cygwin? Scripts will run, but (new) functions do nothing but display ">" in place of the Octave prompt. This seems to be in some kind of editing mode (from which there's no obvious escape). What to do?
    Finder9

  5. #5
    Join Date
    Dec 2007
    Location
    In the lab
    Beans
    122

    Re: need some help with octave

    Quote Originally Posted by Finder9 View Post
    Hi,
    Is this the right place to post a question about trying to run Octave within Cygwin? Scripts will run, but (new) functions do nothing but display ">" in place of the Octave prompt. This seems to be in some kind of editing mode (from which there's no obvious escape). What to do?
    Finder9
    Hello Finder9

    I don't think this is the right place if it's Cygwin specific. Try asking in the octave help mailing list (help@octave.org), some people there use it in cygwin. See this page on their homepage.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •