Thanks alot Jim. I am up and printing with no problems! The directions in the install file worked perfectly except for one part.

I got this error when running the "make" command:

#
# Dependencies...
#
***
*** Error: /usr/include/cups/raster.h is not installed!
***
*** Install cups raster library package
*** for Ubuntu: sudo apt-get install libcupsimage2
***
make: *** [all-test] Error 1

So I tried "sudo apt-get install libcupsimage2" and I got a message that it was already the latest version.

I googled and found this thread:

http://ubuntuforums.org/showthread.php?p=9300604

where someone had said:

"You need to install libcupsimage2-dev then it'll work"

and they were right, it worked.

I made a mistake in my first post, the computer I was working on had Karmic, not Lucid, if that matters.

Thanks everyone!