Page 7 of 7 FirstFirst ... 567
Results 61 to 65 of 65

Thread: HOWTO: Starcraft 2 in WINE

  1. #61
    Join Date
    Nov 2010
    Beans
    4

    Re: HOWTO: Starcraft 2 in WINE

    facing problems when I'm trying to update with the latest patch from blizzard.

    the download jump to 100% immediately and after that nothing happens. So i reboot my computer and try again. now as smaller window appear. "Blizzard updater" and the text "waiting for files to close" but nothing happens.

    anyone else facing this problem or have any solution?

  2. #62
    Join Date
    Mar 2011
    Beans
    1

    Re: HOWTO: Starcraft 2 in WINE

    Quote Originally Posted by AChunkee View Post
    Ok my starcraft 2 works while running on ubuntu 10.04 with WINE but whenever I try to go to medium graphic settings my game always crashes!!!! im stuck on low settings. the fps is pretty darn good though I have to admit. I have an Nvidia gtx460 graphics card which should be able to run starcraft 2 on ultra no problem. I have the latest drivers installed for my card straight from nvidias website. I have no audio problems or startup problems what so ever just can't get my game to run on better graphics settings. Compiz is disabled. Anyone know how to help?
    I know this was posted a long time ago, but the fix for this is to set the VideoMemorySettings emulation keys in the Wine registry. Using the Wine environment where you Starcraft II is installed, run regedit. Once the Registry Viewer is visible, go to HKEY_CURRENT_USERS, and if it doesn't exist already, create a "Direct3D" key under "HKEY_CURRENT_USER/Software/Wine". Within "Direct3D", create a string value whose name is "VideoMemorySize" and set the value to be however much video mem your video card has, in megabytes. So if your card has a gig, set it to 1024.

    You'll find more info here: http://wiki.winehq.org/UsefulRegistryKeys
    Last edited by herbyg; March 31st, 2011 at 04:46 AM.

  3. #63
    Join Date
    Jul 2006
    Beans
    35
    Distro
    Ubuntu 6.10 Edgy

    Re: HOWTO: Starcraft 2 in WINE

    Anyone having problems with the F10 key? I just played my first multiplayer match in Wine and everytime I hit F10, instead of bringing up that menu it would instead bring up the Wireless Connection Settings from my Ubuntu desktop (?). All the other function keys worked fine. May have been because I was running in Ubiquity. I switched back to classic (for sanity's sake) but don't know if that's going to make a difference.
    Hero of Allacrost, an open-source, classical 2D role-playing game. Check us out!

  4. #64
    Join Date
    May 2009
    Location
    FI
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Starcraft 2 in WINE

    Ubuntu UI shortcut keys are handeled first, had similar problem with D2, alt+mouse1 wanted to move window instead showing up loot labels and picking them up.

    So easiest way is to change wireless connection shortcut key.
    "Trying is the first step towards failure"
    - Homer Simpson

  5. #65
    Join Date
    Jul 2006
    Beans
    35
    Distro
    Ubuntu 6.10 Edgy

    Re: HOWTO: Starcraft 2 in WINE

    Actually I fixed it by using the classic desktop instead of Unity (which I was already planning to abandon anyway). Now the game runs fine, except for the performance. Its good enough for single player but the lag is too strong to micro effectively in multiplayer matches.
    Hero of Allacrost, an open-source, classical 2D role-playing game. Check us out!

Page 7 of 7 FirstFirst ... 567

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •