Page 8 of 10 FirstFirst ... 678910 LastLast
Results 71 to 80 of 98

Thread: ATI mobility Radeon HD 5470

  1. #71
    Join Date
    Dec 2010
    Beans
    1

    Re: ATI mobility Radeon HD 5470

    hi there..i would like some advice from someone who tried the ati radeon hd5470..my notebook is asus x52j series,i3 250m,4gb ram,ubuntu 10.10 and obviously hd radeon 5470.
    so my question was..
    how can i get the grafic card to work on ubuntu like it does on windows 7?
    it's not the same guys,ubuntu 10.10 is wonderful but it seems it doesnt reach windows performance about the grafic card,
    can someone tell me his experience?
    thank you guys

  2. #72
    Join Date
    Dec 2010
    Beans
    8
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: ATI mobility Radeon HD 5470

    hello,

    im using an acer aspire 4745g with ATI mobility radeon hd 5470.

    had the same problem when I installed the "ATI/AMD proprietary FGLRX graphics driver"... gnome interface just doesn't load at all when system is restarted and will user will be stuck in the command line.

    Any advice on how to make the graphics card work?

    Thanks.

  3. #73
    Join Date
    Jan 2008
    Beans
    44

    Re: ATI mobility Radeon HD 5470

    hi guys

    I recently baught a hp dv-6 3150sa laptop which uses ATI mobilty readon HD 5470 graphics9switchable with intel HD GMA). after partitioning i could install ubuntu 10.10 without any problems.

    on first restart ubuntu recomnded ATM/AMD proprietary FGLRX graphics driver which i installed straight away. on my next reboot it showed grub and while on choosing ubuntu it went to the command mode. I had to reinstall ubuntu to get back the genome desktop.

    i havent installed that driver again but my compiz is working. but i can see that computer is heating up quiet a lot compared to windows.

    guys can any one help me telling, have i got the right graphics driver now? or do i have to try re installing the fglrx thing once again.

    tx

  4. #74
    Join Date
    Jul 2010
    Beans
    30

    Re: ATI mobility Radeon HD 5470

    im using ubuntu 10.10 and installed the ATI driver, but when i rebooted my laptap, the gnome desktop disappeared..





  5. #75
    Join Date
    Jan 2008
    Beans
    44

    Re: ATI mobility Radeon HD 5470

    Quote Originally Posted by ansary View Post
    im using ubuntu 10.10 and installed the ATI driver, but when i rebooted my laptap, the gnome desktop disappeared..




    y


    hi i had the same problem. I don know if you have a hybrid graphics one. I did a search on this issue and i cannot find a fix on this one so far. I installed a Uubuntu contro centre and switcheroo programes. the switcheroo is switching the cards manually. but it ssems ATI hasnt got right driver. when u install fglrx straight away what happens is on reboot fglrx takes control which is pointed to intel chip (the low power one) by default. and then blank screen.


    correct me if i am wrong.

    what all i need is the ATI to work on ubuntu i don mind about switching the cards at the moment i can wait

  6. #76
    Join Date
    Jan 2008
    Beans
    44

    Re: ATI mobility Radeon HD 5470

    Quote Originally Posted by crypto2600 View Post
    Hey there guys. I had the exact same problem.
    I got the ASUS K72JR-A1 (amazing laptop). I kept reading the forums until I realized the pattern that was fixing the issue.

    There is something off about Catalyst 10.2 and I could never get it to work. Here are the steps that fixed it (going to get into detail for new users):

    • EDIT: First sudo update-pciids
    • Then go and download Catalyst 10.1 from ati.com. This can be done here - http://support.amd.com/us/gpudownloa...eon_linux.aspx
    • chmod +x ati-driver-installer-10-1-x86.x86_64.run
    • sudo ./ati-driver-installer-10-1-x86.x86_64.run
    • If you don't have jockey installed (the proprietary hardware manager) sudo apt-get install jockey-common.
    • then sudo jockey-text -l which should list your adapter. In my case the first column said "xorg:fglrx"
    • sudo jockey-text -e xorg:fglrx When you restart after this step, you will get an irritating "AMD unsupported hardware" (stupid AMD, can't see a REAL reason they even did that aside from the fact that they got crap for brains).
    • The fix for the watermark is to create a file (e.g. "wm.sh") and paste the quoted text below:


    • Then chmod +x wm.sh
    • Followed by sudo ./wm.sh
    • Restart your box and you are good. Compiz should work at this stage. The Catalyst control center should be functional as well.


    IMPORTANT: After you do this, and if you are using Gnome, your Ethernet (that worked perfectly before) might screw up and there is apparently a fix for it (I use KDE because it's BETTER) and I don't have the problem. If I boot into Gnome, it doesn't work. And let's hope that ATI releases proper mobility support in Catalyst 10.3 as promised. Though Sony and a few other snobby companies have opted out of having their hardware support (for what reason? no fscking clue).

    Link for Ethernet fix for ubuntu was somewhere around the forum and i can't seem to find it again.

    If this works for you, or there are issue, post back here and I'll get the email notification and try to help

    UPDATE: You might have to run sudo update-pciids before you start these steps
    I know this is a quiet old post. still giving a try if any one can give me a helping hand. i am using hp dv6 3150sa with ATI radeon HD 5470 graphics switchable with intel HD GMA. i tried installing the catalyst 10.12 from the site. on giving the last command

    ri@oc:~$ sudo jockey-text -e xorg:fglrx
    [sudo] password for ri

    Searching for available drivers...

    SystemError: installArchives() failed

    I m using ubuntu 10.10 64bit.

    i doublecheked vga swinitching under UCC. when i switch to high perfomance the compiz is disabled and ATI card is not specified. when i switch back to low perfomance intel is dsplayed and compiz is back.

    any help would be appreciated

    regards

  7. #77
    Join Date
    Mar 2010
    Beans
    3

    Re: ATI mobility Radeon HD 5470

    Greetings guys, I have been using Ubuntu for quite a long time and 2 years ago I migrated to Arch and was using it as my primary distro. Recently I bought a new notebook (HP g62 with hybrid graphics Intel and ATi mobility Radeon HD 5470) and have serious issues to get this lappy working on Arch. I've pissed my self for real with this and installed Ubuntu 10.10 to see if I can use it on my brand new lap (cause I just simply hate M*C**S*FT crap). Everything went fine with the installation, I did manage to enable vga_switcheroo but once I installed the proprietary ATi drivers I can't seem too boot my Ubuntu anymore.

    Should I use some opensource drivers like xf86-video-ati or something?

    Please, if someone can help me on this so I can get my brand new lappy working on GNU/Linux ...

    Thanks.

  8. #78
    Join Date
    Jun 2007
    Beans
    11,062

    Re: ATI mobility Radeon HD 5470

    Quote Originally Posted by crunkyboy View Post
    Greetings guys, I have been using Ubuntu for quite a long time and 2 years ago I migrated to Arch and was using it as my primary distro. Recently I bought a new notebook (HP g62 with hybrid graphics Intel and ATi mobility Radeon HD 5470) and have serious issues to get this lappy working on Arch. I've pissed my self for real with this and installed Ubuntu 10.10 to see if I can use it on my brand new lap (cause I just simply hate M*C**S*FT crap). Everything went fine with the installation, I did manage to enable vga_switcheroo but once I installed the proprietary ATi drivers I can't seem too boot my Ubuntu anymore.

    Should I use some opensource drivers like xf86-video-ati or something?

    Please, if someone can help me on this so I can get my brand new lappy working on GNU/Linux ...

    Thanks.
    Either revert to open-source drivers: http://wiki.cchtml.com/index.php/Ubu...talyst.2Ffglrx
    or disable the Intel IGP if your BIOS has such an option.

  9. #79
    Join Date
    Mar 2010
    Beans
    3

    Re: ATI mobility Radeon HD 5470

    Quote Originally Posted by Temüjin View Post
    Either revert to open-source drivers: http://wiki.cchtml.com/index.php/Ubu...talyst.2Ffglrx
    or disable the Intel IGP if your BIOS has such an option.
    Thanks man, I`ll try that as soon as I get home (less than 2 hours). The BIOS does not have any option regarding graphics and HP don't give a f**k about launching an updated ver. of the BIOS. THe latest available poweroff's my screen leds. Anyhow, I hope the open source drivers will work so I can use linux OS on my brand new notebook.

    Another issue that I`m sure it will not work either are the Fn keys, but I can workaround that, just hope that I can poweroff the Ati card so my battery life will be satisfying.

    Respect

  10. #80
    Join Date
    Jun 2007
    Beans
    11,062

    Re: ATI mobility Radeon HD 5470


Page 8 of 10 FirstFirst ... 678910 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •