Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: SSHFS and FUSE can't get working.

  1. #1
    Join Date
    Mar 2010
    Beans
    9

    Angry SSHFS and FUSE can't get working.

    Hi Everyone,

    Sorry if this is in the wrong place i am new to these forums and would like your help if possible.

    I am running Ubuntu 8.10 on a webbynode account and am attempting to create a kind of network drive to another one of my servers running the exact same thing.

    I have followed instructions from many different sites on getting this up and running but still running into problems.

    What i have done.

    Code:
    sudo apt-get install sshfs
    I then added the user to the 'fuse' group
    Code:
    sudo adduser root fuse
    I then tested a connection with the following example
    Code:
    sshfs xxx.xxx.xxx.xxx:/path/to/local /path/to/remote
    Which then produces this
    Code:
    fuse: device not found, try 'modprobe fuse' first
    so i do as it asked
    Code:
    modprobe fuse
    and get this
    Code:
    FATAL: Module fuse not found.
    FATAL: Error running install command for fuse
    Now... sorry for dragging on but i have tried ABSOLUTELY EVERYTHING... including restarting the server stopping it then starting several times to even installing fuse manually without any success.

    can anyone help PLEASE!!!!!!!

    Is there a better way of doing what i need?

    Cheers
    Coops

  2. #2
    Join Date
    Nov 2006
    Location
    Iowa, US
    Beans
    36
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: SSHFS and FUSE can't get working.

    Hello,


    I'm no expert on fuse, but a search of your error produces some interesting results, such as ". Not loading the module automatically is a bug." at

    http://myy.helia.fi/~karte/mount_sshfs.html

    you are typing 'sudo' before your commands?

    The latest version of fuse may give you better results.
    Last edited by gare; March 14th, 2010 at 09:26 AM.

  3. #3
    Join Date
    Mar 2010
    Beans
    9

    Re: SSHFS and FUSE can't get working.

    Hi gare,

    Thanks for the reply. I to checked that article out and it was of no support unfortunately. i have tried installing FUSE manually version 2.8.3 which i think is the latest from what i could find but it still doesn't load it as a module like i require.

    Do you know of any further documentation about installing fuse 2.8.3 manually and getting it to display as a module? i have done this

    Code:
    lsmod
    but it still isn't showing in there...
    If you know of any docs/tuts i will try them also.

    Cheers
    Coops

    Quote Originally Posted by gare View Post
    Hello,


    I'm no expert on fuse, but a search of your error produces some interesting results, such as ". Not loading the module automatically is a bug." at

    http://myy.helia.fi/~karte/mount_sshfs.html

    you are typing 'sudo' before your commands?

    The latest version of fuse may give you better results.

  4. #4
    Join Date
    Mar 2010
    Beans
    9

    Re: SSHFS and FUSE can't get working.

    gare,

    I will redeploy the server again as a fresh install and do the article suggested again from scratch and see if it helps. will post results.

    Cheers
    Coops

  5. #5
    Join Date
    Mar 2010
    Beans
    9

    Re: SSHFS and FUSE can't get working.

    Ok i followed that article and still no luck... this is stupid...

    Surely someone has to of come across this problem and found a fix or something??

  6. #6
    Join Date
    Nov 2006
    Location
    Iowa, US
    Beans
    36
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: SSHFS and FUSE can't get working.

    Hi -

    Googling around for your error suggests a kernel / version incompatibility:

    If you do ‘modprobe fuse’, as they tell you to, and you get:
    modprobe fuse
    FATAL: Module fuse not found.

    That means your running kernel is not the same version as the one you compiled with. You have two options here:
    1) you can upgrade your kernel by typing: yum update kernel
    2) find the source files for the kernel you have running and recompile fuse.

    source: http://crazytoon.com/2008/10/07/sshf...oslinuxredhat/
    Last edited by gare; March 14th, 2010 at 02:28 PM. Reason: found better solution ....

  7. #7
    Join Date
    Feb 2010
    Location
    Silicon Valley
    Beans
    1,898
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: SSHFS and FUSE can't get working.

    Quote Originally Posted by jflcooper View Post
    I will redeploy the server again as a fresh install and do the article suggested again from scratch and see if it helps. will post results.
    Check if FUSE is compiled into the kernel - it may not be a module.

    About a week ago I posted how to figure that out over here: http://ubuntuforums.org/showpost.php...33&postcount=2

    By default, the 9.10 Karmic generic kernel has FUSE compiled in. But the default 8.10 Intrepid server kernel does not. Exactly what kernel are you running?
    Last edited by gmargo; March 14th, 2010 at 02:44 PM.

  8. #8
    Join Date
    Mar 2010
    Beans
    9

    Re: SSHFS and FUSE can't get working.

    Hi gare and gmargo,

    First... Thank you both soooooo much for replying haha

    Ok i checked my kernel version and its 2.6.18-92.1.22.ex15xen

    hope this helps?

    So gare and gmargo if i run sudo update kernel this should fix my problem? and i won't have to install fuse manually yeah?

    Also doing this... will it stuff up my apache and ruby and anything else etc etc?

    Thanks again for all your help.

    Cheers
    Coops

  9. #9
    Join Date
    Feb 2010
    Location
    Silicon Valley
    Beans
    1,898
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: SSHFS and FUSE can't get working.

    Ok i checked my kernel version and its 2.6.18-92.1.22.ex15xen
    I believe that is a CentOS or RHEL kernel version, not an Ubuntu 8.10 kernel version. Is this correct?

  10. #10
    Join Date
    Mar 2010
    Beans
    9

    Re: SSHFS and FUSE can't get working.

    ummm i'm not sure... i am sure its Ubuntu only because when i login to my webbynode account it tells me the server is ubuntu 8.10.


    ohhh i just checked on the net how to check the version so i did this

    Code:
    cat /etc/issue
    and it said...

    Code:
    Ubuntu 8.10 \n \l
    Cheers
    Coops

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •