Page 14 of 20 FirstFirst ... 41213141516 ... LastLast
Results 131 to 140 of 193

Thread: HOWTO: Mount NTFS volumes with write support

  1. #131
    Join Date
    Jun 2006
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Mount NTFS volumes with write support

    i did exactly wot sed in the how-to but i cant write to my ntfs partition this is wot my fstab looks like;

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/sda6       /               ext3    defaults,errors=remount-ro 0       1
    /dev/sda1       /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    /dev/sda5       /media/sda5     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    /dev/sda7       none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/sda1       /media/sda1     ntfs-fuse    auto,gid=1002,umask=0002    0    0
    /dev/sda1       /media/sda1     ntfs-fuse    auto,gid=1002,umask=0002    0    0
    Laptop:
    Acer Aspire 5672WLMi
    Intel Core Duo T2600 (2.16), 15.4" WXGA, ATI MOBILITY Radeon x1400 128M, RAM 4GB DDR II, 250G SATA Windows 7 + Ubuntu 10.04

  2. #132
    Join Date
    Feb 2006
    Location
    Timisoara - Romania
    Beans
    44
    Distro
    Ubuntu 6.06

    Re: HOWTO: Mount NTFS volumes with write support

    haani you forgot to comment out the original lines for the 2 ntfs partitions. those lines are first, so it uses them and when it gets to the ones you actually want they get ignored, as the partitions are already mounted.
    your /etc/fstab should read:
    Code:
     # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/sda6       /               ext3    defaults,errors=remount-ro 0       1
    #/dev/sda1       /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    #/dev/sda5       /media/sda5     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    /dev/sda7       none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/sda1       /media/sda1     ntfs-fuse    auto,gid=1002,umask=0002    0    0
    /dev/sda1       /media/sda1     ntfs-fuse    auto,gid=1002,umask=0002    0    0
    Life goal: Have three kids, name them CTRL, ALT and DEL. If they **** me off, hit 'em twice.

    >> Linux user #417659 <<

  3. #133
    Join Date
    Jun 2006
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Mount NTFS volumes with write support

    ok i commented them out and i restarted the computer, when i go places > computer > downloads (thats my ntfs parition) it says Unable to mount the selected volume mount: according to mtab, /dev/sda5 is already mounted on /media/sda5

    mount failed

    but when i go to system > administrator >disks it tells me that the partitions are already mounted but i still cant write to it!!! and i dont have icons of my ntfs paritions on my desktop..!

    now my fstab looks like this

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/sda6       /               ext3    defaults,errors=remount-ro 0       1
    #/dev/sda1       /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    #/dev/sda5       /media/sda5     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    /dev/sda7       none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/sda1       /media/sda1    ntfs-fuse    auto,gid=1002,umask=0002    0    0
    /dev/sda5       /media/sda5    ntfs-fuse    auto,gid=1002,umask=0002    0    0
    EDIT: Nevermind i think its working now i just made a shortcut for the partitions on the desktop and it writes to it now!
    Last edited by haani; June 17th, 2006 at 03:26 PM.
    Laptop:
    Acer Aspire 5672WLMi
    Intel Core Duo T2600 (2.16), 15.4" WXGA, ATI MOBILITY Radeon x1400 128M, RAM 4GB DDR II, 250G SATA Windows 7 + Ubuntu 10.04

  4. #134
    Join Date
    Jun 2006
    Location
    London
    Beans
    67
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Mount NTFS volumes with write support

    Quote Originally Posted by brallan
    Does anyone know how the autodetect/automount for USB drives works enough to modify it so that ntfs drives are hot-mounted (dynamically) without needing an fstab entry? The problem with fstab is that is really best suited to permanent drives.

    Write support for NTFS is fantastic, a great breakthrough for linux users. thanks to those heroes who reverse engineered and thanks to all who contribute!

    brian
    Certainly regular read only auromounting works OK when I attach my 80Gb LaCie drive using usb. This is in with a vanilla amd64-bit Dapper 6.06 setup.

  5. #135
    Join Date
    May 2005
    Beans
    25

    Re: HOWTO: Mount NTFS volumes with write support

    I just noticed that my music folder on that NTFS disk got emptied; about 10 gigs gone. Not really a problem since I have a backup on DVD, but it scares me a bit.
    I mounted the drive with RW support just a few days ago.. I have booted into win one time since that, and the folder was still there. And I surely havn't deleted it (knowingly) in linux.. however I had a lot write actions in there.
    just a little reminder to make backups until the driver is mature..

  6. #136
    Join Date
    Jun 2006
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Mount NTFS volumes with write support

    how can i mount my usb ntfs harddrive. do u have to change something in mtab?
    Laptop:
    Acer Aspire 5672WLMi
    Intel Core Duo T2600 (2.16), 15.4" WXGA, ATI MOBILITY Radeon x1400 128M, RAM 4GB DDR II, 250G SATA Windows 7 + Ubuntu 10.04

  7. #137
    Join Date
    Jun 2006
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Mount NTFS volumes with write support

    my write support in parition 1 worked fine but after i reinstalled ubuntu (got corruput) i again installed write support, but on partition 1 it says only root can mount /dev/sda1 to /media/sda1??? but my other partition works fine??

    this is wot my fstab looks like

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/sda2 / ext3 defaults,errors=remount-ro 0 1
    #/dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
    #/dev/sda3 /media/sda3 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
    /dev/sda4 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/sda1 /media/sda1 ntfs-fuse auto,gid=1002,umask=0002 0 0
    /dev/sda3 /media/sda3 ntfs-fuse auto,gid=1002,umask=0002 0 0

    Edit:
    i fixed it
    Last edited by haani; June 23rd, 2006 at 04:27 PM.
    Laptop:
    Acer Aspire 5672WLMi
    Intel Core Duo T2600 (2.16), 15.4" WXGA, ATI MOBILITY Radeon x1400 128M, RAM 4GB DDR II, 250G SATA Windows 7 + Ubuntu 10.04

  8. #138
    Join Date
    Jan 2006
    Beans
    32
    Distro
    Ubuntu Breezy 5.10

    Re: HOWTO: Mount NTFS volumes with write support

    Hello, I tried to follow the instructions and when I try to mount my ntfs drive, it says only root can mount. My fstab looks like this:

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/mapper/Ubuntu-root / ext3 defaults,errors=remount-ro 0 1
    /dev/hdb1 /boot ext3 defaults 0 2
    /dev/mapper/Ubuntu-swap_1 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
    /dev/hda1 /media/hda1 ntfs-fuse auto,gid=1001,umask=0002 0 0

    Any help would be appreciated. I am pretty new to linux, and I may have missed something obvious. Thank you.

  9. #139
    Join Date
    Jun 2006
    Beans
    71
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Mount NTFS volumes with write support

    Quote Originally Posted by n00buntu
    Hello, I tried to follow the instructions and when I try to mount my ntfs drive, it says only root can mount. My fstab looks like this:

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/mapper/Ubuntu-root / ext3 defaults,errors=remount-ro 0 1
    /dev/hdb1 /boot ext3 defaults 0 2
    /dev/mapper/Ubuntu-swap_1 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
    /dev/hda1 /media/hda1 ntfs-fuse auto,gid=1001,umask=0002 0 0

    Any help would be appreciated. I am pretty new to linux, and I may have missed something obvious. Thank you.
    m8 u need to go into windows and run scandisk on ur hard drive and than reboot, when u boot into ubuntu ur partition will be mounted than go to /media/hda1 to see ur mounted windows files. you also need to create a shortcut on ur desktop if u want.
    Laptop:
    Acer Aspire 5672WLMi
    Intel Core Duo T2600 (2.16), 15.4" WXGA, ATI MOBILITY Radeon x1400 128M, RAM 4GB DDR II, 250G SATA Windows 7 + Ubuntu 10.04

  10. #140
    Join Date
    Aug 2005
    Location
    USA
    Beans
    369
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Mount NTFS volumes with write support

    i have a wierd problem, im added to the ntfs group and i modded the fstab correctly and it still says that i have insufficient privledges to write changes.... even as root!

    heres my fstab:

    /dev/sdb1 /media/stuff ntfs-fuse auto,gid=1001,umask=0002 0 0

Page 14 of 20 FirstFirst ... 41213141516 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •