Page 13 of 20 FirstFirst ... 31112131415 ... LastLast
Results 121 to 130 of 193

Thread: HOWTO: Mount NTFS volumes with write support

  1. #121
    Join Date
    Mar 2006
    Beans
    81

    Question Why I can't mount my ntfs partition with write support?

    Quote Originally Posted by roytobin
    How to assure the necessary "fuse" module is loaded into the kernel.

    % /sbin/modprobe -l | /bin/grep fuse
    /lib/modules/2.6.15-23-386/kernel/fs/fuse/fuse.ko

    If you don't see this pipe return a line like the one above that contains fuse, you don't yet have fuse loaded into the kernel. As the instructions state, this new dynamically loaded piece of the kernel must be present to mount a 'ntfs-fuse' type filesystem. You need to either a) reboot or b) execute the modeprobe command as root as the original post states.
    Both options, of course, are after you have followed the procedures in the original post already.

    Depending on your font, please know the lowercase "el"
    character (for "list") is passed to the modprobe program in the above example, and the vertical bar symbol (aka pipe symbol) follows.

    The instructions were good enough to get me going on
    % uname -a
    Linux ldt-sdoa-004 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006 i686 GNU/Linux

    Dapper system without any troubles and with gratitude.
    Thanks. I tried typing the command:
    Code:
    chefen@chefen-desktop:~$ /sbin/modprobe -l | /bin/grep fuse
    /lib/modules/2.6.15-23-386/kernel/fs/fuse/fuse.ko
    I have restarded my computer and also been trying to run the command:
    Code:
    chefen@chefen-desktop:~$ sudo modprobe fuse && sudo umount -a && sudo mount -a
    Password:
    umount: /home: enheten är upptagen (couldn't unmount)
    umount: /dev: enheten är upptagen (couldn't unmount)
    umount: /var/run: enheten är upptagen (couldn't unmount)
    umount: /: enheten är upptagen (couldn't unmount)
    But the ntfs partition is not mounted. It was mounted before the changes in fstab:

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda6       /               ext2    defaults,errors=remount-ro 0       1
    /dev/hda8       /home           ext2    defaults        0       2
    /dev/hda5       /media/lagring  vfat    user,utf8,auto,fmask=0111,dmask=0000 0       1
    #/dev/hda5       /media/lagring  vfat    defaults,utf8,umask=007,gid=46 0       1
    /dev/hda1       /media/win      ntfs-fuse    auto,gid=1002,umask=0002    0    0
    #/dev/hda1       /media/win      ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
    /dev/hda7       none            swap    sw              0       0
    /dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
    Code:
        Enhet Start     Början        ****     Block    Id  System
    /dev/hda1   *           1         637     5116671    7  HPFS/NTFS
    /dev/hda2             638       24321   190241730    f  W95 Utökad (LBA)
    /dev/hda5            5228       24321   153372555    b  W95 FAT32
    /dev/hda6             638        1275     5124672   83  Linux
    /dev/hda7            1276        1402     1020096   82  Linux växling / Solaris
    /dev/hda8            1403        5227    30724281   83  Linux
    Code:
    chefen@chefen-desktop:~$ uname -a
    Linux chefen-desktop 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006 i686 GNU/Linux
    And I have installed the packages libntfs8, ntfsprogs and libfuse2 from synaptic since they were not installed on my clean desktop install of dapper?

    I hope I have provided enough information so that we could see what's wrong. Any ideas?

  2. #122
    Join Date
    May 2006
    Beans
    414
    Distro
    Ubuntu 6.10 Edgy

    Re: HOWTO: Mount NTFS volumes with write support

    I followed the guide in the 1st post.

    My /etc/fstab :

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/hda3       /               ext3    defaults,errors=remount-ro 0       1
    /dev/hda4       /home           ext3    defaults        0       2
    #/dev/hda1       /media/hda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0
        1
    /dev/hda2       none            swap    sw              0       0
    /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/hda1    /media/hda1    ntfs-fuse    auto,gid=1001,umask=0002    0    0

    and the output from ls -l /media:
    Code:
    lrwxrwxrwx 1 root root    6 2006-06-09 19:42 cdrom -> cdrom0
    drwxr-xr-x 2 root root 4096 2006-06-09 19:42 cdrom0
    dr-x------ 1 root root 8192 2006-06-08 19:53 hda1
    When I booted up the computer /dev/hda1 was not mounted, and I had to mount it as root, and now I can navigate it as root and open files from it as root, but I cannot even navigate as a normal user.

    When, as root, I try to write a file to the NTFS drive, I get told it is a read-only drive.

    I did remember to add my normal user to the group ntfs, so what have I not managed to do correctly?
    Last edited by Lunar_Lamp; June 15th, 2006 at 10:44 AM.

  3. #123
    Join Date
    Jun 2006
    Beans
    5

    Re: Why I can't mount my ntfs partition with write support?

    Quote Originally Posted by JohanSwe
    Thanks. I tried typing the command:
    [

    I hope I have provided enough information so that we could see what's wrong. Any ideas?

    Only one theory: did you fix the Dapper bug by making the
    hard link? Here is the way my Dapper system stands
    after making this link, which I've read in this thread was not in the
    original version of the HOWTO, but this step is certainly there now.

    Code:
     % /bin/ls -i /usr/bin/ntfsmount /sbin/mount.ntfs-fuse
    1140828 /sbin/mount.ntfs-fuse  1140828 /usr/bin/ntfsmount
    Do not be concerned that your inode numbers differ
    from mine. What is important is that 1) both filesystem entries
    exist in your Dapper system and 2) they are links
    (meaning the inode numbers are identical).

    Caveat: the use of a "hard" link to fix this Dapper bug, and not a
    symbolic link, presumes the directories /sbin and /usr/bin are on the same
    filesystem, probably the root filesystem. For example, if you have /
    mounted on one partition, and /usr mounted on another, you will have to
    use a symbolic link. I don't think this very subtle point is impacting
    anyone on this thread that I saw, but thought I'd mention it. If you have
    no understanding what this paragraph is talking about, just ignore it.

  4. #124
    Join Date
    Mar 2006
    Beans
    81

    Question Re: Why I can't mount my ntfs partition with write support?

    Thank you roytobin. But my system is strange. The files just don't exist but the maps are there?

    Quote Originally Posted by JohanSwe
    The command:
    sudo rm /sbin/mount.ntfs-fuse && sudo ln /usr/bin/ntfsmount /sbin/mount.ntfs-fuse
    didn't work for me. I got the message that /sbin/mount.ntfs-fuse didn't exist.
    In nautilus I then looked for the /usr/bin/ntfsmount file but couldn't find that one neither.


    I have restarted my computer but the ntfs partition was not mounted. Then I checked if I had the mentioned packeges but couldn't found
    # libntfs8
    # ntfsprogs
    # libfuse2
    so I installed them.
    Code:
    chefen@chefen-desktop:~$ sudo rm /sbin/mount.ntfs-fuse && sudo ln /usr/bin/ntfsmount
    Password:
    rm: cannot remove `/sbin/mount.ntfs-fuse': No such file or directory
    chefen@chefen-desktop:~$
    Code:
    chefen@chefen-desktop:~$ /bin/ls -i /usr/bin/ntfsmount /sbin/mount.ntfs-fuse
    /bin/ls: /usr/bin/ntfsmount: No such file or directory
    /bin/ls: /sbin/mount.ntfs-fuse: No such file or directory
    Code:
    chefen@chefen-desktop:~$ dir /
    ATI_LICENSE.TXT  cdrom  home        lib         mnt   root  sys  var
    bin              dev    initrd      lost+found  opt   sbin  tmp  vmlinuz
    boot             etc    initrd.img  media       proc  srv   usr
    
    chefen@chefen-desktop:~$ cd /usr
    chefen@chefen-desktop:/usr$ dir
    bin  games  include  lib  lib64  local  sbin  share  src  X11R6
    chefen@chefen-desktop:/usr$
    How can I fix the dapperbug when the files that I am suppuse to fix isn't there?
    My NTFS are not mounted at all. The catalog in /media/ is just empty. As you can see in my previous post (this is my third) I could mount this partition before editing fstab as sad in the how to

    btw What is the column <pass> for in fstab?
    Last edited by JohanSwe; June 15th, 2006 at 07:36 PM.

  5. #125
    Join Date
    Jun 2006
    Beans
    160
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: HOWTO: Mount NTFS volumes with write support

    Code:
    priestc@priestc-desktop:~$ sudo mount -a
    Couldn't mount device '/dev/hda1': Operation not supported
    Windows did not shut down properly.  Try to mount volume in windows, shut down and try again.
    Mount failed.
    Has anyone else gotten this error? I know fuse is loaded into my kernel because when I mount the ntfs drive as read-ponly, it gives no error. It's only when "rw" is added to the fstab that I get this error. This is weird because this drive is a storage drive only. No windows installation has ever existed on this drive.

    Edit: upon further investigation, it seems that I need ntfs.sys and ntoskrnl.exe, which I actually have, but where do I put them? I can't find this answer anywhere...
    Last edited by nbv4; June 15th, 2006 at 08:55 PM.

  6. #126
    Join Date
    Mar 2006
    Beans
    81

    Re: HOWTO: Mount NTFS volumes with write support

    nbv4: If you have win load it so that the ntfs partition is mounted i win. I got this problem when using gparted and a start up and shut down of win solved it.

  7. #127
    Join Date
    Jun 2006
    Beans
    160
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: HOWTO: Mount NTFS volumes with write support

    Quote Originally Posted by JohanSwe
    nbv4: If you have win load it so that the ntfs partition is mounted i win. I got this problem when using gparted and a start up and shut down of win solved it.
    Could you rephrase this post? I'm not understanding what you mean here. This drive does not have windows installed on it. Mounting it on a computer running windows will not change anything on the drive.

  8. #128
    Join Date
    Mar 2006
    Beans
    81

    Re: HOWTO: Mount NTFS volumes with write support

    I don't know. I just know that I had the same problem, except that I had win on the same partition. But have you been trying to mount your partition in win? Are you sure it doesn't matter?

  9. #129
    Join Date
    Jun 2006
    Beans
    5

    Re: Why I can't mount my ntfs partition with write support?

    Quote Originally Posted by JohanSwe
    Thank you roytobin. But my system is strange. The files just don't exist but the maps are there?

    How can I fix the dapperbug when the files that I am suppuse to fix isn't there?
    My NTFS are not mounted at all. The catalog in /media/ is just empty. As you can see in my previous post (this is my third) I could mount this partition before editing fstab as sad in the how to
    You need to first successfully install the packages outlined in the HOWTO so you *will* have
    all necessary files. If a file doesn't exist, it was deleted accidentally, or never installed. Either
    way, the only solution is to reinstall!

    As for your mount point being empty, this is because it is just that: a mount point, since the
    NTFS filesystem can not be mounted there because you don't have the needed binaries.

    If you were to put your fstab back to call out the standard, read-only filesystem type "ntfs"
    (and all other options on the line!), I suspect you could again mount the filesystem read-only.
    The filesystem type "ntfs" is standard with Dapper installs, I understand. One could say it is built-in.

  10. #130
    Join Date
    Feb 2006
    Location
    Timisoara - Romania
    Beans
    44
    Distro
    Ubuntu 6.06

    Re: Why I can't mount my ntfs partition with write support?

    i've gone through all the posts in this thread, but nobody seems to have had my problem.
    i have 2 ntfs patitions, one is primary and has 10GB, the other logical and has ~230GB. i followed the tutorial and i seem to have done it right, because the primary, smaller partition mounts as it should (including r/w acess), but for the other one i get this when doing "mount -a"
    Code:
    Couldn't mount device '/dev/sda5': Input/output error
    Mount failed.
    my /etc/fstab looks like this
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>       <type>      <options>       <dump>  <pass>
    proc            /proc               proc        defaults        0       0
    /dev/sda6       /                   reiserfs     defaults        0       1
    /dev/sda8       /boot               reiserfs     notail          0       2
    /dev/sda7       /home               reiserfs     defaults        0       2
    #/dev/sda1      /media/winc         ntfs        defaults,nls=utf8,umask=007,gid=46 0       1
    #/dev/sda5      /media/wind         ntfs        defaults,nls=utf8,umask=007,gid=46 0       1
    /dev/sda10    /home/sopo/stuff    reiserfs     defaults    0    2
    /dev/sda9       none                swap        sw              0       0
    /dev/hda        /media/cdrom0       udf,iso9660     user,noauto     0       0
    /dev/sda1     /media/winc         ntfs-fuse     auto,gid=1001,umask=0002          0        0
    /dev/sda5     /media/wind         ntfs-fuse     auto,gid=1001,umask=0002          0        0
    could it have something to do with the unusually large size of the second partition?
    any help would be greatly appreciated, because that's the one i actually need to be able to write on, the small one is just the win install
    Life goal: Have three kids, name them CTRL, ALT and DEL. If they **** me off, hit 'em twice.

    >> Linux user #417659 <<

Page 13 of 20 FirstFirst ... 31112131415 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •