Page 12 of 20 FirstFirst ... 21011121314 ... LastLast
Results 111 to 120 of 193

Thread: HOWTO: Mount NTFS volumes with write support

  1. #111
    Join Date
    Jun 2006
    Beans
    13

    Re: HOWTO: Mount NTFS volumes with write support

    works great for me, yay!! read write with ntfs on linux, what could be better?!

  2. #112
    Join Date
    Jun 2006
    Location
    United States
    Beans
    15
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: Mount NTFS volumes with write support

    When I get to the part about doing
    sudo rm /sbin/mount.ntfs-fuse && sudo ln /usr/bin/ntfsmount /sbin/mount.ntfs-fuse
    I get the following error:
    rm: cannot remove `/sbin/mount.ntfs-fuse': No such file or directory

    Everything worked perfectly up until this point. I tried rebooting anyway just to see if it worked, and of course it didn't.

    Thanks,
    David

  3. #113
    Join Date
    May 2006
    Location
    Uruguaiana, RS,
    Beans
    89
    Distro
    The Feisty Fawn Testing

    Re: HOWTO: Mount NTFS volumes with write support

    Someone could rewritte this article with a more easy understandable text?

    It's not newby friend and I could not do it.

    I'm using Dapper Drake and managed to install all of the apps throught the Synaptic Package Manager. But could not writte on my NTFS partition.

    I kindly ask, also, to whoever writte this future article make it, if possible, in a way that do not need to create a "NTFS writte permission group", but in a way where every user can writte on it.

  4. #114
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: HOWTO: Mount NTFS volumes with write support

    on 6.06
    2Rudy507, i found that there is no /sbin/mount.ntfs-fuse file, but there is /sbin/mount.ntfs-fu. i renamed it and aded "se". after run the
    sudo rm /sbin/mount.ntfs-fuse && sudo ln /usr/bin/ntfsmount /sbin/mount.ntfs-fuse

    now it should work just fine.
    Last edited by wyk; June 8th, 2006 at 10:11 AM.

  5. #115
    Join Date
    Jun 2006
    Beans
    1

    Re: HOWTO: Mount NTFS volumes with write support

    Perhaps a stupid question, but I've got one of them external ntfs disks. Is it possible to make drake use fuse to mount such a disk?

    Cheers

  6. #116
    Join Date
    Jun 2006
    Beans
    158
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: HOWTO: Mount NTFS volumes with write support

    I have all the packages installed and they are all up to date.

    I have fuse listed in the modules file.

    This is my fstab file:

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    /dev/sda2       /               ext3    defaults,errors=remount-ro 0       1
    /dev/sda1       none            swap    sw              0       0
    /dev/hdb        /media/cdrom0   udf,iso9660 user,noauto     0       0
    /dev/hda1    	/media/hda1   	ntfs-fuse    auto,gid=1001,umask=0002    0    0
    the ntfs group has my user name as one of it's members and I made sure the guid is the same.

    I also ran that bugfix posted at the bottom of the OP.

    When I reboot, nothing appears in /media/hda1.

    This very ame drive I had mounted in /stuff using the default ntfs read only support. Even though that entry has been removed from the fstab, /stuff remains part of my filesystem. Whats going on here?

  7. #117
    Join Date
    Mar 2006
    Beans
    81

    Re: HOWTO: Mount NTFS volumes with write support

    Quote Originally Posted by wyk
    on 6.06
    2Rudy507, i found that there is no /sbin/mount.ntfs-fuse file, but there is /sbin/mount.ntfs-fu. i renamed it and aded "se". after run the
    sudo rm /sbin/mount.ntfs-fuse && sudo ln /usr/bin/ntfsmount /sbin/mount.ntfs-fuse

    now it should work just fine.
    The command:
    sudo rm /sbin/mount.ntfs-fuse && sudo ln /usr/bin/ntfsmount /sbin/mount.ntfs-fuse
    didn't work for me. I got the message that /sbin/mount.ntfs-fuse didn't exist.
    In nautilus I then looked for the /usr/bin/ntfsmount file but couldn't find that one neither.

    I have restarted my computer but the ntfs partition was not mounted. Then I checked if I had the mentioned packeges but couldn't found
    # libntfs8
    # ntfsprogs
    # libfuse2
    so I installed them.

    I have a clean dapper install

    All help would be highly aprociated

  8. #118
    Join Date
    Jun 2006
    Beans
    5

    Re: HOWTO: Mount NTFS volumes with write support

    How to assure the necessary "fuse" module is loaded into the kernel.

    % /sbin/modprobe -l | /bin/grep fuse
    /lib/modules/2.6.15-23-386/kernel/fs/fuse/fuse.ko

    If you don't see this pipe return a line like the one above that contains fuse, you don't yet have fuse loaded into the kernel. As the instructions state, this new dynamically loaded piece of the kernel must be present to mount a 'ntfs-fuse' type filesystem. You need to either a) reboot or b) execute the modeprobe command as root as the original post states.
    Both options, of course, are after you have followed the procedures in the original post already.

    Depending on your font, please know the lowercase "el"
    character (for "list") is passed to the modprobe program in the above example, and the vertical bar symbol (aka pipe symbol) follows.

    The instructions were good enough to get me going on
    % uname -a
    Linux ldt-sdoa-004 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006 i686 GNU/Linux

    Dapper system without any troubles and with gratitude.

  9. #119
    Join Date
    Jun 2006
    Beans
    5

    Re: HOWTO: Mount NTFS volumes with write support

    The instructions to add this line to /etc/fstab:
    /dev/hda1 /media/hda1 ntfs-fuse auto,gid=1002,umask=0002 0 0

    presume /dev/hda1 has a ntfs filesystem. Certainly on
    my setup, this was the case, but I don't know if it is true for everybody. Perhaps it is the case for Windows OSes that use the NTFS filesystem *must* be on the first partition?

    For me, upon install, Dapper recognized that /dev/hda1 had a valid ntfs filesystem on it, and it automatically put this into the /etc/fstab:

    /dev/hda1 /media/hda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

    Note the filesystem type is "ntfs" and not "ntfs-fuse"
    This "ntfs" calls out the standard, read-only driver to access the Windows NTFS filesystem. This is the driver you want to replace with the "fuse" one this thread is about so you can get write access in addition to read access.

    The instructions would perhaps be a bit more general and precise if it said to change the existing entry to mount the ntfs filesystem to be as described, not unconditionally add it to /etc/fstab.

    While obvious to veterans, may not be so for newbies who
    are letter-for-letter following the instructions without depth of understanding regarding block devices, mount points, drivers, etc.
    Last edited by roytobin; June 17th, 2006 at 07:48 PM.

  10. #120
    Join Date
    Jun 2006
    Beans
    158
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: HOWTO: Mount NTFS volumes with write support

    Quote Originally Posted by roytobin
    The instructions to add this line to /etc/fstab:
    /dev/hda1 /media/hda1 ntfs-fuse auto,gid=1002,umask=0002 0 0

    presume /dev/hda1 has a ntfs filesystem. Certainly on
    my setup, this was the case, but I don't know if it is true for everybody. Perhaps it is the case for Windows OSes that use the NTFS filesystem *must* be on the first partition?

    For me, upon install, Dapper recognized that /dev/hda1 had a valid ntfs filesystem on it, and it automatically put this into the /etc/fstab:

    /dev/hda1 /media/hda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1

    Note the filesystem type is "ntfs" and not "ntfs-fuse"
    This "ntfs" calls out the standard, read-only driver to access the Windows NTFS filesystem. This is the driver you want to replace with the "fuse" one this thread is about so you can get write access in addition to read access.

    The instructions would perhaps be a bit more general and precise if it said to *change* the existing entry to mount the ntfs filesystem to be as described, not unconditionally *add* it to /etc/fstab.

    While obvious to veterans, may not be so for newbies who
    are letter-for-letter following the instructions without depth of understanding regarding block devices, mount points, drivers, etc.
    I totally agree. I think that may have been my problem. I had a line in my fstab for the read-only ntfs, which I had to remove in order to replace it with the one listed in the howto. If I had been thinking, I'd have backed up my fstab, as there were more than a few differences (that I can vaugely recall) between the existing one and the new one. Now everything is all messed up. I wish I had known to just change "ntfs" to "ntfs-fuse", then maybe it would have worked...

Page 12 of 20 FirstFirst ... 21011121314 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •