Results 1 to 7 of 7

Thread: how to enable/disable wireless in command line

  1. #1
    Join Date
    Mar 2008
    Location
    India
    Beans
    54
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question how to enable/disable wireless in command line

    in ubuntu by right clicking the network manager applet and by toggling enable wireless i can switch on/off wireless but how to do it using command line.
    "The box said windows xp or better so i installed Linux"
    my blog

  2. #2
    Join Date
    May 2009
    Beans
    113

    Re: how to enable/disable wireless in command line

    I think the command you seek is:

    Code:
    ifconfig ra0 down
    to bring it back up:

    Code:
    ifconfig ra0 up

  3. #3
    Join Date
    Dec 2009
    Beans
    103

    Re: how to enable/disable wireless in command line

    remember to correctly replace ra0 with your interface (ath0 wlan0 eth0 eth1 etc etc etc!)
    http://blog.shymbolic.com <-----made myself a blog now!

  4. #4
    Join Date
    Mar 2008
    Location
    India
    Beans
    54
    Distro
    Ubuntu 10.04 Lucid Lynx

    Smile Re: how to enable/disable wireless in command line

    replacing it with eth1 worked thanks
    "The box said windows xp or better so i installed Linux"
    my blog

  5. #5
    Join Date
    Apr 2009
    Location
    United States
    Beans
    308
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: how to enable/disable wireless in command line

    How can I run this in a script at boot and shutdown (as it seems to require a sudo permission)? I am having eth0 problems when I boot, and I suspect it is because of the enabled eth0 connection at shutdown (I am running x86 11.04).

    Thanks in advance.

  6. #6
    Join Date
    May 2006
    Location
    Boston
    Beans
    1,909
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: how to enable/disable wireless in command line

    Quote Originally Posted by ngrieb View Post
    How can I run this in a script at boot and shutdown (as it seems to require a sudo permission)? I am having eth0 problems when I boot, and I suspect it is because of the enabled eth0 connection at shutdown (I am running x86 11.04).

    Thanks in advance.
    this should help:
    http://ubuntuforums.org/showthread.php?t=1838337

    blog
    Donations BTC : 12FwoB7uAM5FnweykpR1AEEDVFaTLTYFkS
    DOUBLEPLUSGOOD!!

  7. #7
    Join Date
    Feb 2012
    Beans
    139

    Re: how to enable/disable wireless in command line

    What if this is not working, running lubuntu 11.10.
    1f u c4n r34d th1s u r34lly n33d t0 g37 l41d

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •