Results 1 to 3 of 3

Thread: cannot update gzip 1.3.12-8ubuntu1 to 1.1

  1. #1
    Join Date
    Mar 2010
    Beans
    5

    cannot update gzip 1.3.12-8ubuntu1 to 1.1

    Hi,

    I have weird problem that I couldn't find anything about on the internet: When I try to do the said update in Karmic, I get this error:

    Preparing to replace gzip 1.3.12-8ubuntu1 (using .../gzip_1.3.12-8ubuntu1.1_amd64.deb) ...
    install-info: No dir file specified; try --help for more information.
    dpkg: warning: old pre-removal script returned error exit status 1
    dpkg - trying script from the new package instead ...
    dpkg: error processing /var/cache/apt/archives/gzip_1.3.12-8ubuntu1.1_amd64.deb (--unpack):
    there is no script in the new version of the package - giving up
    Errors were encountered while processing:
    /var/cache/apt/archives/gzip_1.3.12-8ubuntu1.1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:

    Upgrading other packages however works fine. What can be the cause of this? How can I fix it?

    Btw: I already reported this as a bug, but no reactions so far.

    https://bugs.launchpad.net/bugs/515658

    Many thanks!
    Last edited by Walter Bux; March 7th, 2010 at 02:30 AM. Reason: Link to official bug report added.

  2. #2
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: cannot update gzip 1.3.12-8ubuntu1 to 1.1

    Quote Originally Posted by Walter Bux View Post
    Hi,

    I have weird problem that I couldn't find anything about on the internet: When I try to do the said update in Karmic, I get this error:

    Preparing to replace gzip 1.3.12-8ubuntu1 (using .../gzip_1.3.12-8ubuntu1.1_amd64.deb) ...
    install-info: No dir file specified; try --help for more information.
    dpkg: warning: old pre-removal script returned error exit status 1
    dpkg - trying script from the new package instead ...
    dpkg: error processing /var/cache/apt/archives/gzip_1.3.12-8ubuntu1.1_amd64.deb (--unpack):
    there is no script in the new version of the package - giving up
    Errors were encountered while processing:
    /var/cache/apt/archives/gzip_1.3.12-8ubuntu1.1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:

    Upgrading other packages however works fine. What can be the cause of this? How can I fix it?
    .........
    Delete the probably corrupted package from your /var/cache/apt/archives folder and go through the install process again.

    There is nothing wrong at all with that package, I just reinstalled it on my system.
    Last edited by dcstar; March 7th, 2010 at 05:26 AM.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  3. #3
    Join Date
    Mar 2010
    Beans
    5

    Re: cannot update gzip 1.3.12-8ubuntu1 to 1.1

    I have my system configured so it doesn't keep a package archive, i.e. I cannot delete any corrupted package because it is not there.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •